OpenWrt Forum Archive

Topic: Linksys EA4500 dual-firmaware issue

The content of this topic has been archived on 5 May 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Hi, I have recently bought a second hand EA4500, and when I tried to install openwrt something failed.
I downloaded Chaos Calmer from … d/generic/
At first, after flash the router trhough linksys update sofware, the router hang out and didn nothing, tried ssh and telnet but nothing, the switch lights were off and the front light (cisco logo) was blinking.
I wait some minutes thinking that needed some moment to reboot the openwrt firmware. After that power off and reboot.

The dual firmware thing did the magic and the router worked perfect, but with linksys firmware.
I not sure of try again before I am sure that I will be able of make it works.

Now this is the matter:
Some times it seems that boots the other partition that could not be flashed properly and again the switch lights are off and the front light (cisco logo) is blinking, but the router does not work, and I have to power off and on again.

A) Is possible to manage both partition so I can restore again both?

B) If I try to install openwrt again, will be flashed the partition that I tried at first, or there is some risk of flashing the partition that have the linksys firmware and brick the router?

I have googled about manage the dual firmware but didn't find something easy to do it.


jmcoca wrote:

Hi, I have recently bought a second hand EA4500, and when I tried to install openwrt something failed.
I downloaded Chaos Calmer from … d/generic/

are you certain you have downloaded chaos calmer?  the link you have provided is for the dd trunk.

as far as i know, the ea4500 has dual firmware partitions:  the working and the backup partition.  the ea4500 normally boots from a working partition.  firmware flashes occur on the backup partition and the ea4500 shall reboot from the backup partition following from a firmware flash.  the backup partition becomes the working partition when the reboot was successful.  the former working partition becomes the new backup partition.

in the event of a bad flash, the router shall obviously fail to reboot from the backup partition.  i believe after three consecutive failed reboots, the router then reverts back to its working partition and reboots.  based on this understanding, the ea4500 shall always have a partition with a working firmware.  to ensure you have both partitions with working firmware, flash the ea4500 with a known working firmware twice.

Thaks for your help, following your advice I flashed the router twice and seems works fine.

But now about the link I wrote before:

That link it's in the page of EA4500 router:, and I thought it was newest version of Chaos Calmer firmware. As you can see I am not very expertise with this, but in that page says that is a "Prebuilt trunk snapshots".

I am going to try again but renaming the file:

"The factory.bin image can be flashed from the Linksys interface. Upgrading between OpenWrt images is done with the sysupgrade.tar image. If firmware installation fails on linksys firmware, try renaming the file to .img extension. "

But before try: would you know if that link that I am using it is correct or I have to download a different release.


trunk snapshots are designated driver builds.  if you have flashed the ea4500 with a trunk build, then your router is running on designated driver.  you should be able to validate the firmware version when you log into your router under "status."

a side note:  i think it's better for you to stay with the trunk builds so the router can accept future designated driver builds.  i believe the developers have renamed the router from linksys ea4500 (chaos calmer builds) to kirkwood viper with trunk (designated driver) builds.  an ea4500 with a chaos calmer build will not be able to accept a designated driver build due to the router name change.

The discussion might have continued from here.