Hello,
I'm trying to use my WR941ND V3 with IPTV. I have Chaos Calmer 15.05 version of OpenWrt installed. The end result that I'm looking is:
I connect my fiber interface to WAN port, LAN 1 to 3 ports should be used for internet, lan 4 port should be used for IPTV. To reach this here is what i need to do:
Create a Vlan to LAN 1, 2, 3 and another Vlan to Lan4 port. Then switch these Vlan with these tagged / untagged modes:
Here is what i have so far:
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fdc0:5daf:6739::/48'
config interface 'eth'
option ifname 'eth0'
option mtu '1504'
option proto 'none'
config interface 'lan'
option ifname 'lan1 lan2 lan3'
option force_link '1'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'
config interface 'iptv'
option proto 'static'
option ipaddr '10.10.99.99'
option netmask '255.255.0.0'
option gateway '10.218.255.254'
option defaultroute '0'
option peerdns '0'
option type 'bridge'
option _orig_ifname 'lan4.6'
option _orig_bridge 'true'
option ifname 'lan4 lan4.6'
config interface 'wan'
option ifname 'wan'
option proto 'dhcp'
Now i need to tag CPU to iptv interface, but i have no idea how. Actually i would need to switch iptv to make this work.
Would any1 be able to help me with this?
(Last edited by edv.melys on 11 Feb 2016, 12:31)