OpenWrt Forum Archive

Topic: D-Link DIR-601 B1 flashing not working

The content of this topic has been archived on 1 May 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Apologies if this has already been answered somewhere - I searched using Google, but couldn't find a topic that covered what I'm seeing.

I'm experienced with OpenWRT - have used it for years, and currently have it running on a WNDR3800.  I used to build my own for a DIR-825 B1, and use an x86 build in my virtual machine lab.

But this has me stumped.

Following the instructions at using the openwrt-15.05-ar71xx-generic-dir-601-b1-squashfs-factory.bin image (md5sum checks out OK for it).  I'm flashing through the recovery mode web interface using Chrome on Linux (I don't have any Windows systems).

The upload proceeds, reaches 100% and says the upgrade was successful, but the router doesn't reboot on its own.  If I reboot it myself, I end up back in the stock D-Link firmware with the configuration I'd been using.

Any ideas about what I need to do to get this device flashed with Chaos Calmer?

I had a look through that thread, but didn't see anything relating to the issue I'm having.

I just tried flashing the NA image as well (since the router reports the current firmware is 2.01NA), but still no luck getting the flashed firmware to actually work.

The discussion might have continued from here.