OpenWrt Forum Archive

Topic: TP-WDR4300 back to Firmware - Bricked now?

The content of this topic has been archived on 16 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Hi, I had to flash back to the original firmware on my router . Unfortunately I could not find matching firmware or cut the original (.bin) with WinSCP to get the " boot " out . Then I was so stupid and have loaded from  DD - WRT the WDR4300 - Webrevert and tried to flash it . With the bad result that now only the left Power lamp is lit and quite right arrows .
The router is no longer reachable , ipconfig spits only 169.254.71.128 from me .
Can i do know anythink for the router to get him back in life?? If yes how? Thank you very much !

P.s. sorry for my englisch, i still try to teach it wink

Hello and thanks.
Unfortunately I do not speak Russian or significantly worse than English . : D
How do I know at all whether the router is bricked ?

- set IP Your PC 192.168.1.2
- Your router go to safefaile mode (Failsafe mode

Power up your router. When the 'SYS' light (asterisk symbol right of the power light) starts to blink, immediately push the WPS/Reset button on the back-left of the router for a short time (>1 sec). The 'SYS' light should now start to blink very fast.

On a TL-WDR4300 Ver 1.6 and Barrier Breaker Bleeding Edge, r39211, the above instructions were not terribly successful. The only way that I was able to get the router into failsafe mode was to quickly and repeatedly press the WPS/Reset button starting before the front panel "star" LED started flashing. When that LED finally lit, it appeared to go directly into the rapid-flashing "failsafe" indication. If the WPS LED lights (rightmost, "yin-yang arrows"), it may be that you started clicking the button a little early in the boot sequence.), use cmd command ping 192.168.1.1 if response is OK.
-SSH to your router, and use mini-web or mongoose for web download then copy your firmware Openwrt...sysgrade.bin file to /tmp/ directory in router.
- run mtd -r write /tmp/yourfirmware.bin firmware
link help: https://forum.openwrt.org/viewtopic.php … 56#p182356
and https://wiki.openwrt.org/toh/tp-link/tl-wdr4300.

(Last edited by dktn on 9 Mar 2016, 11:42)

Ok, i will try your Information.
Yesterday i didn´t get a ping on 192.168.1.1 (only 169.254.71.128)

I think my "sys" light didn´t blink or lit, only Power (Left) and YingYang on the right.
When i plug in an Lan kabel, this Symbol lit even.

(Last edited by rukain on 10 Mar 2016, 09:59)

run cmd command: ping 192.168.1.1 -t, goto network set IP of your PC: 192.168.1.2  subnet mask:255.255.255.0, gateway 192.168.1.1
seeing on 'cmd' windows does router response when you setting router back to safefail.

It seems that i cant got back to safefail...

Set the Ip to 192.168.1.2 and ping 192.168.1.1 can not connect to the host.

The "Sys" light doesnt blink, when i start my router for one second all lights blink up, then only the power light lit, if i plugin a patch cabel the light for Lan 1 starts to blink.

When i start the router with holding the reset button for 3 seconds (to go in the safefail) the YingYang light is on...

I think now it is a expensive doorstop.

Have you tried TFTP as linked in the first response post?

i try it in this way:
https://www.youtube.com/watch?v=1hWT35w6sVI

The TFTP LogViewer shows me this message:

Connection received from 192.168.0.86 on port 2406 [09/03 20:37:16.183]
Error : connect returns 10061: <Es konnte keine Verbindung hergestellt werden, da der Zielcomputer die Verbindung verweigerte.> [09/03 20:37:16.184]
Connection received from 192.168.0.86 on port 2406 [09/03 20:37:21.183]
Error : connect returns 10061: <Es konnte keine Verbindung hergestellt werden, da der Zielcomputer die Verbindung verweigerte.> [09/03 20:37:21.184]
Connection received from 192.168.0.86 on port 2406 [09/03 20:37:26.182]
Error : connect returns 10061: <Es konnte keine Verbindung hergestellt werden, da der Zielcomputer die Verbindung verweigerte.> [09/03 20:37:26.183]

translate:
< There could be no connection Made Will , because the target machine die connection refused . >

So the device is requesting to connect and your tftp/server machine is refusing the connection? Firewall?

i shut all firewall (Windows) down, but it still doesnt work.
here Screenshot from windump:
http://fs5.directupload.net/images/160309/rgm4np8w.jpg

IP of tftp/server machine? 192.168.0.66

Hi,

IP 192.168.0.86.1540 > Sandra-PC.69: 44 RRQ "wdr4300v1_tp_recovery.bin" octet timeout 5

That's your bricked router!  It's alive!  It's on IP address 192.168.0.86 connecting from port 1540 (isn't that right?).

It's trying to connect to the tftp port (69) on your PC to request a file named wdr4300v1_tp_recovery.bin, but it's failing with a timeout.

1.) Have you set your laptop Ethernet IP address to 192.168.0.66?  I think you have because, if I understand, it wouldn't request the file with that name unless it found that exact IP address.  In other words, the static IP address of the router is always 192.168.0.86 and your laptop's static IP address must always be 192.168.0.66.

2.) Have you downloaded and installed a TFTP server program like tftpd32 or tftpd64?  You need to download and install such a server, then put the firmware file to restore in the folder where the TFTP server is installed (its root directory).  The file needs to be renamed to wdr4300v1_tp_recovery.bin.  Then start the TFTP server program on your laptop.

3.) Then fire up the router the same way you did to get this screen dump which you just posted.  It will take a little while to upload the firmware, flash it, reinitialize and zero out NVRAM, then reboot.  This may take 3 or 4 or 5 minutes.  Please be patient..

Once it reboots it should have the stock firmware on it that you uploaded.  If you go to the device's webpage (either 192.168.0.1 or 192.168.1.1) and don't see this restored firmware, be sure to clear your browser's cache completely.  Sometimes stuff is left over and doesn't show you the real router webpage.

Again, HTH.  Seeing these requests means you should be able to succeed smile

Clemmitt

Yes, network setting of PC is 192.168.0.66...
in TFTP this service interface is selected, but after some time it will
automatically change to 127.0.0.1... but until then nothing happened

@ cmsigler, here some pictures i think i anwsers your questions at all...

Network
http://fs5.directupload.net/images/160309/7o4l2ska.jpg

File
http://fs5.directupload.net/images/160309/3934j8sd.jpg

TFTP32
http://fs5.directupload.net/images/160309/5obnnhbu.jpg

(Last edited by rukain on 9 Mar 2016, 23:46)

As best I can tell, you have things set up correctly.  But I could be wrong and there could be a minor problem on your end.

Are you sure the tftpd32 server is running?  Is there a "Start service" button you have to click?  I've never used it....

If it doesn't work the first time, you may have to try the procedure many times for it to connect and upload the firmware.  Wish I could be of more assistance... neutral

Clemmitt

(Last edited by cmsigler on 10 Mar 2016, 00:16)

From your windump the device is doing a RRQ to Sandra-PC? What is the IP of this machine and where did the device get that name? What is meant by your comment that the PC goes from an assigned IP to loopback? Are you able to prove your TFTP server in any way; another machine perhaps?

Hi,

Sandra-PC is my machine and the IP is set to 192.168.0.66....
If TFTP (32 bit Version) runs correctly or not, i cant check this because i only had one PC at this times.
Is there any way to check it?

@ cmsigler, did you think my router isn´t dead because i get this feedback:

IP 192.168.0.86.1540 > Sandra-PC.69: 44 RRQ "wdr4300v1_tp_recovery.bin" octet timeout 5

whence come this number: 192.168.0.86

(Last edited by rukain on 10 Mar 2016, 09:54)

what is router IP ? use Angry IP Scanner program to find it.
set IP on your getway, then ping to your router.

Hi,

rukain wrote:

@ cmsigler, did you think my router isn´t dead because i get this feedback:
whence come this number: 192.168.0.86

The address ending in .86 is the address of your router, which is sending connection requests to your PC.  As you said, the address of the PC is the one ending in .66.

The router is sending requests to the TFTP program asking to upload the file with name wdr4300v1_tp_recovery.bin.  This means the router is doing what it is supposed to.  Assuming the TFTP server program is working correctly, I'm not sure why it's not flashing because I'm not right there with you to see.  Sorry I can't be of more help sad

Clemmitt

The file is named incorrectly? Look at the name in RRQ line, and what is in your directory.

@ anomeome, i think the name is correct.

i gues the problem is, that the router (192.168.0.86) can not connect, that is the message from TFTP Server Log View...

@ dktn, Angry IP Scan brings no result. it is to bad...

Does it make sense, to try it with a serial cable?
Or meaningless since this trial here not works...

Hi,

Makes perfect sense!  If TFTP refuses to work serial recovery will work, many do so successfully on these forum boards -- provided you solder very carefully and hook it up with a USB to TTL cable correctly (or directly to an old-fashioned serial port).  I hope from the device page for the TL-WDR4300 it's easy to figure out how to solder pins or a pad for serial connection.

I've recovered via TFTP but never soldered a serial port connection.  That's the final frontier for me wink  Good luck!

Clemmitt

Keep in mind that there is a very good chance (probably close to 100%) that your initial flashing with an oversized (including u-boot) vendor firmware has overwritten your router's ART partition (which contains the calibration data for your router's wlan cards), without ART (and ART is specific to each individual device) you'll lose wlan/ AP support (even if you can restore wired functionality).

The discussion might have continued from here.