OpenWrt Forum Archive

Topic: Bootloader/Image for a DLink DWL-2100AP

The content of this topic has been archived between 26 Mar 2018 and 5 May 2018. Unfortunately there are posts – most likely complete pages – missing.

bitbucket wrote:

You can add support for your flash IC in RedBoot (described on wiki), or try to use a bootloader from this page. If you have working JTAG cable - you can't brick the device. You need firmware with lzma decompression.

I have tried these bootloaders, but it doesn't work.
I will try to add support of my flash chip.
But I don't have wiggler cable for backup flash data.
And I don't know structure of flash chip.
Can I get this info with wiggler cable?

(Last edited by antoxa on 18 Mar 2009, 06:14)

antoxa wrote:

I have tried these bootloaders, but it doesn't work.

They can't worc because they are loaded from net, not from flash.

antoxa wrote:

And I don't know structure of flash chip.
Can I get this info with wiggler cable?

Flash look like this: <bootloader> <kernel> <rootfs> <FIS dir> <Redboot config> <Platform config>

You can make full backup using loaded from network linux kernel. To get contents of all flash you can make one bug flash partition (for all flash) from kernel command line.

People can you help me plz.

I have D-Link Access Point DWL-3200AP with bad flash memory.
I need to download bootloader from it.
After installing cygwin, jtag with openwince headers and running command detect i have this

jtag> cable WRIGGLER parallel 0x378
Unknown connection type: WRIGGLER
jtag> cable WIGGLER parallel 0x378
Unknown connection type: WIGGLER
jtag> cable parallel 0x378 WIGGLER
Initializing Macraigor Wiggler JTAG Cable on parallel port at 0x378
jtag> detect
IR length: 5
Chain length: 1
Device Id: 00000000000000000000000000000001
  Unknown manufacturer!
chain.c(110) Part 0 without active instruction
chain.c(133) Part 0 without active instruction
chain.c(110) Part 0 without active instruction

Processor of AP is Atheros AR2313A, flash chip is Atmel AT49BV322A.

How I can read/write flash with jtag and what address of bootloader starts with?


I have some trouble... I have dlink dwl-2100ap rev.A4 with flash s29al032d
With topic soft i compiled redboot. It's work, but i can not     understand next error

+.. Resetting.
RedBoot startup
Could not find valid MAC address for enet1.  Using default!
Ethernet eth1: MAC address 00:XX:f0:XX:XX:XX
IP:, Gateway:
Default server:, DNS server IP:

RedBoot(tm) bootstrap and debug environment [ROM]
Non-certified release, version v2_0 - built 23:16:43, May 22 2009
With changes made by Waldeck Schutzer <>

Copyright (C) 2000, 2001, 2002, Red Hat, Inc.

RAM: 0x80000400-0x80800000, 0x80000400-0x807e1000 available
FLASH: 0xbfc00000 - 0xbffe0000, 62 blocks of 0x00010000 bytes each.

RedBoot> fis list
Name              FLASH addr  Mem addr    Length      Entry point
RedBoot           0xBFC00000  0xBFC00000  0x00050000  0x00000000
RedBoot config    0xBFFC0000  0xBFFC0000  0x00001000  0x00000000
FIS directory     0xBFFD0000  0xBFFD0000  0x00010000  0x00000000
linux             0xBFC50000  0x80041000  0x00100000  0x80041000
Rootfs            0xBFD50000  0x80041000  0x00140000  0x00000000

RedBoot> fis load -d linux
Image loaded from 0x80041000-0x80290086

RedBoot> exec
Now booting linux kernel:
Base address 0x80080000 Entry 0x80041000
Cmdline :
Linux version (ramponis@ramponis-desktop) (gcc version 4.1.2) #2 Thu Apr 17 13:37:48 CEST 2008
CPU revision is: 0001800a
Determined physical RAM map:
memory: 01000000 @ 00000000 (usable)
Initrd not found or empty - disabling initrd
Built 1 zonelists.  Total pages: 4064
Kernel command line: console=ttyS0,9600 rootfstype=squashfs,jffs2 init=/etc/preinit
Primary instruction cache 16kB, physically tagged, 4-way, linesize 16 bytes.
Primary data cache 16kB, 4-way, linesize 16 bytes.
Synthesized TLB refill handler (20 instructions).
Synthesized TLB load handler fastpath (32 instructions).
Synthesized TLB store handler fastpath (32 instructions).
Synthesized TLB modify handler fastpath (31 instructions).
PID hash table entries: 64 (order: 6, 256 bytes)
Using 90.000 MHz high precision timer.
Dentry cache hash table entries: 2048 (order: 1, 8192 bytes)
Inode-cache hash table entries: 1024 (order: 0, 4096 bytes)
Memory: 13504k/16384k available (1955k kernel code, 2880k reserved, 292k data, 116k init, 0k highmem)
Mount-cache hash table entries: 512
NET: Registered protocol family 16
WARNING: No board configuration data found!
CPU 0 Unable to handle kernel paging request at virtual address 00000066, epc == 801445a4, ra == 802785b0
Cpu 0
$ 0   : 00000000 1000c000 00000000 80290000
$ 4   : 00000066 80239c6c 00000006 00000000
$ 8   : 80264990 80260000 802a0000 802a0000
$12   : 802a0000 00000e00 80298d04 00000000
$16   : 00000066 8028ef7c 00000000 00000000
$20   : 00000000 00000000 00000000 00000000
$24   : 00000000 00000000
$28   : 802ec000 802edf58 00000000 802785b0
Hi    : 00000059
Lo    : b3d43000
epc   : 801445a4     Not tainted
ra    : 802785b0 Status: 1000c003    KERNEL EXL IE
Cause : 00801008
BadVA : 00000066
PrId  : 0001800a
Modules linked in:
Process swapper (pid: 1, threadinfo=802ec000, task=802ebbe8)
Stack : 00000000 00000000 80287d50 80287bac 80290000 8028ef7c 00000000 00000000
        80274664 80274664 00000000 00000000 00000000 00000000 00000000 00000000
        00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
        00000000 00000000 00000000 80044ff8 1000c003 00000000 00000000 00000000
        00000000 80044fe8 73797376 69706300 f8414000 99d90010 08210000 10148000
Call Trace:[<80287d50>][<80287bac>][<80274664>][<80274664>][<80044ff8>][<80044fe8>]

Code: 27bd0020  08051170  00000000 <90830000> 90a20000  00621023  14400005  24840001  24a50001
Kernel panic - not syncing: Attempted to kill init!

I need help!

The problem is...

WARNING: No board configuration data found!

I had a 2100AP with same problem.
To solve it...

I have reflashed the 2100AP with the full flash (original bootloader and firmware)
You can find here:

It takes al lot of time

Then i have resetted the mac-address, to do this:

- Connect with telnet to the 2100AP
- do the login
- type "alpha"
- and the password "sdd21234"
- type the command SET MAC ALL 00:XX:XX:XX:XX:XX (you mac-address)
- reboot


- with jtag, reflash only the bootloader (redboot)
- fis init -f
- do the fconfig
- reload the openwrt

(Last edited by ramponis on 3 Jun 2009, 18:52)

I successfully install OpenWRT on 2100AP rev A3, using ramponis excellent manual (good what i have some knowledge in Latin) wink
ramponis, thank you for your work!

but,  firmware from work good, but, unfortunately, 8.09.1 firmware stopped on boot.

ar531x: Registering GPIODEV device
squashfs: version 3.0 (2006/03/15) Phillip Lougher
Registering mini_fo version $Id$
JFFS2 version 2.2. (NAND) (SUMMARY)  ?L 2001-2006 Red Hat, Inc.
Reserved instruction in kernel code[#1]:
Cpu 0
$ 0   : 00000000 0063012c 00000000 00000000
$ 4   : 80280000 00000000 00000000 80280000
$ 8   : 00989680 00000000 80280000 00000000
$12   : ffffffff c4b41806 80280000 00000a00
$16   : 0000002c 00000000 00989680 00000000
$20   : 00000000 000dbba0 802cbde8 0193f097
$24   : 00000000 00008000
$28   : 802ca000 802cbc08 80248990 8007ff7c
Hi    : 00000000
Lo    : 00000000
epc   : 8008003c     Not tainted
ra    : 8007ff7c Status: 10004002    KERNEL EXL
Cause : 30801028
PrId  : 0001800a (MIPS 4Kc)
Modules linked in:
Process swapper (pid: 1, threadinfo=802ca000, task=802cc000, tls=00000000)
Stack : 802cbd18 800bf5e0 802bb005 00000000 80248990 80250000 03b9aca0 00057f43
        8007eeb4 00000072 80280000 30e03500 802cbc80 00000078 802cbc88 0000007a
        80280000 80280e90 00000000 00322273 00000007 80250000 80280000 80280e90
        00000001 01942e2d 802cbde8 0193f097 7fdb60e0 8006c30c 00000002 00989680
        00000001 01942e2d 00000006 00989680 80083410 8008325c 7fdb60e0 8008348c
Call Trace:[<800bf5e0>][<8007eeb4>][<8006c30c>][<80083410>][<8008325c>][<8008348c>][<8007b534>][<80082f28>][<8007c230>][<8007c0cc>][<8007c294>][<8007c0cc>][<80094cf0>][<8005ae84>][<80049614>][<80049614>][<80041ad0>][<80089e00>][<8006be10>][<8008b30c>][<80067328>][<80042148>][<8006740c>][<8004197c>][<8004197c>][<8004197c>][<800432e4>][<800432e4>][<8016489c>][<8015dc50>][<80061d4c>][<800623dc>][<800623f4>][<800623f4>][<800b8dd0>][<80102eb4>][<800b3edc>][<800b3e18>][<80261544>][<8006244c>][<8006244c>][<8026155c>][<800cef8c>][<802613c8>][<802613b4>][<80261544>][<80255618>][<8025557c>][<8004526c>][<8004525c>]

Code: 30783031  30303030  3030006d <6f646574> 74793000  302c6e2c  382c312c  68770065  74686164
Kernel panic - not syncing: Fatal exception in interrupt

Anybody have similar problems?

ramponis wrote:

No problem with ver. 8.09 … rt8.09.rar

Tested on a Rev A3 and A4

Thank you.
Sucessfully installed - but i can't manage bridge between lan and wifi.
I use default configuration (eth0 and wifi0 in bridge mode) but it not worked.
Interestly, wifi client can ping AP, AP can ping all wireline network, but AP can't ping wifi client.

Same problem with Kamikaze 7.06 (openwrt.rar from ramponis site).

Latest trunk (r16540) boot successfully on DLink 2100AP.
Bridge still not working. ;(

I finally fix bridge issue in latest trunk (r16540).
just go to OpenWRT/trunk/build_dir/linux-atheros/madwifi-trunk-r3314/net80211
find if_athproto.h file
and change line
/*#define USE_HEADERLEN_RESV    1*/

and build.
Of course, it require additional testing, now i go to bed wink

Good work doctor64 wink

Hmm. Possibly, it's local hardware problem. i build latest trunk, upload it to different 2100AP and wireless works.
I think it's defective hardware.
Anyway, i exchange my unit to working one wink

i have debricked maybe dwl2100 A2 ap but there is anything wrong now started my router so.:
/fl/ - Volume is OK
Reading Configuration File "/fl/apcfg".
Configuration file checksum: 860c15 is good
ar5212Attach: Could not allocate space to cache the EEPROM
Error initializing wireless software state.
apInit: no wlan device
AP initilization failed!
Attaching interface lo0...done
0x80fffdf0 (tRootTask): memPartAlloc: block too big - 536870526 in partition 0x8
AP init fail: suspend and delete ROMPAGER40 task!
ERROR: AP start-up failed! Wireless network services disabled.

D-Link Access Point login: admin

Wireless Driver Rev
D-Link Access Point wlan2 ->    -----this line is very interest why wlan2

can anybody answer me what is wrong here?
I had soon 1000x reflashed via jtag apimg1... via http webinterface.... but nothing wlan not funct. When i click on the wireless tab on http interface its restarting.

Question.: is it able to repair via rs232 jtag "siemensdata cable"
Or what i need to repair it which hardware which program etc... i am very new on this thing i working since 2 days on it.

Please help me

(Last edited by damak on 11 Jul 2009, 11:32)

Did you flash firmware using jtag cable or via tftp?

hello at least anybody answer
first time my ap was always restarting about after 2-3 sec then i build a siemens data cable and via rs232 and http server on pc and with the art.elf i copied the APIMG1 cfg... to the ap and now starting the ap so.Now i have acces for the http interface i can make firmware update but the wvlan not funct.
I try today to build a parallel jtag cable my first try was the "very poor man" wiggler
/bc337 6-7 resistor/ but any of the progs can not detect then i tryed the "xilinx" /just 5 resistor/ the same without luck.Do i need the really wiggler cable with hc244...?

apropo is the symptome repairable via parallel Jtag?
I can not messed any voltage output on the pin 14  "3,3v" like wiggler buffered cable schematics.Is it bad?

(Last edited by damak on 13 Jul 2009, 00:12)

i build the wiggler jtag like this.:
but it seems my computer can not recognize any AR7 processor,I think i have hardware problem.I tryed  CiClAMab , debrick-mod,OCD without succes.Just a question is it able to reflash the bootloader via rs232 "siemens data cable" RX TX GND.?I tryed soon booting the redboot.elf ,openwrt.efl images but at the end its restaring therefore not working.I can just the art.ef Wxworks image booting with succes.Can i repair ,reflash it via this image?

Hi! Thank you all for the excellent work, all works well. But I would like to use OpenWrt all available frequencies for the chip in the DWL-2100AP rev.A4. This turns out to do when installing countrycode = 511 but reduced to txpower 5dbm. Can ktoto knows how to fix it.

And as I understood komuto been added to REDBOOT support flash S29AL032D. If yes please'll show you how.

Alexander Russia Tyumen.
Thank you very much.

Hi All! At first I want to say that all of you made excellent work due to DWL-2100!
My goal is to build redbot with support S29AL032 flash and LZMA support (or to try to replace it to have some more space for MC, airckrack etc:) - have few 8 bit flash samples).
Now using eCos V3.0 on cygwin. Or the same on Ubuntu 8.04. Have Atheros SOC sources from posted here files ported to 3-th ecos. Building redbot using eCos Configuration Tool. On both platforms have the same errors during making redbot:

make[1]: Entering directory `/tmp/untitled1_build/devs/eth/mips/ar531x/current'
mipsisa32-elf-gcc -c  -I/tmp/untitled1_install/include -I/opt/ecos/ecos-3.0/packages/devs/eth/mips/ar531x/current -I/opt/ecos/ecos-3.0/packages/devs/eth/mips/ar531x/current/src -I/opt/ecos/ecos-3.0/packages/devs/eth/mips/ar531x/current/tests -I. -I/opt/ecos/ecos-3.0/packages/devs/eth/mips/ar531x/current/src/ -finline-limit=7000 -Wall -Wpointer-arith -Wstrict-prototypes -Wundef  -Wno-write-strings -EB -mips32 -msoft-float -g -O2 -ffunction-sections -fdata-sections  -fno-exceptions -G0 -D_KERNEL -D__ECOS -Wp,-MD,src/ae531xecos.tmp -o src/devs_eth_mips_ar531x_ae531xecos.o /opt/ecos/ecos-3.0/packages/devs/eth/mips/ar531x/current/src/ae531xecos.c
/opt/ecos/ecos-3.0/packages/devs/eth/mips/ar531x/current/src/ae531xecos.c: In function 'ae531x_init':
/opt/ecos/ecos-3.0/packages/devs/eth/mips/ar531x/current/src/ae531xecos.c:222: warning: too few arguments for format
/opt/ecos/ecos-3.0/packages/devs/eth/mips/ar531x/current/src/ae531xecos.c: In function 'ae531x_start':
/opt/ecos/ecos-3.0/packages/devs/eth/mips/ar531x/current/src/ae531xecos.c:265: warning: implicit declaration of function 'ae531x_enablePhy1'
/opt/ecos/ecos-3.0/packages/devs/eth/mips/ar531x/current/src/ae531xecos.c:268: warning: implicit declaration of function 'rt_phySetup'
/opt/ecos/ecos-3.0/packages/devs/eth/mips/ar531x/current/src/ae531xecos.c: In function 'ae531x_send':
/opt/ecos/ecos-3.0/packages/devs/eth/mips/ar531x/current/src/ae531xecos.c:363: warning: format '%8.8x' expects type 'unsigned int', but argument 3 has type 'struct eth_drv_sg *'
/opt/ecos/ecos-3.0/packages/devs/eth/mips/ar531x/current/src/ae531xecos.c:407: error: lvalue required as left operand of assignment
/opt/ecos/ecos-3.0/packages/devs/eth/mips/ar531x/current/src/ae531xecos.c:409: warning: pointer targets in assignment differ in signedness
/opt/ecos/ecos-3.0/packages/devs/eth/mips/ar531x/current/src/ae531xecos.c:457: warning: format '%8.8x' expects type 'unsigned int', but argument 5 has type 'unsigned char *'
/opt/ecos/ecos-3.0/packages/devs/eth/mips/ar531x/current/src/ae531xecos.c: In function 'ae531x_recv':
/opt/ecos/ecos-3.0/packages/devs/eth/mips/ar531x/current/src/ae531xecos.c:500: warning: pointer targets in assignment differ in signedness
make[1]: Leaving directory `/tmp/untitled1_build/devs/eth/mips/ar531x/current'
/opt/ecos/ecos-3.0/packages/devs/eth/mips/ar531x/current/src/ae531xecos.c: In function 'ae531x_poll':
make: Leaving directory `/tmp/untitled1_build'
/opt/ecos/ecos-3.0/packages/devs/eth/mips/ar531x/current/src/ae531xecos.c:583: error: lvalue required as left operand of assignment
/opt/ecos/ecos-3.0/packages/devs/eth/mips/ar531x/current/src/ae531xecos.c: In function 'ae531x_TxReap':
/opt/ecos/ecos-3.0/packages/devs/eth/mips/ar531x/current/src/ae531xecos.c:764: error: lvalue required as left operand of assignment
make[1]: *** [src/ae531xecos.o.d] Error 1
make: *** [build] Error 2

Other parts (except eth HAL compiled successfully).
Why i want to use for this purpose eCos 3.0 - even don't know:)
I haven't enough experience to modify C source code with that errors (seems to be that they appear because of compiler version where changed - some sources where fixed by me for new version computability).
If somebody could help with this error... We will have advanced redbot:)
Thanks in advance!

Can somebody please post a working compiled version of 8.09.1 or 8.09.2RC? (any newer trunk version would be )
My AP (DWL-7100AP) is very similar to DWL-2100AP, and I get the same error when trying to install the firmware from site:
Kernel panic - not syncing: Fatal exception in interrupt

The 7.09 files do work though. The original 8.09 release has a bug preventing my specific board to run it, but 8.09.1 should work.

I tried compiling myself, but I am ashamed to say that I couldn't even get the compiler dependencies for my Mandriva 2009.

Thank you very much

(Last edited by OzTm on 16 Oct 2009, 12:54)

Problems with compile errors are solved (GCC version incompatable). Now adding flash chip S29AL032 and LZMA support.

Please post your compiled redboot.
I will do a backup on my 2100AP web space
I think it is usefull for the comunity wink


ramponis, of course I will! Have no time to finish that version. Now it have some issures with size & ethernet support.