OpenWrt Forum Archive

Topic: SOLVED: Image Builder - A5-V11 3G/4G Router

The content of this topic has been archived between 19 Apr 2018 and 27 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

I bought this one.

http://www.ebay.com/itm/Mini-Portable-3 … 464b1b335f

I am reading this page which seems to mention the device as RT5350
https://wiki.openwrt.org/toh/unbranded/a5-v11

And this page seems to imply another type as PROFILE
https://dev.openwrt.org/ticket/18712
Which says to use PROFILE=A5-V11

Can anyone confirm that this is the correct profile name is a5-v11 when using image builder with this device.

I am using
https://downloads.openwrt.org/chaos_cal … 64.tar.bz2

Thank you

(Last edited by projects on 26 May 2016, 17:21)

What makes you doubt that it is the correct profile?

Just trying to confirm because I've had issues in the past and lost many devices.

In this case, I've now built an image and upgraded the firmware with factory but lost access to the device again.

It is not responding to default IP, DHCP is not picking up, nothing what so ever. and no LED.

(Last edited by projects on 9 Apr 2016, 23:14)

Got it into failsafe mode. These are really easy to open up. Could not find the reset button since it's such a short throw switch you cannot tell you are using it.

Anyhow, at least I am in fail safe mode now.

(Last edited by projects on 10 Apr 2016, 01:45)

I thought this was the answer;

https://wiki.openwrt.org/toh/unbranded/a5-v11

This device uses eth0.1 for the lan1 interface, rather than eth0 or eth1, so be aware of that in order for the wired Ethernet to work. You need to change /etc/configuration/network accordingly or the device will not be accessible after flashing without using a serial adapter to unbrick (or possibly OpenWrt Failsafe).

So, in files/etc/config/network
I have the following;

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan0'
        option ifname 'eth0'

config interface 'lan1'
        option ifname 'eth0.1'
        option proto 'dhcp'


However, now the device won't even go into fail safe mode.

(Last edited by projects on 10 Apr 2016, 00:44)

This thing is dead now. When I power it on, the red LED comes on, stays on.
It doesn't try to pick up a DHCP IP and it doesn't go into fail safe mode.

Darn, yet another one bites the dust.

Ok, got my two new units. Time to try this again smile

projects wrote:

Just trying to confirm because I've had issues in the past and lost many devices.

In this case, I've now built an image and upgraded the firmware with factory but lost access to the device again.

It is not responding to default IP, DHCP is not picking up, nothing what so ever. and no LED.

By default, the device  A5-V11 will act as a DHCP server, not client. You want to connect the A5-V11 Ethernet port directly to your PC. Your PC should pick up an IP address from the A5-V11 DHCP server.

Yes, but I only want the device to work as a dhcp client, not a router. I basically just want to use it as a Linux client so I strip most everything off it.

The packages I use are;
make image PROFILE=A5-V11 PACKAGES="libstdcpp ca-certificates libpthread bash curl kmod-ipv6 -dnsmasq -kmod-ath9k -uboot-envtools -wpad-mini -ppp -ppp-mod-pppoe -kmod-ppp -kmod-pppoe -kmod-usb-core -kmod-usb2 -kmod-ledtrig-usbdev -kmod-usb-ohci -kmod-usb-hid" FILES=files/

As mentioned in another post, I'd love to enable wireless dhcp client;

>I don't use wi-fi on these because I don't know how to build a very basic web page that would
>allow someone to use this as a wireless client only, able to enter the SSID and password for the local wireless hot spot in a very limited web page.

Ok, I'm ready to try this again.

This time, I have the dropbear file in files/etc/config/dropbear and my network file looks like this. I would also love to enable wireless as a dhcp client but don't know how yet.

# cat files/etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option ifname 'eth0.1'
        option force_link '1'
        option proto 'dhcp'
        option ip6assign '60'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 6t'

Finally, that worked perfectly. Now the device is a dhcp client via Ethernet nic.

I used the following to build which removes all wireless. I'd like to add wireless dhcp client so that I can work on a basic web page to allow the user to enter the ssid/password and nothing else.

make image PROFILE=A5-V11 PACKAGES="libstdcpp ca-certificates libpthread bash curl kmod-ipv6 -dnsmasq -kmod-ath9k -uboot-envtools -wpad-mini -ppp -ppp-mod-pppoe -kmod-ppp -kmod-pppoe -kmod-usb-core -kmod-usb2 -kmod-ledtrig-usbdev -kmod-usb-ohci -kmod-usb-hid" FILES=files/

Cool, I have this same unit on order (maybe--same outside case anyway).  Looks like fun.  Did you get the 32MB RAM model?  I read here some only have 16MB RAM.

If you want to connect as a wireless client, the package wireless-tools will help, or you can configure /etc/config/wireless

BTW, you can make room for wireless-tools by removing -kmod-ath9k -uboot-envtools
Those two packages are for a different SOC type.  This device runs on a MediaTek/Ralink RT5350F

For your captive portal hotspot, Openwrt already has a couple (wifidog for example).  You will probably need to mount a USB drive and extend the rootfs for that though.  I would add consider adding these packages: blkid block-mount kmod-fs-ext4  kmod-usb-storage kmod-scsi-core

Yes, this is the 32MB version and with what I have installed on it, I still have 14M left on the device for other stuff.
I read that (as seems to be the case too often) it's kind of a hit and miss with these, you don't know for sure what you'll be getting.

Yes, I do remove kmod-ath9k and uboot-envtools when building. I pasted my build string above in fact smile.

I'd love to learn how to enable wireless on these devices but I cannot mount external things, they need to remain stand alone, all just one piece because I prepare them and ship them off to people who simply connect them and nothing else.

So for example, I have as most do, a wireless hot spot here and would like to install only the most basic required packages on the device. What should I add into my build string?

Also, someone mentioned it's not a web server which allows the user to log in to enter the SSID/password so I'm not sure at all what else needs to get installed. I was thinking I could simply put a file on the device when building it that contains the SSID/password since I'll know those in advance.

Maybe the wireless client can just use that file to connect to the local wifi.

Looks interesting but I need the device to be a dhcp client, not a hot spot. I thought that the following was to allow a device to auto log into the local hot spot by pre-setting the ssid/password

config wifi-iface
    option device 'radio0'
    option network 'lan'
    option mode 'ap'
    option ssid 'OpenWrt-A6A70F'
    option key 'OpenWrt-A6A70F'
    option encryption 'psk2'
    option wps_pushbutton '0'

This is the post that I am working on for the wireless.

https://forum.openwrt.org/viewtopic.php … 00#p311200

Do you still have bricked units, or were you able to recover them all?

I'm asking because this post implies that there is possibly TFTP flash option available that I haven't seen documented anywhere else:

! Boot up
If booted (power on) when holding in the reset button,
the gizmo will grab some ip address in the
192.168.1.x range, and will look for a TFTP server at
ip address {{192.168.1.55}}, and an image named {{<some-numbers>.bin}}\\

https://gist.github.com/probonopd/c7bd4118e8502b12a214

I only have three of these and the first one got bricked. It's not actually bricked, it's running, picks up a dhcp IP but there aren't any services running on it so I can't log into it anymore.

I've got a bunch of locked up, bricked units which I'll eventually work on recovering.

I got my unit today.  I'm pretty sure it is the same, but I'm not sure about some of the memory allocations.  I'll probably investigate this TFTP recovery and see if I can find out what IP address it uses and the file it wants.

You should be able to clear all user settings in OpenWRT just by holding reset for a few seconds while it is running, if the reset button is mapped correctly.

Sorry I misunderstood what you wanted on the wifi interface.  This article describes the routed client using wireless:

https://wiki.openwrt.org/doc/recipes/ro … masquerade

Wait, do you mean yours got messed up when you tried converting it to openwrt?
Yes, I've tried all kinds of reset things but none have worked. I also took it apart which is super easy and found no pre-soldered pads so it's in my 'to do' box.

BTW, saw that link, looked at it but it's not clear what I need to do. I know this is not very complicated but when you've never done it, it's all very complicated. I don't want to over complicate something that should not be all that difficult.

What I mean is that default factory builds posted on the site to convert the devices from chinese to openwrt always have wireless enabled, just not as a wireless dhcp client.

(Last edited by projects on 19 Apr 2016, 18:07)

I didn't brick it, but I saw on another thread here where they sometimes brick unless you change the boot loader.  So, I'd like to have TFTP as a backup in case it does brick.

Regarding your wireless setup, if I (finally) understand correctly, it should be very similar to this wireless storage device project:

https://hackaday.io/project/1378-portable-travel-nas

It is a practical example using command line following the wiki article.  Might help make it more clear.

(Last edited by RoutyMcRouter on 20 Apr 2016, 12:02)

That's interesting. All I've done so far is use a factory build then my own. Once I know better that it's all working, I'll build my own factory so I only have to do it once.

The link you sent me seems to have solved my wireless issue, mostly smile.
https://forum.openwrt.org/viewtopic.php … 38#p320538

So, something interesting.

I thought I would try another one of these from another seller so bought this one.

http://www.ebay.com/itm/281997162911?_t … EBIDX%3AIT

This one came with a Qualcomm web interface. Wiki notes say you can brick it if you try to upgrade it directly.

https://wiki.openwrt.org/toh/unbranded/a5-v11

I can telnet into it and it is running busybox but not openwrt. No commands to convert firmware from the CLI either.
Glad I didn't order more than one. Still reading the wiki.

Now I understand why you were messing with the boot loader RoutyMcRouter. Pretty frustrating that these things cannot be consistent.

(Last edited by projects on 7 May 2016, 15:48)

Followed it to the letter, then rebooted as explained in the doc but mine never came back with 192.168.100.1.
It also never tries to pick up a dhcp IP and even though I can get it into what appears to be fail safe mode with the LED flashing quickly, it doesn't respond with any IP.

I also watched the Ethernet port using wireshark. What nonsense these manufacturers put us through.

projects wrote:

Followed it to the letter, then rebooted as explained in the doc but mine never came back with 192.168.100.1.
It also never tries to pick up a dhcp IP and even though I can get it into what appears to be fail safe mode with the LED flashing quickly, it doesn't respond with any IP.

I also watched the Ethernet port using wireshark. What nonsense these manufacturers put us through.

The  uboot256.img and mini.bin firmware link in the English (QualComm) Factory Firmware section of the Wiki does not contain an enabled DHCP server. If you did not upgrade to Chaos Calmer immediately,  you may need to manually reconfigure your Ethernet on your Linux lPC, For many Linux PCs, the command is

sudo ifconfig eth0 192.168.100.249

Afterwards, you should be able to ping your router at 192.168.100.1

If you use NetworkManager, you may need to temporarily un-check the "Enable Networking" drop-down menu item before issuing any of the above commands..

Good Luck!