OpenWrt Forum Archive

Topic: Tp-link CPE210 V 1.1 Firmware support

The content of this topic has been archived on 30 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Hi guys,

I have a Tp-link CPE210 V 1.1 Hardware is the same like V. 1.0.

I see this link:

http://git.openwrt.org/?p=openwrt.git;a … 806a444f47

Maybe some one could tellme how i could recompile a firmware with support for CPE 210 V 1.1

Or someone dev guru for a prebuilt  .bin file and please update with support for V 1.1 this firmware:

https://downloads.openwrt.org/chaos_cal … actory.bin

Thanks for your time.

Cheers!

(Last edited by yan.frank on 11 May 2016, 05:49)

Thank,

Finally i resolve on this way:

Get firmware and flash it from Development Snapshots - Trunk, that includes support for hardware v 1.1 but without LuCI:
http://downloads.openwrt.org/snapshots/ … actory.bin

Get firmware 15.05.1 on newly Openwrt router from ssh 192.168.1.1
#wget http://downloads.openwrt.org/chaos_calm … pgrade.bin
Note "sysupgrade" bin.

Do on you Openwrt:
#sysupgrade -F openwrt-15.05.1-ar71xx-generic-cpe210-220-510-520-squashfs-sysupgrade.bin

Them you have a openwrt 15.05.1 on CPE210 V1.1

Cheers.

yan.frank wrote:

Finally i resolve on this way:
Get firmware and flash it from Development Snapshots - Trunk, that includes support for hardware v 1.1 but without LuCI:

Just curious, if after the snapshot (trunk) is installed opkg update install LuCi
Would be the same?

Hi, you are right, but i dont want install LuCi anytime after press reset button.
Anyway, im already building a custom firmware from Image Builder with my own /etc/network files.
Cheers.

Can someone please add the following targets to the tplink-safeloader.c

"CPE210(TP-LINK|UN|N300-2):1.1\r\n"
"CPE210(TP-LINK|US|N300-2):1.1\r\n"
"CPE210(TP-LINK|EU|N300-2):1.1\r\n"

and upload the compiled trunk?
It seems that the original V1.1 patch only covers the "UN" version, which does not cover
my model so I guess the patch is incomplete.
When I do strings on the Pharos 1.3.3 firmware I see the following targets:


WBS510(TP-LINK|UN|N300-5):1.20
CPE510(TP-LINK|UN|N300-5):1.0
CPE210(TP-LINK|UN|N300-2):1.0
WBS510(TP-LINK|UN|N300-5):1.0
WBS210(TP-LINK|UN|N300-2):1.0
CPE510(TP-LINK|UN|N300-5):1.1
CPE520(TP-LINK|UN|N300-5):1.1
CPE210(TP-LINK|UN|N300-2):1.1
CPE220(TP-LINK|UN|N300-2):1.1
WBS510(TP-LINK|UN|N300-5):1.20
WBS210(TP-LINK|UN|N300-2):1.20
CPE510(TP-LINK|US|N300-5):1.1
CPE520(TP-LINK|US|N300-5):1.1
CPE210(TP-LINK|US|N300-2):1.1
CPE220(TP-LINK|US|N300-2):1.1
WBS510(TP-LINK|US|N300-5):1.20
WBS210(TP-LINK|US|N300-2):1.20
CPE510(TP-LINK|EU|N300-5):1.1
CPE520(TP-LINK|EU|N300-5):1.1
CPE210(TP-LINK|EU|N300-2):1.1
CPE220(TP-LINK|EU|N300-2):1.1
WBS510(TP-LINK|EU|N300-5):1.20
WBS210(TP-LINK|EU|N300-2):1.20
CPE210(TP-LINK|EU|N300-2):2.0
CPE210(TP-LINK|UN|N300-2):2.0
TL-CPE210(TP-LINK|CN|N300-2):1.0
TL-CPE510(TP-LINK|CN|N300-5):1.0
TL-BS210(TP-LINK|CN|N300-2):1.0
TL-BS510(TP-LINK|CN|N300-5):1.0
TL-BS210(TP-LINK|CN|N300-2):1.20
TL-BS510(TP-LINK|CN|N300-5):1.20


My system gets some toolchain make error when I try to compile it
myself, but that is another issue. If someone can submit this fix upstream
it will make full support for all known V1.1 models so far...
Thanks!

Update:
I managed to build the image and included the following regions:

"CPE210(TP-LINK|UN|N300-2):1.1\r\n"
"CPE210(TP-LINK|US|N300-2):1.1\r\n"
"CPE210(TP-LINK|EU|N300-2):1.1\r\n"
"CPE210(TP-LINK|CN|N300-2):1.1\r\n"

So in case anyone got a device like mine, from another region, Pharos will
complain about wrong hardware model. This patch fixes it permanently and
now everything works smile

https://www.sendspace.com/file/qodzx8

yan.frank wrote:

Do on you Openwrt:
#sysupgrade -F openwrt-15.05.1-ar71xx-generic-cpe210-220-510-520-squashfs-sysupgrade.bin

Them you have a openwrt 15.05.1 on CPE210 V1.1

Worked well for me, I SCPed the openwrt-15.05.1-ar71xx-generic-cpe210-220-510-520-squashfs-sysupgrade.bin image manually to /tmp/ with winSCP portable! wink

(Last edited by Mitsch87 on 8 Sep 2016, 15:33)

can any one with the right mind assist me after i upgrade the router i cant log intow it ofcourse what must i do with the upgrade file to install luci. what must i do with winscp give directions step by step. Dont just say ssh into how must i install the luci upgrade

vinnyk after update the firmware you have in yhe link, i can't access the router, can you help me?

thanks a lot

joaopascoal wrote:

i can't access the router,

access via  SSH (putty)
usually you dont have interface, you need to download and install it, via SSH (putty)
if not your case do Recovery here is how http://forum.tp-link.com/showthread.php … Pharos-CPE

The discussion might have continued from here.