OpenWrt Forum Archive

Topic: Gateway 7001 - no wireless interfaces

The content of this topic has been archived on 17 Mar 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

I just flashed 15.05.1 last night to one of my Gateway 7001 APs.  Unfortunately there are no wireless interfaces available to configure when there should be two.  I have three Gateway 7001s and have been running OpenWRT since 2010 and this is the first time I have encountered this problem.

There is no wireless option in LuCI
And there is no wireless config file in /etc/config/

On this page
https://wiki.openwrt.org/doc/uci/wireless
Note3: In case your image does not contain the driver for your wireless chipset, simply install them with opkg and proceed with Regenerate Configuration.

However looking at the opkg list I don't see atheros drivers. 

Please let me know if there are additional commands to run to further diagnose or is there is just a package I need to install. Thank you.

Solved:

First

opkg install pciutils 

So I could run lspci to determine the wireless cards installed.

root@OpenWrt:~# lspci
00:01.0 Ethernet controller: Qualcomm Atheros AR5212/AR5213 Wireless Network Adapter (rev 01)
00:02.0 Ethernet controller: Qualcomm Atheros AR5212/AR5213 Wireless Network Adapter (rev 01) 

I determined I needed the ath5k driver by verifying it with this page
https://wiki.debian.org/ath5k

opkg install kmod-ath5k

I then tried to detect the wireless cards which didn't work until after I reboot the device

root@OpenWrt:~# wifi detect > /etc/config/wireless
root@OpenWrt:~# ls /etc/config/
dhcp      dropbear  firewall  luci      network   rpcd      system    ucitrack  uhttpd    wireless
root@OpenWrt:~# cat /etc/config/wireless
root@OpenWrt:~# reboot

root@OpenWrt:~# cat /etc/config/wireless
config wifi-device  radio0
        option type     mac80211
        option channel  11
        option hwmode   11g
        option path     'pci0000:00/0000:00:01.0'
        option htmode
        # REMOVE THIS LINE TO ENABLE WIFI:
        option disabled 1

config wifi-iface
        option device   radio0
        option network  lan
        option mode     ap
        option ssid     OpenWrt
        option encryption none

config wifi-device  radio1
        option type     mac80211
        option channel  36
        option hwmode   11a
        option path     'pci0000:00/0000:00:02.0'
        option htmode
        # REMOVE THIS LINE TO ENABLE WIFI:
        option disabled 1

config wifi-iface
        option device   radio1
        option network  lan
        option mode     ap
        option ssid     OpenWrt
        option encryption none

I could now configure wireless in LuCI, but was unable to utilize WPA2 until I installed wpad-mini

root@OpenWrt:~# opkg install wpad-mini
Installing wpad-mini (2015-03-25-1) to root...
Downloading http://downloads.openwrt.org/chaos_calmer/15.05.1/ixp4xx/generic/packages/base/wpad-mini_2015-03-25-1_ixp4xx.ipk.
Configuring wpad-mini.

Once this was installed I rebooted again and successfully set up wifi

To clean up I

opkg remove lspci

(Last edited by 7001 on 12 May 2016, 14:23)

The discussion might have continued from here.