OpenWrt Forum Archive

Topic: TP-Link TL-WR810N (US) ver 1.0

The content of this topic has been archived on 3 May 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

I just got my WR810N(US) today. Flashed OpenWrt trunk and everything worked fine (haven't tested USB though).

The US version is very similar to the EU version. They have same CPU, RAM, and Flash, so the same openwrt firmware just works fine. It is a little bit smaller than the EU version, because it does not have the hardware switch for AP/3G/ROUTER (2 programmable GPIO in OpenWrt). FCC have some nice pictures of it.

Since TP-Link now locks firmware on US version due to FCC regulations, flashing openwrt directly from the web interface didn't work. Then, I tried TP-Link's TFTP recovery mode (press reset while booting). I used Wireshark to listen for ARP, but the little box never ask for an IP address. I guess TP-Link just removed the TFTP recovery function in US version in order to make it harder to flash 3rd party firmwares.

Flashing via serial console should still work as always, but I didn't bother to try it. Thankfully, I found this method from our forum, which basically disables the firmware check via shell injection in the web interface. It did the trick and now I'm running openwrt. smile

OpenWrt trunk for WR810n: … actory.bin

Some picture of it (smaller one) with my old WR720n (larger one):

(Last edited by edwards on 22 May 2016, 10:11)

I tried a few times and never succeeded. Anyone else had similar experience.

Meanwhile, I find the DD-WRT support below

not sure if I want to use it.

(Last edited by run4life on 17 Jun 2016, 22:28)

The discussion might have continued from here.