OpenWrt Forum Archive

Topic: cable modem in bridge mode with openwrt

The content of this topic has been archived on 3 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

How do I connect a CH6640E cable modem from Kabel Deutschland in bridge mode with a TP-Link WR842N V2.3 openwrt router running Chaos Calmer? I connected the wan port of the openwrt-router with the lan1-port of the cable modem, but I don't get access to Internet. What do I have to do?

Kabel Deutschland (a larger ISP in Germany) provides Internet connectivity through cable modems on standard cable television infrastructure. Thus a cable modem is provided by the provider. Without configuration change the DOCSIS-3 modem use DHCPv4 to provide IPv4 addresses (RFC 1918 addresses, NATed) and IPv6 SLAAC to hand out a /64 prefix. The later is the minimum which is required to fulfills the requirements. It do no allow me to group the network into routing areas (subnetting) - which is bad.

Kabel Deutschland provides a mode to switch the modem - and the infrastructure behind - into a so called bridge mode. The result is that a public IPv4 is replied for an DHCPv4 request but if you try DHCPv6 prefix delegation (DHCP-PD) I get an error that no IPv6 addresses are available

- http://www.jauu.net/2015/03/03/complete-openwrt-guide/

you log into OpenWRT go to NETWORK/ INTERFACES/ GO TO WAN EDIT/ CLICK ON PROTOCOL DROP DOWN WINDOW .Their should be PPP,PPtP,PPPoE,PPPoA,L2tp,OPENWRT HAS A NEW PACKAGE PPP-multilink A PPP (daemon with multilink support) and PPP-mod-radius.If you have none of these thin you don't have the packages installed you will have PPPoE.Call your ISP and ask with protocol you need to bridge your modem with a router,click on to it if you don't have it install it put your click on switch protocol put in user name and password you are ready to go.My protocol is PPPoE i have no problem with IP6 if you do IPv6 Tunnel Setup with Sixxs

Install aiccu and the required dependencies:

(Last edited by ckm on 16 Jun 2016, 05:01)

by default your provider modem(Router) is in normal router mode. If you want  the bridge mode you have to setup this on Vodafone Website login and search for the router settings and change it to bridge mode after this change the router get a firmware upgrade its take 15 min up to 24h

Then the LAN 1 port give you now the ip over dhcp, this is the openwrt default for WAN. bu you get only ipv4 no ipv6

(Last edited by trismo on 16 Jun 2016, 08:20)

ckm wrote:

you log into OpenWRT go to NETWORK/ INTERFACES/ GO TO WAN EDIT/ CLICK ON PROTOCOL DROP DOWN WINDOW .

Correct. Kabel Deutschland is PPPoE

ckm wrote:

Install aiccu and the required dependencies:

Unnecessary.

trismo wrote:

by default your provider modem(Router) is in normal router mode.

N.B. the first sentence of the thread.

@tristank: Some cable ISPs (charter for example) require you to power cycle the modem and the router (simultaneously) before delivering DHCP addresses to the router. Ex-Kabel Deutschland, now vodafone, might behave similarly. My best guess is that in the luci GUI the default protocol DHCP should be the correct one.

        @ckm & @ Max: Vodafone uses PPPoE on its remaining DSL-lines, but I would be really amazed if they would use this on their DOCSIS plants (as that would be a sort of belt and suspender approach to user authentication); heck even Max's link seems to confirm that... (The link is to a question which PPPoE (username & password) settings to use with vodafone with the response "No settings required")

Best Regards
        M.

(Last edited by moeller0 on 16 Jun 2016, 11:44)

Max Hopper wrote:

DOCSIS + PPPoE

I am not saying that DOCSIS is incompatible with PPPoE or that it would be impossible to use PPPoE over DOCSIS; I am saying that Vodafone does not seem to use PPPoE on its DOCSIS plant, so from OPs perspective the pppoe subthread seems like a distraction. Thanks for the link though.

Best Regards
        M.

I never seen a cable based internet service that uses PPPoE, its either Static IP or DHCP, which is binded to a MAC address.

Thanks for all answers. It seems that powering the modem off and back on after a longer period of time has solved the issue. I also had to make sure that the only device connected to the modem was the router, because for some reason that MAC-Address is than whitelisted for use by Kabel Deutschland (Vodafone). There are no PPPoE credentials necessary.

(Last edited by tristank on 21 Jun 2016, 21:48)

The discussion might have continued from here.