OpenWrt Forum Archive

Topic: Struggling with WR841N v11 [Resolved]

The content of this topic has been archived between 3 Apr 2018 and 6 May 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Downloaded the firmware from here:

this site /toh/tp-link/tl-wr841nd

Tried to install it and got the error:

Error code: 18005 Upgrade unsuccessfully because the version of the upgraded file was incorrect. Please check the file name.

Downloaded the latest official firmware from here:

tp-link aus site /download/TL-WR841N.html#Firmware

Renamed the openwrt to match and get the same error, just to test, tried uploading the original firmware with absolutely no changes to the name and still get the same error.

Thought it might be because the firmware says it's the same as on the router:

3.16.9 Build 160325 Rel.62500n

So tried upping the version numbers, no joy, same error.

Googling suggested trying to put dd-wrt on first, they have only the v9:

dd-wrt site /site/support/other-downloads?path=others%2Feko%2FBrainSlayer-V24-preSP2%2F2014%2F12-22-2014-r25697%2Ftplink_tl-wr841ndv9%2F

but tried it anyway (factory-to-ddwrt.bin) and no joy, renaming as above had no so luck either.

I'm guessing it's checking something within the .bin itself but can't view the archive (as that's beyond my skill, I did give textpad a shot, as, why not, but no such luck).

Any other way to flash this? I see mention of TFTP but this seems like some weird voodoo, how many chickens do I need?

(apologies, new user, can't post links so bastardised them)

(Last edited by Sampler on 15 Sep 2016, 04:48)


maurer wrote:

have you tried my version *snip* ?

Thanks, given it a go and still getting the same error:

Error code: 18005
Upgrade unsuccessfully because the version of the upgraded file was incorrect. Please check the file name.

Tried renaming it to the latest official firmware:
And same result = (

Where would I find that, on the tp link site it only has wr841nv11_wr841ndv11_en_3_16_9_up_boot(150616) (there's no link to historic firmware or alternatives)

oh, nm, saw you'd edited the link in after I posted = )

(Last edited by Sampler on 8 Sep 2016, 10:49)

Same error, though I think that might be because it's the same firmware that the router shipped with:

Firmware Version:    
3.16.9 Build 160325 Rel.62500n
Hardware Version:    
WR841N v11 00000000

Hi nozombian,

Finally managed to get it to work with the tftp method (over ethernet, rather than usb) - thanks for everyone's help, no idea why the default system gui wouldn't let me update.


Sampler wrote:

no idea why the default system gui wouldn't let me update.

Because of the FCC regulations

But that wouldn't account for it not accepting it's own firmware from their site, plus, FCC don't have jurisdiction in Aus = p

(I know, I know)

Thanks NeDark, hopefully that'll help someone else coming across this post

It works Super here !!!!
Thank you NeDark

Hello, got experience levels sort of mixed but I do feel comfortable trying to do this. Having said that if I'm looking to put Chaos Calmer on a WR-841N v11 AND I need LUCI is the current thinking to load v10 over the serial port with sysupgrade -F, if so do you need the setenv's and so forth to precede it (I don't see an exact list, model or video to crib from)? Or does someone have a mature patch for v11 with a countable # of things not working? I just bought the serial port but I haven't used this one in this context, doesn't bother me to type long command sequences (my error rate's low) but I don't know enough about what's going on to make my own sequences just yet.

works here too! smile thank you sooooooo much NeDark. I wasted many hours trying different builds for v11 (non US) before coming across this !! Cheers!

Hi NeDark, I'm very keen to try your bin file (post #13) but the link to your dropbox doesn't work any more.  Are you able to make this available again please?  Thanks.

NeDark wrote:

Modified version 150616. New version 160325 will accept this file

I did modification explained in post ...

Hi to all
I am on the same page ... sad
Unfortunately the link is broken
Is it possible to reupload the file to another web hosting ?
Many thanks

mh3g wrote:


Look here for download
Guarda qui per il download

Firstable many thanks for your support
Your link goes to a web page of DD-WRT forum where you=mh3g suggests to go to OPENWRT forum to this 3D
It is a closed circle smile

Do you have chance to upload the patched firmware that allows to upgrade with custom firmware ?
The link of Nedark is not working (as you can try)
Can you confirm that after upgraded using this firmware provided by NeDark I will be able to install one of my favourite firmare custom OPENWRT or DD-WRT ??
Pratically my question is : the fimrware provided by NeDark substitutes the official firmware with a new modified able to accept later a custom firmware or is itself a OPENWRT firmware ?


(Last edited by paolocorpo on 21 Apr 2017, 12:20)

You need to register to ddwrt forum to view the file to download attached in the discussion ;-)

Ti devi registrare al forum di ddwrt per visualizzare il file da scaricare allegato nella discussione. ;-)

(Last edited by mh3g on 21 Apr 2017, 13:25)

I got it
I need to reset the router before use this patched firmware ?

Can you please support me with my other questions/doubt s ?

(Last edited by paolocorpo on 21 Apr 2017, 14:10)

With this file you unlock the router. After this flash the router is unlocked forever but you dont reflash again the orginal firmware 160325 from tplink (is locked).  From the upgrade page, after the flash,  you can install other firmware like ddwrt or lede or openwrt or gargoyle without the 18005 error.
Reset not required, my router works great. For other questions no problem.

Many Thanks
I installed the patched firmware by NeDark
After I installed the DD-WRT firmware