OpenWrt Forum Archive

Topic: Help with reverting WRT1900AC

The content of this topic has been archived on 20 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Hi all,
  I'm attempting to revert my original firmware using this wiki.

However, I don't have a "linux" partition.  cat /proc/mtd returns this.

cat /proc/mtd
dev:    size   erasesize  name
mtd0: 00100000 00020000 "u-boot"
mtd1: 00040000 00020000 "u_env"
mtd2: 00040000 00020000 "s_env"
mtd3: 00100000 00020000 "devinfo"
mtd4: 02800000 00020000 "kernel1"
mtd5: 02500000 00020000 "ubi"
mtd6: 02800000 00020000 "kernel2"
mtd7: 02500000 00020000 "rootfs2"
mtd8: 02600000 00020000 "syscfg"
mtd9: 00780000 00020000 "unused_area"
mtd10: 00008000 00008000 "spi0.0"

Which partition should I flash?  My goal is to remove open WRT. It's not clear to me which partition I should overwrite.  I'm turning my WRT1900AC into a dumb AP, and unfortunately I can't get the WAN port (eth1) to bridge onto the LAN.


But if you have a deep seated need to get down and dirty. Also if you have  not already flashed over your original OEM on the other partition, toggle the power switch 3 times, or do this.

So bad news and worse news.....

I've tried the 3 toggle to switch boot partitions.  Unfortunately, it doesn't seem to solve my issue.  I seem to have somehow managed to get myself into a state where both partitions are the WRT1900AC factory firmware.  I think this is the case due to the orange LED on the internet light blinking as it boots.  OpenWRT doesn't do that.

Unfortunately, when I get an IP of and connect to in my browser, I get some unrecognizable text that seems to be html in the wrong language, with no CSS and no links/buttons I can follow. 

Specifically, I see this.

0324384f=Martedì 0635e043=Che cos'è la Pianificazione wireless 07a17b06=PIN dispositivo 0c7cf4f3=Automatica 1013d277=Filtri MAC 127663c3=Modalità di rete 129e4346=Elenco filtri MAC 129eeb80=Scegliere se si desidera abilitare la connessione SimpleTap. Questa funzione consente di connettere un dispositivo mobile compatibile con NFC alla rete utilizzando la scheda SimpleTap in dotazione con il router. 13e22435=Consenti l'accesso SOLO agli indirizzi MAC inclusi nell'elenco 14732497=Connessione SimpleTapTM 1499c864=Se si disattiva la funzionalità Wi-Fi Protected Setup in questa pagina, anche il relativo pulsante sul router sarà disattivato. 1976e32a=2,4 GHz 1c7c5288=Il dispositivo client non è riuscito a connettersi alla rete. Per ulteriori informazioni, fare riferimento al dispositivo client. 1e538eb6=Wireless disattivato 1f2cb273=È stata configurata una pianificazione wireless. 256fee65=Compatibilità per la funzionalità Wi-Fi Protected Setup 25f8bf32=Nessuna 2fe65abd=Opzioni di filtro 30c623e8=Password: 3618bd6a=Elimina 378171a9=Mercoledì 3a22962e=Ampiezza canale: 3cedff94=Modalità di protezione: 3d843555=Se il dispositivo client richiede il codice PIN del router, immettere il codice nel dispositivo client. 3d896dd1=Attivato 4201de09=Connessione intelligente: 442cb6c7=Impostazioni del router 448878f3=È stato immesso il numero massimo consentito di indirizzi MAC. Impossibile aggiungerne altri. 450a4780=PIN router 46bd419c=Venerdì 46d33a9a=Pulsante 4929b67e=Aggiungi indirizzo MAC 4a370bdd=Modifica 4a868832=Porta RADIUS: 4bc9132a=Modalità di rete: 4c84c5e8=Se il dispositivo client è dotato di un codice PIN per la funzionalità Wi-Fi Protected Setup, inserirlo qui, quindi fare clic su Registra. 4e4b66b6=4 4fa1819c=Solo 802.11b 4fd07f02=Cifratura: 504061d0=Numero PIN non valido. 51248839=AVVERTENZA: L'impostazione della modalità di protezione su WEP, WPA Personal o WPA Enterprise causerà la disattivazione della funzionalità WPS (Wi-Fi Protected Setup). Non sarà disponibile neanche la modalità di rete Wireless-N. Procedere? 529f86cb=Non protetto 52fd3a01=40/64 bit (10 cifre esadecimali) 55ae8f3f=Connessione non riuscita. 5e95afe8=Che cos'è la gestione di banda Connessione intelligente? 5ea8b8c2=Chiave 2: 5f0cf02a=80 MHz 6311b9b2=L'Utilità di pianificazione wireless ha disattivato il wireless. 66902e86=Per essere operativa, la funzionalità Wi-Fi Protected Setup richiede la trasmissione dell'SSID. Sarà possibile utilizzare la funzionalità Wi-Fi Protected Setup soltanto per gli SSID che vengono trasmessi. 679449f9=Ricerca dispositivo client in corso. 6a377dc5=SimpleTap 6c813321=40 MHz 723ace2b=Salva 728d6236=Attendere... 72d5b8ea=1 74f0ca39=Wireless 760c45b1=SSID 2,4 GHz: 761608b5=Solo 802.11b/g 77ba6059=Per essere operativa, la funzionalità Wi-Fi Protected Setup richiede la trasmissione dell'SSID. Si desidera attivare la trasmissione dell'SSID? 78248efd=Disattivato 791ce4a1=La pianificazione creata disattiverà ora l'accesso wireless. Tutti i dispositivi wireless saranno disconnessi. Continuare? 7b701b91=Domenica 7d7c6474=Nega l'accesso agli indirizzi MAC inclusi nell'elenco 7e80b0d3=Trasmetti SSID: 7f3ef59c=L'attivazione del filtraggio MAC disattiverà la funzione WPS. Continuare? 7fdeae92=Chiudi 82752b70=Utilizzare uno dei metodi riportati in basso per connettere il dispositivo utilizzando la funzionalità Wi-Fi Protected Setup. 8446cb23=Solo 20 MHz 85b3973a=Visualizza e modifica la configurazione wireless 86967226=Solo 802.11a 880cd1f9=SSID non trasmesso. 8885e952=Lunedì 8d475e28=Solo 802.11b/g/n 8f475444=Annulla 91b1215d=Il dispositivo client è ora connesso alla rete. 95bf52fd=Solo 802.11a/n 9638a358=Ampiezza canale 967fece9=Mista 96d3c7d5=Mostra widget sulla homepage. a33dffc6=Chiave TX: a607a42a=Orario del router: a62597b9=Nome della rete: a8afb84b=104/128 bit (26 cifre esadecimali) a98877f4=Giovedì af11364f=2 b04db74f=Visualizza e modifica le impostazioni del router b0725057=Indirizzo MAC b15f9c79=Gestione della banda da 5 GHz b66dfc28=Registra b805542e=Rete: b9ef9a13=No bd32b640=Utilità di pianificazione wireless bfbaa700=Connessione intelligente c0aca228=Wi-Fi Protected Setup c0e04dfd=È possibile attivare e disattivare le reti wireless, facendo clic sul calendario in basso. c397d39e=Sì c3a5ca53=Reti singole c45ebad7=La modalità di protezione è disabilitata su una o più reti wireless in uso. La rete potrebbe essere accessibile a utenti non autorizzati. Procedere? c48003ed=3 c5b74657=Azione c681481a=Canale: c7909e11=Solo 802.11g c9b9fe80=Chiave 3: ca3e67c6=Chiave 1: cb460ddb=Wi-Fi Protected SetupTM cbda92fc=Se il dispositivo client è dotato di un pulsante Wi-Fi Protected Setup, selezionare o premere tale pulsante, quindi fare clic sul pulsante riportato di seguito. ceed77ee=Solo 802.11ac d3805946=Genera d5a932d7=Canale d792743b=Server RADIUS: d9c3794a=Filtraggio MAC db4c422e=Congratulazioni. de8a0fc8=Solo 802.11n df0302f8=Passphrase: e57d63f9=La funzionalità Wi-Fi Protected Setup non può essere utilizzata con la modalità di protezione wireless WEP o WPA o con il filtraggio MAC. Per utilizzare la funzionalità Wi-Fi Protected Setup, modificare la modalità di protezione wireless e/o disattivare l'opzione Filtraggio Mac. e9b662b3=OK ec4dc4e7=Per essere operativa, la funzionalità Wi-Fi Protected Setup richiede la trasmissione dell'SSID. Si desidera abilitare la trasmissione dell'SSID (il router verrà riavviato)? eed5a000=Sabato f17d9d5f=Modalità di sicurezza f29550e5=Wireless attivato f47b8767=Chiave 4: fce86bf7=Applica fdedcaa0=Chiave condivisa: fe960f2a=Protetto ff28c9be=Solo 802.11a/n/ac

I've tried holding the reset button 10 seconds to no avail, as well as a 30/30/30 reset for good measure.  Unfortunately my router reset 1 legged dance didn't work, nor did my string of expletives...  Any other ideas?


(Last edited by todd.nine on 6 Oct 2016, 21:07)

Is that Italian? Where did you pull the OEM image from? Yes, it looks like OEM on both partitions. If you are sure that you are actually flipping partitions, and you cannot work your way through the screens to flash something else, than I guess you will need a serial console to flash from the uboot console. I don't know if there is any none-serial method of doing a tftp with this device, the wiki would have you believe the answer is no.

So thankfully I was wrong.  I was shutting off the power too early when using the toggle switch to select the boot partition. The good news is I was able to get into Open WRT.  I then flashed with the following (via ssh)

cd /tmp

/usr/sbin/fw_printenv -n boot_part

This returns 1, therefore, this means the my WRT install is on kernel1, as a result, I want to flash kernel2.  I proceed with the following

mtd -r write FW_WRT1900AC_1.1.10.167514_prod.img kernel2

My system writes, then reboots. I then used the 3 cycle trick to switch back to the factory partition.  I end up in exactly the same state.  This makes me thing something with my settings in the factory partition (kernel2) isn't correct.  Does the configuration come from this partition or does it come from a different partition?  If I 0 out the configuration partition with dd, will that most likely cause the factory firmware to function in it's default state?


I guess I would be inclined to a higher level call:

sysupgrade -n -v image-name

in going between owrt and OEM as the partition layout is not the same.

As well as getting the environment setup correctly as per my earlier link.

(Last edited by anomeome on 6 Oct 2016, 21:53)

The discussion might have continued from here.