OpenWrt Forum Archive

Topic: Where is mknod?

The content of this topic has been archived on 25 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.


I am trying to create a device node with mknod but mknod is not on my firmware, even though it is enabled with a * in busybox.

Is this normal?

I am running kamikaze r4548. Is this up to date?



Answer to my own question :
The make menuconfig from buildroot-ng root dir is not updating the busybox/.config file correctly. I had to set the mknod option by hand in that .config file to have it build correctly.


OpenWrt uses devfs; mknod is unnecessary

The discussion might have continued from here.