OpenWrt Forum Archive

Topic: Bought MT7620A running Open-wrt - where can I get update etc

The content of this topic has been archived on 19 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

So I bought this router from Ali-express which seemed pretty good but the router firmware seems outdated and having bugs, for example

  • 5Ghz option is not showing wireless security options of WPA and WPA2 but only WEP
    The packages repo is not getting updated.
    It shows firmware version as OpenWrt Barrier Breaker unknown / LuCI Trunk (svn-r10457) hence I really do not know what should I upgrade to and if something goes wrong I wont be able to restore maybe (nobo here)

I somehow feel everything related to my router should show here /snapshots/trunk/ramips/mt7620/ but which one should I download so it works fine as the model I have doesn't show there as its OEM type router.

System
Hostname    OpenWrt
Model    AWF-5G
Firmware Version    OpenWrt Barrier Breaker unknown / LuCI Trunk (svn-r10457)
Kernel Version    3.10.44
Local Time    Mon Jan 9 13:26:06 2017
Uptime    4h 38m 58s
Load Average    0.03, 0.07, 0.06
Memory
Total Available    
101948 kB / 126660 kB (80%)
Free    
85852 kB / 126660 kB (67%)
Cached    
12464 kB / 126660 kB (9%)
Buffered    
3632 kB / 126660 kB (2%)

Hardware Specs

Hardware
Model Number    WE1628
Chipset    MT7620A/580MHZ
Flash    16M
SDRAM    128M
Antenna    For 2.4GHz,2*detachable 7dBi antenna, 
for dual band,4*detachable 7dBi antenna,
Interface    4*10/100M LAN Port,support(Auto MDI/MDIX)
1*10/100M WAN Port(Auto MDI/MDIX)
USB2.0*1
1*SD Card Slot
Button    Reset
LED    SYS/USB/WLAN/WAN/Port3/Port2/Port1/Port0
Power Supply    DC 12V/1A
Software
System    OpenWRT/SDK Linux
Work Mode    AP;Router;
WAN Type    PPPoE,DynamicIP,Static IP
Port Forwarding    Virtual Server, Port Triggering, UPnP, DMZ
QoS    WMM, Bandwidth Control for gaming mode
Access Control    IP/MAC/Domain Filtering
VPN Pass-through    PPTP, L2TP, IPSec (ESP Head)
DHCP    Server, Client, DHCP Client List, Address Reservation
Wireless
Standard    IEEE802.11a/11n/11g/11b/802.3/802.3u
Frequency Range    2.4-2.4835GHz,5GHz
Work Channel    2.4GHz choose:1-13
5GHz choose:149,153,157,161,165
Signal Rate    2.4G: 300Mbps
5G: 867Mbps
Data Transfer Rate    11n: Up to 300Mbps (dynamic)
11g: Up to 54Mbps (dynamic)
11b: Up to 11Mbps (dynamic)
11ac:up to 867Mbps
Security    WEP, WPS, MAC filter, WPA-PSK, PWA2-PSK, WPA/WPA-PSK
Coverage    300M( diameter)
User    30
Other
Dimension(mm)     
Weight(g)     
Operating Temperature    35~+75ºC(-31~+167°F)
Storage Temperature    -40~+85°C(-40~+85°F)
Operating Humidity    95% ( Non-condensing)

Thanks for help!

(Last edited by coolraghav on 9 Jan 2017, 15:32)

Hello,
the OpenWRT firmware on these routers is developed directly by the manufacturer. Is not part of the OpenWRT here and as I see, there is not official support for this router at this moment. But maybe I miss.

Correct, there is no support in trunk for this router, neither in CC. Happy to help if someone wants to get this working.

-w-

aliexpress.com/item/1200Mbps-802-11AC-Wireless-WiFi-Router-2-4G-5G-Dual-Band-Wireless-WIFI-Repeater-4-7dBi/32688177290.html

Here's the link to the router I bought, maybe I can flash it with something else which has all options as this is really like with half-functionalities.

wigyori wrote:

Correct, there is no support in trunk for this router, neither in CC. Happy to help if someone wants to get this working.

-w-

You sure there is no way? If the manufacturer has put OpenWrt they must have used some firmware which we can re-flash.

TIA!

coolraghav wrote:

I somehow feel everything related to my router should show here /snapshots/trunk/ramips/mt7620/ but which one should I download so it works fine as the model I have doesn't show there as its OEM type router.

It looks like a ZBT-product, very similar (identical ?) to a ZBT-826. Which is officially supported.
ZBT is very helpful, so you might contact them directly.
Or, in case you are a brave man, try to flash an official openwrt/LEDE ZBT-826 image :-)

augustus_meyer wrote:
coolraghav wrote:

I somehow feel everything related to my router should show here /snapshots/trunk/ramips/mt7620/ but which one should I download so it works fine as the model I have doesn't show there as its OEM type router.

It looks like a ZBT-product, very similar (identical ?) to a ZBT-826. Which is officially supported.
ZBT is very helpful, so you might contact them directly.
Or, in case you are a brave man, try to flash an official openwrt/LEDE ZBT-826 image :-)

Thanks! So I flashed a firmware and it is working fine, though I am not able to connect to internet as when I put my adsl cable to WAN port the router gives IP of adsl modem. When I remove it, the router gives its own IP but then there's no internet hence I cannot install luci or anything else via SSH...

what to do?

@coolraghav: You are new to the forum and possibly do not yet know how to reply correctly.
When answering, you do not need to quote the whole message. It's sufficient if you hit "Post reply".

@tmo26, next time will see to it.. Thanks ..do you have the solution?

This is Done from ZBT.
We don't update our own firmware on the openwrt.org, as our customer normally will build their own firmware for the routers, we are OEM manufacturer.
I think the hardware is ZBT-WE1826?
If yes, you could try the below firmware:
openwrt-15.05-ramips-mt7620-xiaomi-miwifi-mini-squashfs-sysupgrade.bin
It works well.

Hi - i just confirm that openwrt-15.05.1-ramips-mt7620-xiaomi-miwifi-mini-squashfs-sysupgrade.bin installed well

(Last edited by painfull30 on 19 Jul 2017, 13:18)

Hi All,

I have this router, where can I download the above mentioned firmware from? I have been seaching through the main site and cannot find this speific .bin file

Justin

justinj wrote:

Hi All,

I have this router, where can I download the above mentioned firmware from? I have been seaching through the main site and cannot find this speific .bin file

Justin

example of working link for firmware image (it is zbt-826 with 5ghz if any, 4 antennas it have, metal case etc)

1) via ssh\sysupgtade lede NOT INSTALL (from default factories openwr14 i mean)
2) via https://wiki.openwrt.org/toh/zbt/we-826#debricking failover all ok!

p.s. - as i know pci-e modem in lede showes lower LTE speed than factories openwrt14

(Last edited by painfull30 on 12 Feb 2018, 18:59)

The discussion might have continued from here.