OpenWrt Forum Archive

Topic: Package names containing illegal characters

The content of this topic has been archived on 30 Mar 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.


I just checked out trunk and tried compiling it, but I'm stuck with the following error message:

PATH="/home/mkortela/B/wrt54g3g/trunk/openwrt/staging_dir_mipsel/usr/bin:/home/mkortela/B/wrt54g3g/trunk/openwrt/staging_dir_mipsel/bin:/bin:/sbin:/usr/bin:/usr/sbin" ipkg-build -c -o root -g root /home/mkortela/B/wrt54g3g/trunk/openwrt/build_mipsel/linux-2.6-brcm/linux-modules/ipkg/ipv6 /home/mkortela/B/wrt54g3g/trunk/openwrt/bin/packages
*** Error: Package name  contains illegal characters, (other than [a-z0-9.+-])

In fact, it seems that every package that contains a 'v' or a 'w' character will spill an error. Strange?! I can get further by changing the package name in the control file, but there must be a better way to do it?

What do you think could be wrong? I'm doing the compilation on a Ubuntu x86 machine.

Can you indicate which package are you attempting to build ? Thanks a lot in advance.

I just ran "make menuconfig" and after that "make". The compilation stopped at kmod-ipv6. I can only get through by editing the control file of the ipkg. I renamed it "kmod-ip6" and no error, then. The next package it stopped at was kmod-fs-vfat, which was corrected by renaming it to kmod-fs-fat. And so on. If the package name contains either a 'v' or a 'w', ipkg-build will throw an error. I also tried checking out whiterussian, but it has the same problem. It's the same if I run the compilation as myself or as root. I had no ipkg-build installed before so it can't be that, either.

I just can't understand where this comes from...

I had the chance to test the compilation on another machine. It was a gentoo server. I used exactly the same procedures as with the Ubuntu, but the compilation was successful without any errors.

That's great, but I would still like to know what could possibly be the source of the problem on the Ubuntu machine. Does ipkg-build use some library for doing the regexp on the package name?

kortzi wrote:

Does ipkg-build use some library for doing the regexp on the package name?

ipkg-build just uses grep to check if the package name contains illegal characters.
What does the command below returns on your system ?

echo kmod-ipv6 | grep '[^a-z0-9.+-]'

The discussion might have continued from here.