OpenWrt Forum Archive

Topic: Cant upload OpenWrt onto TP-Link WR1043ND even though wiki says its ok

The content of this topic has been archived on 4 May 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Stock Firmware Version:    
3.16.9 Build 160122 Rel.38384n

Hardware Version:    
WR1043ND v3 00000000

OpenWrt Version:
openwrt-15.05.1-ar71xx-generic-tl-wr1043nd-v2-squashfs-factory.bin

Wiki Page:
wiki.openwrt.org/toh/hwdata/tp-link/tp-link_tl-wr1043nd_v2

Problem:
When i go into stock firmware to firmware upgrade page and select the .bin, it shows it as selected, then i click upload it says "please select firmware to upload" like i didnt select anything.

Is there a 3rd party tool i can upload this with?

Hardware Version: WR1043ND v3
vs
openwrt-15.05.1-ar71xx-generic-tl-wr1043nd-v2-squashfs-factory.bin

...spot the difference

What does the hardware version have to do with the fact the stock firmware wont even recognize the file?

I followed instructions on there to force openwrt onto it

:!: NOTE: For revision v3.0, stock FW 3.16.9 build 150514: With the current stock TP-Link firmware it's not possible to flash the current stable OpenWrt Chaos Calmer 15.05.1 release for v2 routers. The web interface keeps complaining, that filename and version do not match. Since the hardware of v3 is basically identical to v2, the only problem is the version check during the firmware upgrade. But there is an easy workaround:

    1. Install the current OpenWrt trunk version for v3 via the TP-Link web interface


THIS DOES NOT WORK IT STILL COMPLAINS ABOUT FILENAME MISMATCH USING THE FILES THEY LINKED!

I tried the hex edit trick to change versions and it still does not work.

How to flash Chaos Calmer (15.05) into the V3 version with the V2 OpenWRT factory file

Since there is another TP-Link software installed on the V3 version of the router which does not accept the firmware file for the V2 version it is not possible to install CC on it.
But there is a little trick to install it anyways.

    Download the V2 version

    Change with an Hex editor the version number in the header of the file from 02 to 03 and save the file. It is located in byte 43.


    Rename the file to "wr1043v3_tp_recovery.bin" and flash it via tftp how described above

^^^^^^^^^^^^This does not work

Founds this guy with same problem trying to make ddwrt work, this was a week ago, no one has responded, figures no one cares but ill leave this here as warning to others not to buy hardware based on wiki as its not accurate

Model No. TL-WR1043ND:
Firmware Version:
3.16.9 Build 160122 Rel.38384n
Hardware Version:
WR1043ND v3 00000000
Just got my TL-WR1043ND a few days ago with the intention of flashing to DD-WRT. I am also having the issues with ability to change to DD-WRT.

1: So far I have tried to webgui default interface only to get the "Error code 18005".

2: Next I tried the Reddit method by changing the name/save of the wireless SSID with "bash" commands. Once I was done with the last bash command/name the router slowed to a crawl, rebooted and reset to the default 192.168.0.1 along with admin/admin for login. I was already hooked up to the router via nic cable from my laptop, the laptop is the only thing connected to the router at this point. Took about 3-4 minutes for the router to assign my laptop an IP. I logged into the router via webgui interface and immediately it I lost connection to it and the LAN light went off. Waited about 5 more minutes and the Lan light came on but it would not respond when I would try to connect via webgui again 192.168.0.1. So I TFTP method to restore the latest firmware from TP-Link site (wr1043ndv3_us_3_16_9_up_boot(151021).bin) and was able to get my router back up and running, but it still is running
(3.16.9 Build 160122 Rel.38384n) according to the Webgui.

3: I went as far as TFTP method and tried to flash directly using factory-to-ddwrt.bin and tplink_tl-wr1043nd-v3.bin to no avail. Everytime it was complete it would still boot up with TP-Link Webgui showing 3.16.9 Build 160122 Rel.38384n on the status screen.

Still stuck at the moment, Thanks for any help, POP

(Last edited by DDWRTaway on 12 Feb 2017, 20:49)

The discussion might have continued from here.