I have a DIR-825 which I'm trying to configure as a kind of dumb AP. A router with DHCP is connected to the WAN port with address 192.168.0.1, and the DIR-825 has static address 192.168.0.2. Wifi works and gets ip addresses from the router on the WAN, so does anything connected to the LAN ethernet ports. I can easily access LuCI/ssh by going to 192.168.0.2.
When I try to update packages though, it fails. I can ping LAN addresses except for 192.168.0.1, for which the packets get lost. Trying to ping 8.8.8.8 gives me "ping: sendto: Network is unreachable". Here is the output of route:
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.0.0 * 255.255.255.0 U 0 0 0 br-lan
And here is /etc/config/network (with ula_prefx removed, I don't know if this is important or not), which seems to work, but is probably wrong somehow...:
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix '[ removed ]'
config interface 'lan'
option type 'bridge'
option _orig_ifname 'eth0.1 radio0.network1 radio1.network1'
option _orig_bridge 'true'
option proto 'static'
option gateway '192.168.0.1'
option ifname 'eth0.1 eth1'
option ipaddr '192.168.0.2'
option netmask '255.255.255.0'
option broadcast '192.168.0.1'
option dns '8.8.8.8'
config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'
config switch_vlan
option device 'switch0'
option vlan '1'
option ports '0 1 2 3 5t'
Please help!
Ash