Hello,
I'm trying to configure my new linksys router to connect to internet which is provided on a vlan. I have another openwrt router which connect very well, but I was not able to configure this one. I have the following switch configuration:
config interface 'lan'
option type 'bridge'
option proto 'static'
option netmask '255.255.255.0'
option ip6assign '60'
option ipaddr '192.168.2.1'
option _orig_ifname 'eth1 radio0.network1 wlan1'
option _orig_bridge 'true'
option ifname 'eth1.2 wlan1'
config interface 'wan'
option proto 'dhcp'
option _orig_ifname 'eth0'
option _orig_bridge 'true'
option delegate '0'
option ifname 'eth0.34'
option type 'bridge'
config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'
option enable_vlan4k '1'
config switch_vlan
option device 'switch0'
option vlan '2'
option ports '0 1 2 3 6t'
config switch_vlan
option device 'switch0'
option vlan '34'
option ports '4t 5t'
34 is the id of the VLAN i need to connect to. swconfig dev switch0 show shows that even though the cable is connected, the link is still down:
...
Port 4:
mask: 0x0000: (4)
qmode: 3
pvid: 0
link: port:4 link:down
Port 5:
mask: 0x0000: (5)
qmode: 3
pvid: 0
link: port:5 link:up speed:1000baseT full-duplex
Port 6:
mask: 0x0000: (6)
qmode: 3
pvid: 0
link: port:6 link:up speed:1000baseT full-duplex
VLAN 2:
port_based: 0
vid: 2
ports: 0 1 2 3 6t
VLAN 34:
port_based: 0
vid: 34
ports: 4t 5t
Can anyone point me to what is going wrong with this configuration?