Hi,
I need some help setting up the following config:
I want to use NORDVPN, but only from one ethernet interface on my router instead of my entire LAN zone. I already created a separate VLAN for that particular interface and I've created forwarding rules between my LAN zone and the new VLAN zone called SYN. I am able to access the device in the SYN zone and vice versa.
The next step I took was to set up the OpenVPN config for the NORDVPN service. I used the OpenWRT tutorial that's on the NORDVPN support site as a guideline to set up the VPN from that particular SYN interface/zone.
The tunnel seems to be up just fine, but the device in the SYN zone is unable to connect to the internet through the tunnel. I'm missing something and I don't know what.
Any ideas?
Here are the relevant parts of my configs.
Network:
config interface 'SYN'
option force_link '1'
option proto 'static'
option ipaddr '192.168.3.1'
option netmask '255.255.255.0'
option ip6assign '60'
option _orig_ifname 'eth1'
option _orig_bridge 'true'
option ifname 'eth1.11'
config interface 'WAN'
option proto 'dhcp'
option ifname 'eth0'
config interface 'nordvpntun'
option proto 'none'
option ifname 'tun0'
Firewall:
config zone
option name 'vpnfirewall'
option output 'ACCEPT'
list network 'nordvpntun'
option input 'REJECT'
option forward 'REJECT'
option masq '1'
option mtu_fix '1'
config forwarding
option dest 'wan'
option src 'lan'
config forwarding
option dest 'lan'
option src 'SYN'
config forwarding
option dest 'vpnfirewall'
option src 'SYN'
config forwarding
option dest 'SYN'
option src 'lan'
config rule
option enabled '1'
option target 'ACCEPT'
option src 'SYN'
option dest 'vpnfirewall'
option name 'SYN'