I am a total noob with OpenWrt but have a bit of experience with coding. I recently bought a Linksys WRT 1200ac V2 router and installed OpenWrt Chaos Calmer 15.05.1. My intention was to disable the diversity and configure the antennas on the router such that; one antenna is TX and the other antenna is RX.
I used the following commands to configure the antennas
1. First I disabled the radios in Luci
2. uci set wireless.radio1.diversity=0
3. uci set wireless.radio1.txantenna=1
4. uci set wireless.radio1.rxantenna=2
5. uci commit wireless
6. wifi
This is what i get when for the /etc/config/wireless file:
************************************************************************************************************************************
root@OpenWrt:/etc/config# cat wireless
config wifi-device 'radio0'
option type 'mac80211'
option channel '36'
option hwmode '11a'
option path 'soc/soc:pcie-controller/pci0000:00/0000:00:01.0/0000:01:00.0'
option htmode 'VHT80'
option country 'US'
option txpower '23'
config wifi-iface
option device 'radio0'
option mode 'ap'
option ssid 'OpenWrt'
option network 'lan'
option encryption 'psk2'
option key 'abcdefghijkl'
config wifi-device 'radio1'
option type 'mac80211'
option channel '11'
option hwmode '11g'
option path 'soc/soc:pcie-controller/pci0000:00/0000:00:02.0/0000:02:00.0'
option htmode 'HT20'
option country 'US'
option diversity '0'
option txantenna '1'
option rxantenna '2'
option txpower '0'
config wifi-iface
option device 'radio1'
option mode 'ap'
option ssid 'OpenWrt'
option network 'lan'
option encryption 'psk2'
option key 'abcdefghijkl'
************************************************************************************************************************************
I then turned back on the radios in Luci and tested to check if the antenna configuration has worked but it did not. I then checked the available antennas using the command: iw phy phy1 info
************************************************************************************************************************************
root@OpenWrt:/etc/config# iw phy phy1 info
Wiphy phy1
max # scan SSIDs: 4
max scan IEs length: 2242 bytes
Retry short limit: 7
Retry long limit: 4
Coverage class: 0 (up to 0m)
Available Antennas: TX 0 RX 0
Supported interface modes:
* managed
* AP
* AP/VLAN
* monitor
Band 1:
Capabilities: 0x6f
RX LDPC
HT20/HT40
SM Power Save disabled
RX HT20 SGI
RX HT40 SGI
No RX STBC
Max AMSDU length: 3839 bytes
No DSSS/CCK HT40
Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
Minimum RX AMPDU time spacing: 4 usec (0x05)
HT TX/RX MCS rate indexes supported: 0-15, 32
VHT Capabilities (0x33801931):
Max MPDU length: 7991
Supported Channel Width: neither 160 nor 80+80
RX LDPC
short GI (80 MHz)
SU Beamformer
SU Beamformee
RX antenna pattern consistency
TX antenna pattern consistency
VHT RX MCS set:
1 streams: MCS 0-9
2 streams: MCS 0-9
3 streams: not supported
4 streams: not supported
5 streams: not supported
6 streams: not supported
7 streams: not supported
8 streams: not supported
VHT RX highest supported: 0 Mbps
VHT TX MCS set:
1 streams: MCS 0-9
2 streams: MCS 0-9
3 streams: not supported
4 streams: not supported
5 streams: not supported
6 streams: not supported
7 streams: not supported
8 streams: not supported
VHT TX highest supported: 0 Mbps
Frequencies:
* 2412 MHz [1] (30.0 dBm)
* 2417 MHz [2] (30.0 dBm)
* 2422 MHz [3] (30.0 dBm)
* 2427 MHz [4] (30.0 dBm)
* 2432 MHz [5] (30.0 dBm)
* 2437 MHz [6] (30.0 dBm)
* 2442 MHz [7] (30.0 dBm)
* 2447 MHz [8] (30.0 dBm)
* 2452 MHz [9] (30.0 dBm)
* 2457 MHz [10] (30.0 dBm)
* 2462 MHz [11] (30.0 dBm)
* 2467 MHz [12] (disabled)
* 2472 MHz [13] (disabled)
* 2484 MHz [14] (disabled)
valid interface combinations:
* #{ AP } <= 16, #{ managed } <= 1,
total <= 16, #channels <= 1, radar detect widths: { 20 MHz (no HT), 20 MHz, 40 MHz, 80 MHz }
HT Capability overrides:
* MCS: ff ff ff ff ff ff ff ff ff ff
* maximum A-MSDU length
* supported channel width
* short GI for 40 MHz
* max A-MPDU length exponent
* min MPDU start spacing
************************************************************************************************************************************
I noticed that the available antennas are assigned TX0 and RX0 which if I am not mistaken means that there are no antennas available for configuration. How do I enable antenna configuration for my router? Is there something I am missing or you cannot configure antennas for this device?
Thanks in advance