OpenWrt Forum Archive

Topic: Setting up 2 SSID on 2 bridges fails

The content of this topic has been archived on 29 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Dear community,

today I digged up my Linksys WRT54GS v1 router [1] and put Chaos Calmer 15.05 for BCM47xx on it.  I use the broadcom-wl driver [2].

I want the device to act as two WiFi access points (APs):

AP 1 with SSID "home" connected to the Ethernet ports 1 - 4 (VLAN 1, eth0.1) on network 192.168.31.0/24
AP 2 with SSID "let" connected to the Ethernet port "Internet" (VLAN 2, eth0.2) on network 192.168.35.0/24

I created two bridges: the first "br-home" bridging WiFi "home" to VLAN 1, the second "br-let" bridging WiFi "let" to VLAN 2 using Luci.

WiFi is not added to the bridge "br-let" and adding it manually fails:

root@linksys:~# brctl show
bridge name     bridge id               STP enabled     interfaces
br-home         7fff.000f66c78618       no              eth0.1
                                                        wl0
br-let          8000.000f66c78618       no              eth0.2
root@linksys:~# brctl addif br-let wl0
brctl: bridge br-let: Device or resource busy

Any help to resolve this issue is greatly appreciated.

Please see below for config files.

Best regards
Boris


[1] htt ps://wiki.openwrt.org/toh/linksys/wrt54g
[2] htt ps://wiki.openwrt.org/doc/hardware/soc/soc.broadcom.bcm47xx#broadcom-wl


/etc/config/network

config switch 'eth0'
        option name 'adm6996_gpio'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'adm6996_gpio'
        option vlan '1'
        option ports '1 2 3 4 5t'

config switch_vlan
        option device 'adm6996_gpio'
        option vlan '2'
        option ports '0 5t'

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd7d:5aab:e89a::/48'

config interface 'home'
        option type 'bridge'
        option proto 'static'
        option ifname 'eth0.1'
        option ipaddr '192.168.31.122'
        option netmask '255.255.255.0'
        option gateway '192.168.31.1'
        option metric '1'
        option dns '192.168.31.1'
        option ip6assign '64'

config interface 'let'
        option type 'bridge'
        option proto 'static'
        option ifname 'eth0.2'
        option ipaddr '192.168.35.122'
        option netmask '255.255.255.0'
        option gateway '192.168.35.1'
        option metric '2'
        option dns '192.168.31.1'
        option ip6assign '64'

/etc/config/wireless

config wifi-device 'wl0'
        option type 'broadcom'
        option txantenna '3'
        option rxantenna '3'
        option hwmode '11g'
        option channel 'auto'
        option txpower '24'

config wifi-iface
        option device 'wl0'
        option mode 'ap'
        option ssid 'home'
        option encryption 'psk2'
        option key 'hidden'
        option network 'home'

config wifi-iface
        option device 'wl0'
        option mode 'ap'
        option network 'let'
        option ssid 'let'
        option encryption 'psk2'
        option key 'hidden'

eth0.2 is your wan interface, do you want to create bridge, containing it?

ulmwind wrote:

eth0.2 is your wan interface, do you want to create bridge, containing it?

Correct. The device is not intended to work as as router but as a switch/AP plus second AP.

The device will be situated behind a firewall. The firewall will provide two subnets ("home" and "let") on two of its ethernet ports. The "home" network will be connected to LAN port 1 of the device and visible through the "home" WiFi network, the "let" network will be connected to the "Internet/WAN" port of device and visible through the "let" WiFi network.

The discussion might have continued from here.