OpenWrt Forum Archive

Topic: USR8200 Chaos Calmer 15.05.1 - SSH or Luci reboot freezes

The content of this topic has been archived on 4 May 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

(Tried to create a ticket, but website rejects it as spam).


The ONLY way to reboot it is to push hardware button. (Which is disaster if you're not next to the unit)

In all other cases (SSH, Luci or Serial) boot process stuck at the moment when image uncompressing should start (saw it using serial connection).
At this moment PWR lights GREEN and process freezes.

(Last edited by portuquesa on 1 Oct 2017, 18:58)

OK, this is what happens:

WORKING OUTPUT (hardware reset button is pushed):

RedBoot> mfill -b 0xc8004004 -l 4 -p 0x1ff0 -4
RedBoot> mfill -b 0xc8004000 -l 4 -p 0x600f -4
RedBoot> fis load linux
RedBoot> exec
Using base address 0x00024c00 and length 0x00123d60
Uncompressing Linux... done, booting the kernel.

Trying NPE-B...success. Using NPE-B with PHY 9.
Trying NPE-C...success. Using NPE-C with PHY 16.

...and continues booting OK
 
 
WHEN IT HALTS (through Luci reboot):

RedBoot> mfill -b 0xc8004004 -l 4 -p 0x1ff0 -4
RedBoot> mfill -b 0xc8004000 -l 4 -p 0x600f -4
RedBoot> fis load linux
RedBoot> exec
Using base address 0x00024c00 and length 0x00123d60
Uncompressing Linux... done, booting the kernel.

...and booting freezes



I THINK IT'S ALL ABOUT BOOT SCRIPT, but I'm not sure. How does it matter - was reboot performed by hardware button push, or via Luci?

Probably we need some DELAY between items in boot script? (what's the command in this case?)

fis load linux
...DELAY...
exec

Or there's something else?




PS JUST tested with LEDE 17.01.4.
SAME STORY ((

(Last edited by portuquesa on 29 Apr 2018, 16:19)

kick

The discussion might have continued from here.