Hello everyone,

I have been using DDWRT for quite some time (absolutely love it) and I recently picked up a WNDR3700 because I knew it was supported, as long as you didn't have the V5 model. Well I ended up with the V5 model and I found out sadly DDWRT is not supported, but there were rumors that you could install LEDE on it, but the documentation from: ht tps://forum.openwrt.org/viewtopic.ph … 37&p=1 was a little scattered and hard to follow.

Here is a step by step of how to install the most recent version of LEDE on your WNDR3700V5.
NOTE: I am not responsible for any damage/bricking of your router, all these steps have been performed on my router that was running the firmware version: This in theory should work regardless of the firmware version.

NOTE: I did not write the code behind this, build the binary images, or do any of the development on this router. I am simply providing some documentation on how to get LEDE on this router in the hopes of helping others.

INFO: I had to put a space between ht tp because I cannot post links, you will have to fix this when copying links.

Step#1 Enable Telnet
Enabling telnet on this router is fairly simple, grab the telnetenable.exe from: ht tps://github.com/insanid/NetgearTeln … Enable.exe

Plug the your Desktop/Loptop into the one of the LAN ports on the back of the device, you can leave your Network IP settings the way they are. Ensure going to opens Netgears web interface.

Open CMD and type

arp -a

You should see a entry like this:

Internet Address      Physical Address      Type           c6-84-4b-4e-xx-xx     dynamic

Run telnetenable.exe with the following options:

telnetenable.exe PHYSICALADDRESS admin password

NOTE: You must enter what arp -a says is the physical address in this format: C6844B4EXXXX. You also must capitalize each character for this to work. Also, don't change your web login info! It should be admin password.


telnetenable.exe C6844B4EXXXX admin password

Now in CMD type:


NOTE: You will have to enable the telnet client on Windows if you haven't already. Just google "Windows cmd enable telnet"

You should be greeted with a # and a root terminal after running the telnet command.

Step#2 Replace bootloader
You will want to replace your bootloader on this device in case you run into trouble. This bootloader has a web recovery interface that allows us to upload binary images, this is important.

In the # root terminal we just opened via telnet and CMD (in the previous step), type:

cd media

NOTE: We have to cd to media because we need a place where we can read/write to the filesystem.

Plug a ethernet cable with internet into the WAN port (yellow one) on the back of the router and wait a few seconds. You should see the globe icon on the router light up, the router will need internet for this step.

Run the following command after the router shows on the front that it has internet:

wget ht tp://xdd.co/router/pb-uboot-wndr3700v5.bin

wget should say completed or something similar. If it says read only filesystem it means you have not yet ran this command:

cd media

NOTE: You may also use this bootloader: ht tps://github.com/pinney/MT7621-u-boo … _uboot.bin   I have not tested this, but someone else said it was working from the thread I linked to at the very top of this post. I ran the bootloader from the command above, and it worked great.

INFO: If you want to use the alternative bootloader, run this command:

wget ht tp://raw.githubusercontent.com/pinney/MT7621-u-boot-mod/master/bin/MT7621S_uboot.bin

Now that you have your bootloader downloaded on the routers filesystem, you will need to run this command:

mtd_write write pb-uboot-wndr3700v5.bin Bootloader

INFO: If you used the alternative bootloader, you will need to use this command:

mtd_write write MT7621S_uboot.bin Bootloader

Step#3 Enter Web Recovery

NOTE: Before turning off the router, unplug the Ethernet cable in the wan port on the back of the router (yellow one)

Now turn off the router (make sure the Ethernet cable in the wan port is unplugged) by pressing the power button on the back and letting the router completely power off. Take a paper clip or pen and press and hold the reset button on the back of the router, DO NOT LET GO OF THE RESET BUTTON YET. While holding the reset button, push in the power button and let the router begin to turn on. The power LED should start flashing. Wait 10 seconds and release the reset button.

With 10 seconds waited, and the reset button being released, the router power LED will continue to flash. This is normal. You should have the Ethernet cable from your Desktop/Laptop still plugged into the router and the Ethernet cable that was going into the WAN port (yellow one) on the router unplugged.

Change your Desktop/Laptop's network settings to have a static ip of, and a gateway of You may be able to get away with not doing this, but this is what I did and it worked.

Step#4 Install LEDE
Download the following bin file: ht tps://downloads.lede-project.org/rel … pgrade.bin

Navigate to with your web browser, you should see a screen that says: "Pandorbox" and recovery. Select the bin file you downloaded and click upgrade/flash.

NOTE: If you do not see the recovery screen and you enter the Netgear web interface again, go back to Step#3 and refollow the last portion very carefully. You don't have to flash the bootloader again.

Once the recovery web interface begins flashing your router DO NOT TURN IT OFF or unplug anything, leave it be. This may take about 4-5 minutes. I think mine took maybe 3. Let it do it's job. Set a timer for 5 minutes, and come back.

The power LED may be off, the router isn't off don't worry. You should be able to now type again in a new tab and be welcomed by the LEDE web interface. If you don't see it, wait a minute or two more and try powering off the router and turning it back on. You shouldn't have to though.

I hope this helps and I really hope no one accidentally bricks their device doing this, I followed these steps and it worked for me. Let me know if you run into any problems. Be sure to thank everyone from the LEDE team who put together these binaries and thank you to: hikey and ldpinney, you guys really helped me!


(Last edited by civilwarrock on 4 Oct 2017, 23:55)