OpenWrt Forum Archive

Topic: Router connects to internet, but devices are 'connected, no internet'

The content of this topic has been archived on 2 May 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

I've been struggling the past week or so to get this all properly configured. My goal for all of this is to have a dual AP + Client setup for my router. I have the client totally setup and it can connect to my local WIFI network no problem and access the internet. Also I have an ethernet connection that also works with no problems. My issue is that any devices that connect to the AP put out by the router connect but are not given access to the wan.

This is my etc/config/wireless

config  'wifi-iface'
        option  'device'        'radio0'
        option  'network'       'lan'
        option  'mode'  'ap'
        option  'ssid'  'MLoggertest'
        option  'encryption'    'none'

config 'wifi-iface'
        option 'device' 'radio0'
        option 'network' 'wwan'
        option 'mode' 'sta'
        option 'ssid' 'MSI WiFi 2.4Ghz'
        option 'encryption' 'psk'
        option 'key' 'password'

config wifi-device  radio0
        option type     mac80211
        option channel  11
        option hwmode   11g
        option path     'pci0000:00/0000:00:03.0'

/etc/config/network

config 'interface' 'loopback'
        option 'ifname' 'lo'
        option 'proto' 'static'
        option 'ipaddr' '127.0.0.1'
        option 'netmask' '255.0.0.0'

config 'interface' 'lan'
        option 'ifname' 'eth0'
        option force_link '1'
        option 'type' 'bridge'
        option 'proto' 'static'
        option 'ipaddr' '192.168.123.254'
        option 'netmask' '255.255.255.0'
        option 'ipassign' '60'

config 'interface' 'wwan'
        option 'proto' 'dhcp'

config 'interface' 'wan'
        option 'ifname' 'eth1'
        option 'proto' 'dhcp'

config interface 'wifi'
        option 'proto' 'dhcp'

config 'interface' '3G'
        option 'proto' '3g'
        option 'service' 'evdo'
        option 'device' '/dev/ttyACM3'
        option 'maxwait' '0'

/etc/config/firewall

config 'defaults'
        option 'syn_flood' '1'
        option 'input' 'ACCEPT'
        option 'output' 'ACCEPT'
        option 'forward' 'REJECT'

config 'zone'
        option 'name' 'lan'
        option 'network' 'lan'
        option 'input' 'ACCEPT'
        option 'output' 'ACCEPT'
        option 'forward' 'REJECT'

config 'zone'
        option 'name' 'wan'
        list 'network' 'wan'
        list 'network' 'wan6'
        list 'network' 'wwan'
        option 'input' 'REJECT'
        option 'output' 'ACCEPT'
        option 'forward' 'ACCEPT'
        option 'masq' '1'
        option 'mtu_fix' '1'
        option 'network' 'wan 3G'

config 'zone'
        option name wifi
        list    network 'wifi'
        option input ACCEPT
        option output ACCEPT
        option forward REJECT

config 'forwarding'
        option 'src' 'wifi'
        option 'dest' 'wan'

config 'forwarding'
        option 'src' 'lan'
        option 'dest' 'wan'

config 'rule'
        option 'src' 'wan'
        option 'proto' 'udp'
        option 'dest_port' '68'
        option 'target' 'ACCEPT'
        option 'family' 'ipv4'

config 'rule'
        option 'src' 'wan'
        option 'proto' 'icmp'
        option 'icmp_type' 'echo-request'
        option 'target' 'ACCEPT'

config 'include'
        option 'path' '/etc/firewall.user'

/etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
#       option rebind_protection '1'
        option rebind_protection '0'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'
        option localservice '1'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv6 'server'
        option ra 'server'

config dhcp 'wan'
        option interface 'wan'
        option start '150'
        option limit ' 200'
        option leasetime '12h'
        option dhcpv6 'server'
        option ra 'server'
#       option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'

config 'dhcp' 'wifi'
        option 'interface' 'wifi'
        option 'start' '100'
        option 'limit' '150'
        option 'leasetime' '12h'
        option 'dhcpv6' 'server'
        option 'ra' 'server'

output of ifconfig

br-lan    Link encap:Ethernet  HWaddr 00:D0:12:06:EE:2E
          inet addr:192.168.123.254  Bcast:192.168.123.255  Mask:255.255.255.0
          inet6 addr: fe80::2d0:12ff:fe06:ee2e/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2071 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1249 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:145551 (142.1 KiB)  TX bytes:96475 (94.2 KiB)

eth0      Link encap:Ethernet  HWaddr 00:D0:12:06:EE:2E
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1352 errors:0 dropped:0 overruns:0 frame:0
          TX packets:562 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          RX bytes:98826 (96.5 KiB)  TX bytes:43732 (42.7 KiB)

eth1      Link encap:Ethernet  HWaddr 00:D0:12:06:EE:30
          inet addr:10.20.30.188  Bcast:10.20.30.255  Mask:255.255.255.0
          inet6 addr: fe80::2d0:12ff:fe06:ee30/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:15609 errors:0 dropped:272 overruns:0 frame:0
          TX packets:3423 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          RX bytes:1520849 (1.4 MiB)  TX bytes:430322 (420.2 KiB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:2991 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2991 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:243454 (237.7 KiB)  TX bytes:243454 (237.7 KiB)

wlan0     Link encap:Ethernet  HWaddr 00:15:6D:67:AA:A4
          inet addr:10.20.30.243  Bcast:10.20.30.255  Mask:255.255.255.0
          inet6 addr: fe80::215:6dff:fe67:aaa4/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:4372 errors:0 dropped:12 overruns:0 frame:0
          TX packets:906 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:662787 (647.2 KiB)  TX bytes:104235 (101.7 KiB)

wlan0-1   Link encap:Ethernet  HWaddr 02:15:6D:67:AA:A4
          inet6 addr: fe80::15:6dff:fe67:aaa4/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:286 errors:0 dropped:0 overruns:0 frame:0
          TX packets:284 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:22522 (21.9 KiB)  TX bytes:26358 (25.7 KiB)

contents of my /tmp/dhcp.leases

1505060791 ac:37:43:50:b5:4e 192.168.123.230 * 01:ac:37:43:50:b5:4e

I would appreciate any help that anyone might be able to give. Thanks in advance

(Last edited by zlb323 on 2 Nov 2017, 16:14)

Turn off DHCP v6 on the LAN ('dhcpv6 and 'ra' set to 'disabled').  Make sure the only physical device in the wwan is the wifi client.  Check on the main status page that wwan acquired an IP address from its AP.  Make sure that IP is not in the same range as your LAN.

Usually I just set up a wifi client, and attach it to the existing wan network that is set up by default, removing any Ethernet port etc.  Then there is no need to modify the firewall.

The discussion might have continued from here.