Hi,

I have this router from my provider where I have access to OpenWRT with root SSH
In GUI there is no option for bridge mode, so I would like to change it to bride, so I have eth3 together with the WAN DSL side.  But the rest is still usable, wifi together with eth0-2.  this way I can send bridge eth3 into pfsense box and from that into eth0 so I can use the WIFI part still.  I have been researching on the net and there is a recommendation to create a new bridge interface like this:
config interface 'adsl_wan'
        option type 'bridge'
        option ip6hint '0'
        option force_link '0'
        list ifname 'eth4'
        list ifname 'eth3'
        list ifname 'atm_8_35'     (would mine be "vlan_data") ??
        list ifname 'ptm0'
Then remove vlan_eth3 from interface "lan"   ??
And possible disable DHCP

any help or info would be appreciated, Thanks..

Original network file:
config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'
    option default_ps '0'

config interface 'lan'
    option type 'bridge'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'
    option force_link '0'
    option ip6hint '0'
    option igmp_snooping '0'
    option ipv6 '1'
    option ip6assign '64'
    option ifname 'vlan_eth0 vlan_eth1 vlan_eth2 vlan_eth3'
    list pppoerelay ''

config interface 'Guest1'
    option proto 'static'
    option ip6assign '64'
    option ipv6 '1'
    option ip6hint '1'
    option netmask '255.255.255.128'
    option ipaddr '192.168.168.126'
    option ifname 'wl0_1'
    option force_link '0'

config interface 'Guest1_5GHz'
    option proto 'static'
    option ip6assign '64'
    option ipv6 '1'
    option ip6hint '2'
    option netmask '255.255.255.128'
    option ipaddr '192.168.168.254'
    option ifname 'wl1_1'
    option force_link '0'

config device 'vlan_eth0'
    option type '8021q'
    option ifname 'eth0'
    option name 'vlan_eth0'
    option vid '1'

config device 'vlan_eth1'
    option type '8021q'
    option ifname 'eth1'
    option name 'vlan_eth1'
    option vid '1'

config device 'vlan_eth2'
    option type '8021q'
    option ifname 'eth2'
    option name 'vlan_eth2'
    option vid '1'

config device 'vlan_eth3'
    option type '8021q'
    option ifname 'eth3'
    option name 'vlan_eth3'
    option vid '1'

config device 'phy_eth3'
    option name 'eth3'
    option mtu '1500'

config switch 'bcmsw_int'
    option reset '1'
    option type 'bcmsw'
    option qosimppauseenable '0'
    option unit '0'
    option enable_vlan '0'

config switch 'bcmsw_ext'
    option reset '1'
    option type 'bcmsw'
    option qosimppauseenable '0'
    option unit '1'
    option enable_vlan '1'

config switch_vlan
    option device 'bcmsw_ext'
    option vlan '1'
    option ports '1* 2* 3* 4* 8t'

config interface 'hotspot'
    option type 'bridge'
    option ifname 'gre-hotspot'

config interface 'wan'
    option auto '0'
    option proto 'dhcp'
    option reqopts '1 3 6 15 33 42 43 51 121 249'
    option ip4table 'main'
    option ifname 'vlan_data'
    option vendorid '**************_RGW|VANT-R|CP1635UARD4|VDSL|wan|vlan101'

config interface 'wan6'
    option ifname '@wan'
    option proto 'dhcpv6'
    option reqopts '12 21 22 23 24 25 31 56 64 67 82 83'
    option noslaaconly '1'
    option iface_464xlat '0'

config interface 'debug'
    option auto '0'
    option proto 'dhcp'
    option reqopts '1 3 6 15 33 42 43 51 121 249'
    option ifname 'ptm0'
    option vendorid '*************_RGW|VANT-R|CP1635UARD4|VDSL|debug|ptm0'

config interface 'wwan'
    option auto '1'
    option metric '10'
    option proto 'mobiled'
    option session_id '0'
    option profile '1'

config interface 'voip'
    option auto '0'
    option proto 'dhcp'
    option ip4table 'voip'
    option reqopts '1 3 6 15 33 42 51 121 249'
    option iface6rd '0'
    option dnsset 'voip'
    option ifname 'vlan_voip'
    option vendorid '********_RGW|VANT-R|CP1635UARD4|VDSL|voip|vlan34'

config device 'phy_eth4'
    option name 'eth4'
    option mtu '2000'

config device 'phy_ptm0'
    option name 'ptm0'
    option mtu '2000'

config device 'vlan_data'
    option type '8021q'
    option ifname 'ptm0'
    option name 'vlan_data'
    option vid '101'

config device 'phy_atm'
    option name 'atm_wan'
    option mtu '2000'

config device 'vlan_voip'
    option type '8021q'
    option ifname 'ptm0'
    option name 'vlan_voip'
    option vid '34'
    option macaddr '************'
    option mtu '1500'