Hello!
I've been trying to set up a VPN server on a router with OpenWrt installed
I can successfully connect to the VPN and ping and traceroute work from the client. However I don't seem to get internet access through the VPN. DNS also seems to work just fine. Using Wireshark it does look like some tcp traffic goes through, so doesn't look like a Firewall problem. However I can't seem to be able to create a connection through the VPN.
Could you please help me out? I've disabled the firewall on the server side to make sure it's not the culprit.
Here is my server config:
ca /etc/openvpn/ca.crt
cert /etc/openvpn/my-server.crt
dev tun
dh /etc/openvpn/dh2048.pem
keepalive 10 120
key /etc/openvpn/my-server.key
port 1194
proto udp
server 10.8.0.0 255.255.255.0
verb 3
push route 192.168.1.0 255.255.255.0
push redirect-gateway def1
And my network setup on the server side:
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'config globals 'globals'
option ula_prefix 'fdc3:aa38:426c::/48'config interface 'lan'
option ifname 'eth0'
option force_link '1'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'config interface 'wan'
option ifname 'eth1'
option proto 'dhcp'
option peerdns '0'
option dns '8.8.8.8 8.8.4.4'config interface 'wan6'
option ifname 'eth1'
option proto 'dhcpv6'config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'config switch_vlan
option device 'switch0'
option vlan '1'
option ports '0 1 2 3 4'config interface 'vpn0'
option _orig_ifname 'tun0'
option _orig_bridge 'false'
option ifname 'tun0'
option proto 'none'
(Last edited by deerss on 24 Dec 2017, 13:30)