Hi All,
I am using openwrt on am3351 as a wifi AP+STA device. I have my wireless configuraion which will configure my network card as both AP and STA. My issue is that all the new network changes are reflecting only after reboot.
ie, I have connected my device to network "WifiHome1". And i can browse the Luci Web interface, scan for other networks and try to connect another network , say "WifiHome2". But the wifi connection will be reflected only after the device reboot. I have tried manually the "wifi" command in the shell. still the same.
This issue happens only if i have configuration for both AP+STA in my wireless configuration. If i have only STA configuration network swiching without restarting is working like charm.
my wireless configuration is as below
config wifi-device 'wlan0'
option type 'mac80211'
option path 'platform/ocp/47810000.mmc/mmc_host/mmc1/mmc1:0001/mmc1:0001:1'
option txpower '20'
option country '00'
option hwmode '11g'
option disabled '0'
option channel '11'
config wifi-iface
option ssid 'AzeemHome'
option encryption 'none'
option device 'wlan0'
option mode 'sta'
option network 'wwan'
option bssid 'XX:XX:XX:XX:XX:XX'
config wifi-iface 'ap'
option device 'wlan0'
option mode 'ap'
option network 'lan'
option ssid 'HomeWifi'
option encryption 'none'
option wait '20'