OpenWrt Forum Archive

Topic: keepalive_adaptive

The content of this topic has been archived on 18 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Form what I have read so far, OpenWRT support adaptive keepalive on PPPoE connections...

How to enable/disable that feature?

P.S: I use TP-Link TL-MR3220, and I have installed OpenWRT and Luci on it today.
I did try to find it before asking here, but other than information that it is supported, I could not find how to activate it...

I have find this on lede-project, and if anyone can confirm that adding option pppd_options 'lcp-echo-adaptive' to /etc/config/network is actualy that what I am looking for?

wan section in /etc/config/network is now like this

config interface 'wan'
        option ifname 'eth1'
        option _orig_ifname 'eth1'
        option _orig_bridge 'false'
        option proto 'pppoe'
        option username 'XXXXX'
        option password 'XXXXX'
        option keepalive '3 20'
        option pppd_options 'lcp-echo-adaptive'

(Last edited by neko on 13 Jan 2018, 17:49)

The discussion might have continued from here.