I started using OpenWRT about a year ago, when I heard that my ISP (Spectrum) was supporting IPV6, and I couldn't get it working on DD-WRT.  OpenWRT had it up and running pretty much out-of-the-box, with public IPV6 addresses being assigned to all of my devices that could take one.

I recently decided to segregate my network into multiple VLANs for reasons that I won't go into here unless someone really wants to know.  There are, at this point, eight interfaces in place, not counting loopback, wan or wan6.

The problem now is that my IPV6 connectivity doesn't work on the new interfaces, and stopped working on the default LAN interface as well (which I'm not using anyway).  This leaves me wondering how to get this back up and running again. 

What would be a good starting point? 

Router is a Netgear WNDR3700. 

/etc/config/network follows:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd92:41df:55f4::/48'

config interface 'lan'
        option ifname 'eth0.1'
        option force_link '1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth1'
        option proto 'dhcp'

config interface 'wan6'
        option ifname 'eth1'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'
        option blinkrate '2'
        option enable_vlan4k '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 5t'

config switch_port
        option device 'switch0'
        option port '1'
        option led '6'

config switch_port
        option device 'switch0'
        option port '2'
        option led '9'

config switch_port
        option device 'switch0'
        option port '5'
        option led '2'

config switch_vlan
        option device 'switch0'
        option ports '0t 5t'
        option vlan '10'

config switch_vlan
        option device 'switch0'
        option ports '1 5t'
        option vlan '20'

config switch_vlan
        option device 'switch0'
        option ports '3 5t'
        option vlan '30'

config switch_vlan
        option device 'switch0'
        option ports '2 5t'
        option vlan '31'

config switch_vlan
        option device 'switch0'
        option ports '0t 5t'
        option vlan '33'

config switch_vlan
        option device 'switch0'
        option ports '0t 5t'
        option vlan '41'

config interface 'trusted'
        option proto 'static'
        option ifname 'eth0.10'
        option ipaddr '10.81.10.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wireless'
        option proto 'static'
        option ipaddr '10.81.20.1'
        option netmask '255.255.255.0'
        option ip6hint '0020'
        option type 'bridge'
        option _orig_ifname 'eth0.20'
        option _orig_bridge 'true'
        option ifname 'eth0.20'
        option ip6assign '64'

config interface 'ooma'
        option proto 'static'
        option ifname 'eth0.30'
        option ipaddr '10.81.30.1'
        option netmask '255.255.255.0'
        option ip6hint '0030'
        option ip6assign '64'

config interface 'work'
        option proto 'static'
        option ifname 'eth0.33'
        option ipaddr '10.81.33.1'
        option netmask '255.255.255.0'
        option ip6hint '0033'
        option ip6assign '64'

config interface 'Admin'
        option proto 'static'
        option ifname 'eth0.41'
        option ipaddr '10.81.41.1'
        option netmask '255.255.255.0'
        option ip6hint '0041'
        option ip6assign '64'

config interface 'bluray'
        option proto 'static'
        option ifname 'eth0.31'
        option ipaddr '10.81.31.1'
        option netmask '255.255.255.0'
        option ip6hint '0031'
        option ip6assign '64'

config interface 'guest'
        option _orig_ifname 'wlan0-1'
        option _orig_bridge 'false'
        option proto 'static'
        option ipaddr '10.81.21.1'
        option netmask '255.255.255.0'
        option ip6assign '64'