Hi,
i'm using odhcp6c as dhcpv6 client on my router and not able to get address assigned to eth0 interface even though the serve has replied back. Below is my configuration
config interface loopback
option ifname lo
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0
config interface lan
option type bridge
option proto static
option ipaddr 192.168.1.254
option netmask 255.255.255.0
option ifname 'eth1 eth2 eth3'
option ip6assign '64'
option macaddr '00:10:18:00:00:07'
option is_lan '1'
config interface wan
option ifname 'eth0'
option type anywan
option macaddr '00:10:18:00:00:08'
option reqopts '43 66 67 128 132 224 225 226'
option reqprefix '64'
option reqaddress 'try'
option proto 'dhcp'
config interface 'wan6'
option proto 'dhcpv6'
option ifname '@wan'
option reqaddress 'try'
option reqprefix 'auto'
Error log :
=======
Jan 1 03:27:32 DPU504G_BCM380 odhcp6c[2049]: carrier => 0 event on eth0
Jan 1 03:27:32 DPU504G_BCM380 odhcp6c[2049]: Starting RELEASE transaction (timeout 4294967295s, max rc 5)
Jan 1 03:27:32 DPU504G_BCM380 odhcp6c[2049]: Send RELEASE message (elapsed 0ms, rc 0)
Jan 1 03:27:32 DPU504G_BCM380 odhcp6c[2049]: Failed to send DHCPV6 message to ff02::1:2 (Network is unreachable)
Jan 1 03:27:32 DPU504G_BCM380 odhcp6c[2049]: (re)starting transaction on eth0
Jan 1 03:27:32 DPU504G_BCM380 odhcp6c[2044]: carrier => 0 event on eth0
Jan 1 03:27:32 DPU504G_BCM380 odhcp6c[2044]: (re)starting transaction on eth0
Jan 1 03:27:32 DPU504G_BCM380 netifd: Interface 'lan' is enabled
Jan 1 03:27:32 DPU504G_BCM380 netifd: Interface 'lan' is setting up now
Jan 1 03:27:32 DPU504G_BCM380 netifd: Interface 'lan' is now up
Jan 1 03:27:32 DPU504G_BCM380 netifd: Interface 'loopback' is enabled
Jan 1 03:27:32 DPU504G_BCM380 netifd: Interface 'loopback' is setting up now
Jan 1 03:27:32 DPU504G_BCM380 netifd: Interface 'loopback' is now up
Jan 1 03:27:32 DPU504G_BCM380 netifd: Interface 'wan' is enabled
Jan 1 03:27:32 DPU504G_BCM380 netifd: Network device 'lo' link is up
Jan 1 03:27:32 DPU504G_BCM380 netifd: Interface 'loopback' has link connectivity
Jan 1 03:27:32 DPU504G_BCM380 netifd: Network device 'eth0' link is up
Jan 1 03:27:32 DPU504G_BCM380 netifd: Interface 'wan' has link connectivity
Jan 1 03:27:32 DPU504G_BCM380 netifd: Interface 'wan' is setting up now
Jan 1 03:27:32 DPU504G_BCM380 netifd: Interface 'wan' is now up
Jan 1 03:27:32 DPU504G_BCM380 odhcp6c[2044]: Starting SOLICIT transaction (timeout 4294967295s, max rc 0)
Jan 1 03:27:32 DPU504G_BCM380 odhcp6c[2044]: Failed to send DHCPV6 message to ff02::1:2 (Cannot assign requested address)
Jan 1 03:27:32 DPU504G_BCM380 odhcp6c[2044]: carrier => 1 event on eth0
Jan 1 03:27:32 DPU504G_BCM380 odhcp6c[2044]: (re)starting transaction on eth0
Jan 1 03:27:33 DPU504G_BCM380 odhcp6c[2049]: Starting SOLICIT transaction (timeout 4294967295s, max rc 0)
Jan 1 03:27:33 DPU504G_BCM380 odhcp6c[2049]: Failed to send DHCPV6 message to ff02::1:2 (Cannot assign requested address)
Jan 1 03:27:33 DPU504G_BCM380 odhcp6c[2049]: carrier => 1 event on eth0
Jan 1 03:27:33 DPU504G_BCM380 odhcp6c[2049]: (re)starting transaction on eth0
Jan 1 03:27:33 DPU504G_BCM380 odhcp6c[2044]: Starting SOLICIT transaction (timeout 4294967295s, max rc 0)
Jan 1 03:27:33 DPU504G_BCM380 odhcp6c[2044]: Failed to send DHCPV6 message to ff02::1:2 (Cannot assign requested address)
Jan 1 03:27:33 DPU504G_BCM380 odhcp6c[2044]: carrier => 0 event on eth0
Jan 1 03:27:33 DPU504G_BCM380 odhcp6c[2044]: (re)starting transaction on eth0
Jan 1 03:27:33 DPU504G_BCM380 netifd: Network device 'eth0' link is down
Jan 1 03:27:33 DPU504G_BCM380 netifd: Interface 'wan' has link connectivity loss
Jan 1 03:27:33 DPU504G_BCM380 netifd: Interface 'wan' is now down
Jan 1 03:27:33 DPU504G_BCM380 netifd: Interface 'wan' is disabled
Jan 1 03:27:33 DPU504G_BCM380 netifd: Interface 'wan' is enabled
Jan 1 03:27:34 DPU504G_BCM380 odhcp6c[2049]: Starting SOLICIT transaction (timeout 4294967295s, max rc 0)
Jan 1 03:27:34 DPU504G_BCM380 odhcp6c[2049]: Failed to send DHCPV6 message to ff02::1:2 (Network is unreachable)
Jan 1 03:27:34 DPU504G_BCM380 odhcp6c[2049]: carrier => 0 event on eth0
Jan 1 03:27:34 DPU504G_BCM380 odhcp6c[2049]: (re)starting transaction on eth0
Jan 1 03:27:34 DPU504G_BCM380 odhcp6c[2044]: Starting SOLICIT transaction (timeout 4294967295s, max rc 0)
Jan 1 03:27:34 DPU504G_BCM380 odhcp6c[2044]: Failed to send DHCPV6 message to ff02::1:2 (Network is unreachable)
Jan 1 03:27:34 DPU504G_BCM380 odhcp6c[2049]: Starting SOLICIT transaction (timeout 4294967295s, max rc 0)
Jan 1 03:27:34 DPU504G_BCM380 odhcp6c[2049]: Failed to send DHCPV6 message to ff02::1:2 (Network is unreachable)
Jan 1 03:27:35 DPU504G_BCM380 odhcp6c[2044]: Failed to send DHCPV6 message to ff02::1:2 (Network is unreachable)
Jan 1 03:27:35 DPU504G_BCM380 odhcp6c[2049]: Failed to send DHCPV6 message to ff02::1:2 (Network is unreachable)
Jan 1 03:27:36 DPU504G_BCM380 odhcp6c[2049]: carrier => 1 event on eth0
Jan 1 03:27:36 DPU504G_BCM380 odhcp6c[2049]: (re)starting transaction on eth0
Jan 1 03:27:36 DPU504G_BCM380 odhcp6c[2044]: carrier => 1 event on eth0
Jan 1 03:27:36 DPU504G_BCM380 odhcp6c[2044]: (re)starting transaction on eth0
Jan 1 03:27:36 DPU504G_BCM380 netifd: Network device 'eth0' link is up
Jan 1 03:27:36 DPU504G_BCM380 netifd: Interface 'wan' has link connectivity
Jan 1 03:27:36 DPU504G_BCM380 netifd: Interface 'wan' is setting up now
Jan 1 03:27:36 DPU504G_BCM380 netifd: Interface 'wan' is now up
Jan 1 03:27:36 DPU504G_BCM380 odhcp6c[2049]: Starting SOLICIT transaction (timeout 4294967295s, max rc 0)
Jan 1 03:27:36 DPU504G_BCM380 odhcp6c[2049]: Failed to send DHCPV6 message to ff02::1:2 (Cannot assign requested address)
Jan 1 03:27:36 DPU504G_BCM380 odhcp6c[2044]: Starting SOLICIT transaction (timeout 4294967295s, max rc 0)
Jan 1 03:27:36 DPU504G_BCM380 odhcp6c[2044]: Failed to send DHCPV6 message to ff02::1:2 (Cannot assign requested address)
Jan 1 03:27:37 DPU504G_BCM380 odhcp6c[2049]: Failed to send DHCPV6 message to ff02::1:2 (Cannot assign requested address)
Jan 1 03:27:39 DPU504G_BCM380 odhcp6c[2049]: Got a valid reply after 2975ms
Jan 1 03:27:39 DPU504G_BCM380 odhcp6c[2049]: Starting REQUEST transaction (timeout 4294967295s, max rc 10)
Jan 1 03:27:39 DPU504G_BCM380 odhcp6c[2049]: Send REQUEST message (elapsed 0ms, rc 0)
Jan 1 03:27:39 DPU504G_BCM380 odhcp6c[2049]: Got a valid reply after 2ms
Jan 1 03:27:39 DPU504G_BCM380 odhcp6c[2049]: entering stateful-mode on eth0
Jan 1 03:27:39 DPU504G_BCM380 odhcp6c[2049]: Starting <POLL> transaction (timeout 302400s, max rc 0)