OpenWrt Forum Archive

Topic: how to wan port be lan port on wr941v5.1

The content of this topic has been archived on 21 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Follow the dumb ap recipe. After you disable firewall you can bridge eth port assigned to wan with lan, so it will look like

cat /etc/config/network
config interface 'lan'
        option ifname 'eth0 eth1'
        option type 'bridge'

But there can be other numbers (i.e. eth0.1), it is hardware specific, you will have to find out your eth numbers using ifconfig first. If you bridge bad eths, you will make your router inacessible, so make sure you can enter failsafe mode ;-)

i dont want to risk

There's no risk. If you make router inacessible, press reset few times during boot, which gets you to failsafe, run mount_root, vi /etc/config/network, fix it and reboot. Just try it before making any change, it is easy. Btw. in failsafe, router is always on IP, very old openwrt relaeases used telnet protocol for failsafe, newer releases use ssh without password

The WAN port does not go through the switch on this model.  It is a direct line to the CPU as eth0.  So as nozombian said, you need to put both eth0 and eth1 into the LAN bridge.  This can be done on the GUI from Network - Interfaces - edit LAN - Physical Settings.

The LED configuration only affects how and when the LEDs light up.  It does not change any routing functionality.

The discussion might have continued from here.