Assuming that I have a OpenWrt client which works in STA mode and I have defined somewhere networks A, B, C. When the station is in A station coverage it connects to A, if it is in B station coverage it connects to B and so on... A, B, C are in totally different locations so they won't overlap. It is a normal operation for e.g. Ubuntu clients or Windows clients - they connect to WiFi AP which they have remembered and the clients are in range of the remembered AP. Is it possible to achieve that with OpenWrt "in the box"?
Topic: Is it possible to have multiple SSIDs a station can connect to
The content of this topic has been archived on 20 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.
This is the kind of questions that get answered faster if you just try it.
I can't find any information about that. I have an idea about solving in out of the box: running service which scans available SSIDs and executes uci commands when one of the defined AP has been found. But I'm looking for a solution "in the box".
I would just configure all those networks as wireless clients, and bridge them together to the same WWAN; it just takes a few minutes, and you can easily see in the logs how it behaves.
From my old fundus of experience, this method is called:
"non-deterministic programming ...." :-)
In this profession, we make random changes until it works as expected, then we never touch it again!
Jokes aside, OpenWrt is quite complex; you can dive into the source code, or wait till some expert appears, or you can just try it yourself and see what happens.
Is it possible to achieve that with OpenWrt "in the box"?
Try package travelmate, see here
Thank you very much for Your support.
I would just configure all those networks as wireless clients, and bridge them together to the same WWAN; it just takes a few minutes, and you can easily see in the logs how it behaves.
I've done using the approach @eduperez had proposed: Firstly I added some wifi-ifaces in /etc/config/wireless:
config wifi-iface
option device 'radio0'
option network 'wlan0'
option mode 'sta'
option ssid 'TESTAP1'
option encryption 'psk2'
option key 'makapaka'
config wifi-iface
option device 'radio0'
option network 'wlan1'
option ssid 'TESTAP2'
option mode 'sta'
option encryption 'psk2'
option key 'makapaka'
and corresponding records in /etc/config/network:
config interface 'wlan0'
option proto 'dhcp'
option metric '1'
config interface 'wlan1'
option proto 'dhcp'
option metric '1'
And bridged the interfaces:
config interface 'wlan'
option type 'bridge'
option ifname 'wlan0 wlan1'
Now I have another question: should the firewall rules work on such a bridge if earlier I have had only one interface defined which had been called wlan?
(Last edited by KKoovalsky on 6 Feb 2018, 18:26)
The discussion might have continued from here.