OpenWrt Forum Archive

Topic: Bridging between 3g and ethernet

The content of this topic has been archived on 24 Mar 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Hello,


      I want to bridge between 3g interface and ethernet interface. I want to connect to the internet via 3g. My device is connected to the ethernet port of the openwrt device.

      How sould I configure the "/etc/config/network" in order to achive the above goal ?

Best Regards

well, you could start by telling us what the 3g device is and how it is being used: are you joining your LAN with it, or leaving the LAN (i.e. 3g is your WAN interface?)

Hello

I share my /etc/config/network settings. I want to bridge 3g and lan interfaces.



config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd48:2845:21d4::/48'

config interface 'lan'
        option ifname 'eth0'
        option force_link '1'
        option macaddr '9c:65:f9:1e:85:5e'
        option type 'bridge'
        option proto 'dhcp'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '0'

config interface '3g'
        option proto '3g'
        option device '/dev/ttyACM0'
        option service 'umts'
        option apn 'mgbs'
enkavak wrote:

      How should I configure the "/etc/config/network" in order to achive the above goal ?

Best Regards

Would you please tell me how can I configure files in /etc ?

The discussion might have continued from here.