Hi all, I'm trying to set up IPTV to work on TP-Link TL-WR841N/ND v8 running OpenWrt Chaos Calmer 15.05.1 / LuCI 15.05-149-g0d8bbd2 Release.
First, I had a problem with a power failure and my original WAN port stopped working. I changed the WAN port to P1 and have set up 2 separate VLANs for networking. Vlan "LAN" is used for all home devices and vlan "LAB" is used for my server.
On Port 4 I want to set up my IPTV (needs to be on vlan ID 35) however if I tag port 1 (wan port) the TV works, but the rest of devices do not have Internet connection.
Bellow a short summary of my switches:
VLAN ID CPU Port1 Port2 Port3 Port4
1 tagged untagged off off off (wan)
2 tagged off untagged off off (LAN)
3 tagged off off untagged off (LAB)
35 off off off off untagged (IPTV)
My network config file is the following:
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fdc7:f146:0a97::/48'
config interface 'lan'
option force_link '1'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'
option _orig_ifname 'eth1 radio0.network1'
option _orig_bridge 'true'
option ifname 'eth1.2'
config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'
config switch_vlan
option device 'switch0'
option vlan '1'
option vid '1'
option ports '0t 1'
config switch_vlan
option device 'switch0'
option vlan '2'
option vid '2'
option ports '0t 3'
config interface 'WORLD'
option proto 'dhcp'
option _orig_ifname 'eth1.1'
option _orig_bridge 'true'
option ifname 'eth1.1'
config switch_vlan
option device 'switch0'
option vlan '3'
option vid '3'
option ports '0t 2'
config interface 'LAB'
option proto 'static'
option ifname 'eth1.3'
option ipaddr '10.10.10.1'
option netmask '255.255.255.0'
option type 'bridge'
config switch_vlan
option device 'switch0'
option vlan '4'
option vid '35'
option ports '4'
Thank you