I have a Pi set up as a OpenVPN router behind my main router for certain VPN only clients. All works nicely.
I'd like to add a wifi adaptor so I can utilise the VPN via either a LAN cable OR Wifi.
The LAN adaptor is the standard bridged config, and runs a dhcp client for VPN clients.
I'm not sure how to configure the Wifi adaptor so it utilises the LAN DHCP server ?
I am thinking that perhaps I run it as Protocol 'unmanaged' and bridge it with the LAN interface?
Any suggestions appreciated.
B. Rgds
John
Some basic details:
LEDE Reboot 17.01.4 r3560-79f57e422d / LuCI lede-17.01 branch (git-18.061.17832-d092772)
All updates applied
WAN - DHCP Client to main router
IP 192.168.10.x
DNS pointed to upstream VPN server
config interface 'wan'
option proto 'dhcp'
option ifname 'eth0'
option delegate '0'
option peerdns '0'
option dns '192.168.90.1'
LAN - Static IP 192.68.50.1
DHCP to VPN clients - 192.168.50.100 - 250
config interface 'lan'
option type 'bridge'
option ifname 'eth1'
option proto 'static'
option netmask '255.255.255.0'
option ipaddr '192.168.50.1'
VPN - 192.168.90.x
config interface 'VPN'
option ifname 'tun0'
option _orig_ifname 'tun0'
option _orig_bridge 'false'
option proto 'none'
option delegate '0'
WLAN - (currently disabled - want to access DHCP on LAN interface above)
config wifi-device 'radio0'
option type 'mac80211'
option channel '11'
option hwmode '11g'
option path 'platform/soc/20980000.usb/usb1/1-1/1-1.4/1-1.4:1.0'
option htmode 'HT20'
option disabled '1'
config wifi-iface 'default_radio0'
option device 'radio0'
option mode 'ap'
option ssid 'LEDE'
option encryption 'none'
option network 'lan wlan'