OpenWrt Forum Archive

Topic: 2 SSID with 2 VLAN

The content of this topic has been archived on 1 May 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Hello,

I want to configure 2 WiFi on a D-Link DAP-1350, each WiFi must communicate only on his VLAN ID.

My infrastructure : ibb.co/ivpHcH

I want to create 2 SSID, 1 VLAN by SSID, to separate my networks, if a client connect "Home" WiFi network he can go to pfSense and if he connect to "Guest" network he can connect to Alcasar.
My D-Link have only one port, on this port i want to attach my "Home" WiFi to VLAN 1 and my "Guest" WiFi to VLAN 6.

This config works with a Cisco AIR-CAP3702I-E-K9 but i dont understand how to do this with my DAP-1350 and OpenWRT (i use version 15.05.1, my DAP-1350 seems to be be VLAN capable : wiki.openwrt.org/toh/d-link/dap-1350).

I use LuCI to configure my DAP-1350.

Can i have some help please ?

Thanks in advance and sorry for my bad English.

Log in to the router by wifi (on your "home" AP, which goes to the router's LAN network) while making these changes.  If you are connected by Ethernet, it will likely lose access in the middle of making changes.

This unit has a RT3052 SoC, so even though there is only one Ethernet port wired up, you still have to configure the switch on the chip.  All Ethernet traffic comes from port eth0 on the CPU then passes through the switch section before it leaves the chip.  To save space and money, D-Link only connected one of the switch outputs to an Ethernet port.  The other switch channels dead-end inside the router.

Go to Network--Switch and change the CPU and the active Ethernet port to be tagged in VLAN 1.  Add a new VLAN 6 and set the CPU and the Ethernet port to tagged in that VLAN also.  The other 4 ports can be "off". 

It is now configured so that eth0.1 will go out to the Ethernet cable tagged with VLAN 1, and eth0.6 will go on the same cable tagged with VLAN 6.

Go to Network--Interfaces and click the edit button on LAN.   Click physical settings.  Change from eth0 to eth0.1.  When you are using VLANs you should not use plain eth0 for anything.

Go back to the main Network--Interfaces page and add a new interface called 'guest'.  The protocol should be "unmanaged," since this network will be merely a bridge from wifi to Ethernet port.  On physical settings, make this network a bridge and attach it to eth0.6, your guest VLAN.

Go to Network-Wireless and add a wifi AP for guests.  Attach it to the guest network.

(Last edited by mk24 on 6 Apr 2018, 15:59)

Thanks a lot, it works !

You're great, thanks again for the explanations !

The discussion might have continued from here.