OpenWrt Forum Archive

Topic: OpenWRT USB Tethering to Nokia 8 (Android 8.1) problem.

The content of this topic has been archived on 8 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Hi,

I’m looking for advice on how to resolve a USB tethering issue.

Router: GL-I MT300N-V2 with openwrt-ramips-mt76x8-gl-mt300n-v2-squashfs-sysupgrade.bin image. USB-RNDIS drivers installed.

USB tethering setup is confirmed as working with a (borrowed) Huawei P8 lite, this is how it used to work with my old phone, a Huawei P9. The P9 broke and I bought a Nokia 8 as a replacement.

USB Tethering on Nokia 8 connected directly to a Windows laptop works without any issues, Win8.1 / Win10 create a RNDIS interface and internet is available without any manual configuration.

IFCONFIG shows the USB0 interface when I connect the Huawei phone, USB0 is not listed with the Nokia 8 phone.

Nokia 8 is running Android 8.1, Huawei P8 lite and P9 use Android 7.1.
Snippet from dmesg: usb 1-1: new high-speed USB device number 2 using ehci-platform


Is there something else I need to install/configure for USB tethering with Android 8.1 phone?

Thanks.

If that's the only message you see, it means that the USB core enumerated the phone, but the CDC / RNDIS driver did not recognize that it should attach to it.  You must of course have USB tethering turned on in the phone's settings.

Some drivers have an internal list of manufacuter:device USB ID's but I don't know if RNDIS is like that.

(Last edited by mk24 on 8 Apr 2018, 15:45)

The discussion might have continued from here.