OpenWrt Forum Archive

Topic: TP-Link WDR3600 OpenWRT CC v15.05.1 - Firewall and VLAN LUCI Error

The content of this topic has been archived on 13 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Hi, I'm using a WDR3600 with Firmware:

OpenWrt Chaos Calmer 15.05.1 / LuCI 15.05-149-g0d8bbd2 Release (git-15.363.78009-956be55)

Problem:

When I try to add a Firewall / Traffic Rule in the webgui, i get the following LUCI Error:

Status: 500 Internal Server Error /usr/lib/lua/luci/dispatcher.lua:433: Failed to execute arcombine dispatcher target for entry '/admin/network/firewall/rules'. The called action terminated with an exception: /usr/lib/lua/luci/template.lua:97: Failed to execute template 'cbi/header'. A runtime error occured: /usr/lib/lua/luci/template.lua:97: Failed to execute template 'header'. A runtime error occured: /usr/lib/lua/luci/template.lua:97: Failed to execute template 'themes/material/header'. A runtime error occured: [string "/usr/lib/lua/luci/view/themes/material/head..."]:154: attempt to call global 'url' (a nil value) stack traceback: [C]: in function 'assert' /usr/lib/lua/luci/dispatcher.lua:433: in function 'dispatch' /usr/lib/lua/luci/dispatcher.lua:168: in function

When I try to add a VLAN on switch0 in the webgui, i get the following error:

Status: 500 Internal Server Error /usr/lib/lua/luci/dispatcher.lua:433: Failed to execute cbi dispatcher target for entry '/admin/network/vlan'. The called action terminated with an exception: /usr/lib/lua/luci/template.lua:97: Failed to execute template 'cbi/header'. A runtime error occured: /usr/lib/lua/luci/template.lua:97: Failed to execute template 'header'. A runtime error occured: /usr/lib/lua/luci/template.lua:97: Failed to execute template 'themes/material/header'. A runtime error occured: [string "/usr/lib/lua/luci/view/themes/material/head..."]:154: attempt to call global 'url' (a nil value) stack traceback: [C]: in function 'assert' /usr/lib/lua/luci/dispatcher.lua:433: in function 'dispatch' /usr/lib/lua/luci/dispatcher.lua:168: in function

Who can help to resolve this issue?

Many thx in advance!

Upgrade to LEDE 17.1.4
Do not save any config files.
https://downloads.openwrt.org/

(Last edited by tapper on 13 Apr 2018, 01:55)

The discussion might have continued from here.