For a while I've had a Netgear WNR2000 v4. Someone gave it to me after it quit working. They gave no explanation for why it quit working. After powering it on it just shows a solid amber power light. I soldered a 4-pin header to JP1 on the board of the router and connected it to a Raspberry Pi and used the minicom program to get output from the router. There is some character corruption but you can see what's happening. The following is output from a regular startup.

I don't understand all of that but about the moment 'kernel panic' shows is when I only see a solid amber power light. I was unaware someone tried to put OpenWrt on this router. Apparently that happened and they had problems. The following is the output from me starting the router while holding down the reset button and trying to use a TFTP program to upload Netgear's last firmware for this router.

The firmware update is refused because the hardware IDs don't match. Actually, not sure how but the HW ID on the board looks like it doesn't make sense. How do I recover from this? I'm OK with going back to Netgear's firmware or going forward and fixing whatever went wrong with OpenWrt. Whichever is easier to do, I guess.

Edit: Finally, I was able to post. I kept getting a vague message about the forums not working.. try back in a few minutes. However, I suspected my long pastes of output from the router wasn't being accepted so I tried using pastebin.

(Last edited by Lanplan on 21 Apr 2018, 02:21)