I wanted to have 2 VLANs on my router. So I configured it this way:
etc/config/network:
#### VLAN configuration
config switch eth0
option vlan0 "1 2 3 5*"
option vlan1 "4 5"
option vlan2 "0 5"
#### Loopback configuration
config interface loopback
option ifname "lo"
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0
#### LAN configuration
config interface lan
option type bridge
option ifname "eth0.0 ath0"
option proto static
option ipaddr 172.16.1.1
option netmask 255.255.255.0
#### WAN configuration
config interface wan
option ifname "eth0.1"
option proto dhcp
#### LAN2 configuratione
config interface lan
option ifname "eth0.2"
option proto static
option ipaddr 172.16.2.1
option netmask 255.255.255.0
but vlan2 isnt running, while the other vlans work as configurated..
ifconfig:
ath0 Link encap:Ethernet HWaddr 00:09:5B:F7:94:B6
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
br-lan Link encap:Ethernet HWaddr 00:09:5B:F7:94:B6
inet addr:172.16.1.1 Bcast:172.16.1.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
eth0 Link encap:Ethernet HWaddr 00:09:5B:F7:9E:2C
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:12 errors:0 dropped:0 overruns:0 frame:0
TX packets:7 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1772 (1.7 KiB) TX bytes:2590 (2.5 KiB)
Interrupt:4
eth0.1 Link encap:Ethernet HWaddr 00:09:5B:F7:9E:2C
inet addr:172.16.0.27 Bcast:172.16.0.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:11 errors:0 dropped:0 overruns:0 frame:0
TX packets:7 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:1311 (1.2 KiB) TX bytes:2534 (2.4 KiB)
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
wifi0 UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 0-00-00-00-00-00
wifi0 UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 0-00-00-00-00-00
RX packets:28 errors:0 dropped:0 overruns:0 frame:1633
TX packets:2 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:199
RX bytes:1490 (1.4 KiB) TX bytes:92 (92.0 B)
Interrupt:2 Memory:c0080000-c0090000
so whats wrong in my configuration? Anyone any ideas?
(Last edited by leviathan on 22 Oct 2006, 21:38)