OpenWrt Forum Archive

Topic: serial cable for wgt634u

The content of this topic has been archived on 26 Mar 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Hi guys

Quick question: I am building a serial cable for my wgt634u. Bought a CA-42 cable by "Connecting People" off eBay. Colours are white, black, orange, blue, green. Anyone else used this cable? If so, what arrangement did you use? I have searched the internet, but nothing has descriptions for this cable configuration...


Hi all,

I have been going crazy here trying to resolve this issue.

I am surprised to see that, no matter what combination I use, I cannot loop text back when I attach any two wires together in a tool such as minicom, zterm or hyperterminal. However, I can read the load information if I attach my blue wire to the third pin and the white wire to the fourth. Has anyone else ever come across this situation: Does it mean my cable is a dud, or am I just missing something obvious? All wires carry a voltage as measured by a multimeter.

Is there any other way to tell what wire is to input data into the router, as I have tried every solution I can think of.


I would start by making sure your grounds are tied together.

Make sure +5V from the USB port is not being passed through to the router.
If you can figure out these two things, then you'll only have to worry about the Tx and Rx lines.

(Last edited by KillaB on 21 Feb 2007, 18:27)

use screen. something like this:

screen /dev/ttyUSB0 115200

you should not, of course, attach a usb port directly to the router's serial. usb is NOT compatible with serial, that's what controllers like the pl2303 are useful for (I don't see how the usb pinout is relevant)
I find a speaker helpful for differentiating tx and rx

Kevin wrote:

you should not, of course, attach a usb port directly to the router's serial. usb is NOT compatible with serial, that's what controllers like the pl2303 are useful for (I don't see how the usb pinout is relevant)
I find a speaker helpful for differentiating tx and rx

It's assumed that theaz is trying to get console access on his WGT.
Therefore, he needs to determine the proper pinout from his USB-to-TTL adapter.  That's why the USB pinout is relavent.

If I'm wrong in this assumption, please let us know.

I bought a CA-42 on eBay for my WGT634U that sounds similar. The USB end is blue plastic and has a serial number starting with WT048 on the silver label on one side. After searching around for a while I couldn't find anything on this very generic cable. So, I stripped the wires, connected the USB end, opened up minicom with 115200 N81 on /dev/ttyUSB0 and connected different color wires to RX while booting the router until I got a bunch of garbled output. Then I tried the remaining wires on GND until the text became readable. After that it was no problem to find the wire for TX. Anyway, the following worked for me:

White to TX
Blue to RX
Green to GND

if he's trying to find the pinout, the serial tx and rx have no relation to the usb tx and rx. looking at the chip datasheet would tell you all the pins anyway, if you want to follow traces wink

I need a serial cable for the wgt634u to. I have a siemens usb cable for a S65. At the cable is written S30880-S5601-A810. Can I use this cable for a serial cable?

The CA-42 cables do have a serial to USB chip, usually a PL2303. So, if its a PL2303 based cable all you have to find is the correct serial RX, TX, & GND wires. Having the pin-out for the POP port end is pretty much useless anyway, as its usually next to impossible to expose the wiring without nearly destroying it. If you're running Linux and want to find out if your cable is using a PL2303 chip plug it into a USB port and run: 

lsmod | grep pl2303

You'll see the pl2303 module is loaded and in use by the usbserial and usbcore modules. The one I got on eBay does use a PL2303 and works great when connected as posted above. You can of course find the pin-out for the serial header on the router here.

Hi guys,

Sorry for the slow reply: had to wait for the weekend to start mucking about again. Your feedback has been very useful.

KillaB: No chance of that: None of the wires had anywhere near 5V running through them as read on the multimeter. I confess I was getting a quite confused working out the pinouts though.
Kevin: you are right, as noted by bradthebuyer, the cable has PL2303 in it
Bradthebuyer: Your cable differs slightly from mine as mine has a different silver label on it: IL40083821; Nonetheless, like magic, I used your colour combination and I was able to control-c into CFE!

Now I have got into CFE, I cannot actually type anything into it. eg: if I type "help" nothing appears in the hyperterminal/minicom etc. I have tried with and without hardware and software flow control and all sorts of terminal settings. After I have loaded into CFE, should I be able to ping the router across the WAN port? What settings did you guys use for your local IP, subnet, [and gateway]? I have tried static IPs eg and

The thing is that I am sure the desktop can communicate with the router as I can get into CFE with control-c. Is this a beginners mistake: have I forgotten to do something obvious?

thanks in advance...

(Last edited by theaz on 24 Feb 2007, 07:34)

Maybe you don't have Rx right (what the router sees you type)? If you tried "screen /dev/ttyUSB0 115200" under root and don't see your own output, then that's gotta be it.

IP addresses aren't an issue - communicating over the serial port is completely independent of all that. To set it up so you can ping your router over wan you need to configure the router's config file (/etc/config/wireless). The only difference from the default is to uncomment the line that says "#option network lan".

Use this as a reference: … figuration

If the router is just sitting at a CFE prompt you wont be able to ping / communicate with it via IP at all since you would have to at least setup an IP address for the WAN port in CFE with an ifconfig command first. It wouldn't do you any good anyway though since there aren't any services running while in CFE. Thats strange that you can control-C into CFE but not enter any input into the router afterwards. If you hit control-C again while at the CFE prompt do you get a new line?

I played around with the cables some more, and actually got it working: the colours I used were

White to TX
Blue to RX
Orange to GND

I am guessing that using the green on ground allowed the text to be sent from the router no problems, whilst also allowing the router to interpret the control c; but that was all. However, it would not read anything more from the serial console, and additional control-c did not add new lines: pretty strange...

Thanks for helping me get this thing sorted.


I have the exact same problem with the same ca-42 cable  IL40083821
Can't make the loopback work
connecting white to blue (it is indeed confirmed by the nokia connector pinout)
except that the ground is black

I tried pico under linux and openwrt and hyperterminal under windows xp.
Can't see anything echoed.

Is there anyone who got this cable working?

sophana wrote:

I have the exact same problem with the same ca-42 cable  IL40083821
Can't make the loopback work

I think I read that some people had data cables that needed power from the phone (or router, in this case) to work properly, power from the USB port was not enough (or simply wasn't used). You may want to try that out.

sophana wrote:

I have the exact same problem with the same ca-42 cable  IL40083821
Can't make the loopback work

Some Samaritan in this forum was very nice to send me a free USB/Serial console cable that works nicely with my WGT634U, LaFonera, and some other WiFi routers. I am not sure if it is the same cable you have; however, it's made from a Nokia CA-42 V2 adapter converter as shown on the following excerpt from the /var/tmp/messages file on my Linu SuSE computer:

Oct  8 08:33:24 Mi syslog-ng[2317]: last message repeated 2 times
Oct  8 08:50:42 Mi kernel: usb 3-1: new low speed USB device using ohci_hcd and address 4
Oct  8 08:50:42 Mi kernel: usb 3-1: new device found, idVendor=07d0, idProduct=4101
Oct  8 08:50:42 Mi kernel: usb 3-1: new device strings: Mfr=1, Product=2, SerialNumber=0
Oct  8 08:50:42 Mi kernel: usb 3-1: Product: USB to Serial
Oct  8 08:50:42 Mi kernel: usb 3-1: Manufacturer: Kingsun Semiconductor
Oct  8 08:50:42 Mi kernel: usb 3-1: configuration #1 chosen from 1 choice
Oct  8 08:50:42 Mi kernel: cypress 3-1:1.0: Nokia CA-42 V2 Adapter converter detected
Oct  8 08:50:42 Mi kernel: usb 3-1: Nokia CA-42 V2 Adapter converter now attached to ttyUSB0

BTW, what exactly did you mean by a loopback?

I now have a DKU-5 cable that works with my phone, but can't get it to work with my router. Since I haven't had any console on that device at all so far, I don't know if I should blame the router or the cable. The cable seems suspicious though. It gives me a ttyUSB0 when I plug it in, I then measured its signals using a cheap multi-meter and they're not quite 3.3V at all. Is this a typical sympton of "your cable needs 3.3V from the board"?

I find it strange that I can get it to work with my phone, but not as a loopback. The cables also aren't exactly how I expected them; there's no data GND, only charging GND. Also, there's a GND on the outside of the connector, I guess I should be using that one.

(Last edited by Wilmer on 18 Oct 2008, 20:29)

I have been using DKU-5 cable with wgt634u for quite a while. And I can say I am 100% happy. From the first connection - it just works. Here are a few notes:

- Keep DC 3.3V unconnected! You don't need it - the chip on the cable is powered by USB port itself.
- GND _DEFINITELY_ needs to be connected to the board. Without it, no joy, sorry!!!
- Don't rely on wire colors from web. No standard exists here!!! Each vendor make it own decisions on wiring. Only way how to find out reliably is when you disassembling the Nokia connector - keep close eye on pins where wires are connected to.

(Last edited by baracudaz on 18 Oct 2008, 23:15)

I definitely ignored all the documented colours, all I looked at is pin-out descriptions of the Nokia data cables. It took quite some time to trace those all back to the individual wires since it's was impossible to open the connector normally, I just had to slowly shave it off, slice by slice, to get to the actual wires. :-/

I'll give it another shot, but I just don't trust the voltage already... Also, I have the impression that I have to do something to make the cable really behave like RS232 on the phone end, and that by default it operates in a slightly different way.

(I'm actually doing this for a different device, but it should all be the same IMHO.)

(Last edited by Wilmer on 19 Oct 2008, 13:53)

FWIW for people who have a cable similar to mine (DKU5 with an ark3116 chip), I figured out how it should work:

pin wire - description
xx blue - gnd on the sides
02 yellow - gnd/charge
03 orange - aci (insert-remove)
05 white - usb vbus
06 green - pc <- phone
07 red - pc -> phone

I found the docs on the pin - description somewhere else, where it said 7 is rx<-phone and 6 is tx->phone, but my tests showed otherwise since with red/7 disconnected I still received stuff from the router. Makes me wonder if maybe I did screw up mapping the wires to pins on the connector. :-/

Anyway, with this cable, one should connect blue (the ground pins on the sides) to the GND on the router and both orange and white to the +3.3V. The yellow ground wire can be ignored.

Of course YMMV, but just adding yet another option to this endless list.

Hi friends, I am first time here and really found ti good by all means, Infact the topic is good to read and and sending this page to my other firends because they are always asking me for the good resources to read out

I haven't tried this cable but using HDMI cable from long time. I suggest you go for gold plated hdmi cable. They are expensive but give you much better quality.

This post is very interesting, I like it. I will always come to visit after.I would recommend to friends more.
wire covers

The discussion might have continued from here.