After installing OpenWRT on dozens of WRT54GL, WRTSL54GS, and Asus 500Gp's, it is time to move to a platform with a faster processor. I would like your assistance loading Kamikaze the Gateworks Avila GW-2348-4. I'll apologize for what may turn out to be an easy question in advance.
I have a fairly impressive IPSec VPN running White Russian .9 on the WRTSL54GS . I am getting around 4.2Mbps using AES-128 encryption. I would like to be able to use AES-256 at 10Mbps+ without maxing out the CPU. (ok, I'm getting off topic.)
Here is what I did to flash the Avila GW2348-4:
fis init -f
load -r -b %{FREEMEMLO} openwrt-avila-2.6-zImage
fis create kernel
load -r -b %{FREEMEMLO} openwrt-ixp4xx-2.6-squashfs.img
fis create rootfs
This is what I get when I reboot:
+No devices on IDE controller 0
Trying NPE-B...success. Using NPE-B with PHY 0.
Ethernet eth0: MAC address 00:d0:12:03:42:53
IP: 192.168.1.1/255.255.255.0, Gateway: 192.168.1.1
Default server: 192.168.1.2
RedBoot(tm) bootstrap and debug environment [ROM]
Gateworks certified release, version 2.02 - built 05:22:19, Mar 3 2006
Platform: Gateworks Avila GW234X (IXP42X 533MHz) BE
Copyright (C) 2000, 2001, 2002, 2003, 2004 Red Hat, Inc.
Copyright (C) 2004, 2005 Gateworks Corporation
RAM: 0x00000000-0x04000000, [0x000298b0-0x03fc1000] available
FLASH: 0x50000000 - 0x51000000, 128 blocks of 0x00020000 bytes each.
== Executing boot script in 2.500 seconds - enter ^C to abort
RedBoot> fis load kernel
RedBoot> exec
Using base address 0x00029c00 and length 0x000e8024
Uncompressing Linux................................................................. done, booting the kernel.
Linux version 2.6.21.6 (nbd@ds10) (gcc version 4.1.2) #11 Thu Jul 26 18:11:21 CEST 2007
CPU: XScale-IXP42x Family [690541c1] revision 1 (ARMv5TE), cr=000039ff
Machine: Gateworks Avila Network Platform
Memory policy: ECC disabled, Data cache writeback
CPU0: D VIVT undefined 5 cache
CPU0: I cache: 32768 bytes, associativity 32, 32 byte lines, 32 sets
CPU0: D cache: 32768 bytes, associativity 32, 32 byte lines, 32 sets
Built 1 zonelists. Total pages: 16256
Kernel command line: root=/dev/mtdblock2 rootfstype=squashfs,jffs2 noinitrd console=ttyS0,115200 init=/etc/preinit
PID hash table entries: 256 (order: 8, 1024 bytes)
Dentry cache hash table entries: 8192 (order: 3, 32768 bytes)
Inode-cache hash table entries: 4096 (order: 2, 16384 bytes)
Memory: 64MB = 64MB total
Memory: 62848KB available (1788K code, 167K data, 76K init)
Mount-cache hash table entries: 512
CPU: Testing write buffer coherency: ok
NET: Registered protocol family 16
IXP4xx: Using 16MiB expansion bus window size
PCI: IXP4xx is host
PCI: IXP4xx Using direct access for memory space
PCI: bus0: Fast back to back transfers enabled
NET: Registered protocol family 2
Time: OSTS clocksource has been installed.
IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
TCP established hash table entries: 2048 (order: 2, 16384 bytes)
TCP bind hash table entries: 2048 (order: 1, 8192 bytes)
TCP: Hash tables configured (established 2048 bind 2048)
TCP reno registered
NetWinder Floating Point Emulator V0.97 (double precision)
squashfs: version 3.0 (2006/03/15) Phillip Lougher
Registering mini_fo version $Id$
JFFS2 version 2.2. (NAND) (C) 2001-2006 Red Hat, Inc.
io scheduler noop registered
io scheduler deadline registered (default)
IXP4xx Watchdog Timer: heartbeat 60 sec
Serial: 8250/16550 driver $Revision: 1.90 $ 2 ports, IRQ sharing disabled
serial8250.0: ttyS0 at MMIO 0xc8000000 (irq = 15) is a XScale
serial8250.0: ttyS1 at MMIO 0xc8001000 (irq = 13) is a XScale
IXP4XX Q Manager 0.2.1 initialized.
IXP4XX NPE driver Version 0.3.0 initialized
ixp4xx_crypto 0.0.1 registered successfully
IXP4XX-Flash.0: Found 1 x16 devices at 0x0 in 16-bit bank
Intel/Sharp Extended Query Table at 0x0031
Using buffer write method
cfi_cmdset_0001: Erase suspend on write enabled
Searching for RedBoot partition table in IXP4XX-Flash.0 at offset 0xfe0000
6 RedBoot partitions found on MTD device IXP4XX-Flash.0
Creating 6 MTD partitions on "IXP4XX-Flash.0":
0x00000000-0x00080000 : "RedBoot"
npe: searching for firmware...
npe: found at 0x12104, unknown/NPE-A func: 03, rev: 5.8, size: 1074729484, id: 5003c508
npe: found at 0x3fd1c, IXP465/NPE-A func: 81, rev: 2.0, size: 12848, id: 10810200
npe: found at 0x42f4c, IXP425/NPE-B func: 01, rev: 2.0, size: 12848, id: 01010200
Image loaded to NPE-B Func:1, Rel: 2:0, Status: 82400000
npe: found at 0x4617c, IXP425/NPE-C func: 01, rev: 2.0, size: 12848, id: 02010200
Image loaded to NPE-C Func:1, Rel: 2:0, Status: 80800000
0x00080000-0x00180000 : "kernel"
0x00180000-0x002a0000 : "rootfs"
0x00280000-0x002a0000 : "rootfs_data"
0x002a0000-0x00fe0000 : "unallocated"
0x00fe0000-0x00fff000 : "FIS directory"
0x00fff000-0x01000000 : "RedBoot config"
i2c /dev entries driver
nf_conntrack version 0.5.0 (512 buckets, 4096 max)
ip_tables: (C) 2000-2006 Netfilter Core Team
TCP westwood registered
NET: Registered protocol family 1
NET: Registered protocol family 17
802.1Q VLAN Support v1.8 Ben Greear <greearb@candelatech.com>
All bugs added by David S. Miller <davem@redhat.com>
XScale DSP coprocessor detected.
ixp4xx_mac driver 0.3.1: eth0 on NPE-B with PHY[0] initialized
ixp4xx_mac driver 0.3.1: eth1 on NPE-C with PHY[1] initialized
drivers/rtc/hctosys.c: unable to open rtc device (rtc0)
VFS: Mounted root (squashfs filesystem) readonly.
Freeing init memory: 76K
Warning: unable to open an initial console.
- preinit -
jffs2 not ready yet; using ramdisk
mini_fo: using base directory: /
mini_fo: using storage directory: /tmp/root
- init -
init started: BusyBox v1.4.2 (2007-07-23 08:26:10 CEST) multi-call binary
Please press Enter to activate this console. eth0: link up, 100Mbps, full-duplex, lpa 0x41E1
eth0: link up, 100Mbps, full-duplex, lpa 0x41E1
PPP generic driver version 2.4.2
wlan: 0.8.4.2 (svn r2568)
ath_hal: module license 'Proprietary' taints kernel.
ath_hal: 0.9.30.13 (AR5210, AR5211, AR5212, AR5416, RF5111, RF5112, RF2413, RF5413, RF2133, REGOPS_FUNC)
ath_rate_minstrel: Minstrel automatic rate control algorithm 1.2 (svn r2568)
ath_rate_minstrel: look around rate set to 10%
ath_rate_minstrel: EWMA rolloff level set to 75%
ath_rate_minstrel: max segment size in the mrr set to 6000 us
wlan: mac acl policy registered
ath_pci: 0.9.4.5 (svn r2568)
jffs2: Too few erase blocks (1)
BusyBox v1.4.2 (2007-07-23 08:26:10 CEST) Built-in shell (ash)
Enter 'help' for a list of built-in commands.
_______ ________ __
| |.-----.-----.-----.| | | |.----.| |_
| - || _ | -__| || | | || _|| _|
|_______|| __|_____|__|__||________||__| |____|
|__| W I R E L E S S F R E E D O M
KAMIKAZE (7.07) -----------------------------------
* 10 oz Vodka Shake well with ice and strain
* 10 oz Triple sec mixture into 10 shot glasses.
* 10 oz lime juice Salute!
---------------------------------------------------
root@OpenWrt:/#
nbd asked skycode to make a larger rootfs partition in another thread. Assuming that this is the same problem I am having, I still need some help.
http://forum.openwrt.org/viewtopic.php?id=11809
DD-WRT has step by step directions to flash the GW-2348. I would be happy to write a WIKI page for OpenWRT once I get this figured out.
http://www.dd-wrt.com/wiki/index.php/In … sor_GW2348
The docs to flash the GW-2348 are located here for anyone else looking for more information.
http://ecos.sourceware.org/docs-latest/ … ystem.html
Update:
I tried searching for "fis create" and found the Kamikaze Installation
http://wiki.x-wrt.org/index.php/Kamikaz … ot_devices
The section on computing free space is one of the things I was missing.
http://wiki.x-wrt.org/index.php/Kamikaz … space_size
I am much closer to a working router using the following commands.
fis init -f
load -r -b %{FREEMEMLO} openwrt-avila-2.6-zImage
fis create kernel
fis free
load -r -b %{FREEMEMLO} openwrt-ixp4xx-2.6-squashfs.img
fis create -l 0xE60000 rootfs (Replace 0xE60000 with the value you calculated from fis free.)
Right now I'm trying to figure out why eth0 does not work. Logread shows dhcpdiscover and dhcpoffer. The workstation is not getting an IP address and setting a static IP address does not work.
Update 2:
I'm not sure exactly what I did but the ethernet ports are now working. I added the wan section to /etc/config/network and entered "ifup wan" to bring up eth1.
The following thread may be of some help to those getting started with Kamikaze.
http://forum.openwrt.org/viewtopic.php?id=11451
root@OpenWrt:/etc/config# cat network
# Network configuration file
config interface loopback
option ifname lo
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0
config interface lan
option ifname eth0
option proto static
option ipaddr 192.168.1.1
option netmask 255.255.255.0
config interface wan
option ifname eth1
option proto dhcp
The last thing I did was to install the X-WRT Web Interface by following the instructions here.
http://wiki.x-wrt.org/index.php/Kamikaz … t_Kamikaze
So far, so good. My next project is to figure out what I am going to do for an IPSec VPN. Kamikaze replaced OpenSwan with IPSec-Tools with the kernel change from 2.4 to 2.6. I have a project that might not work with IPSec-Tools. Anyway, I'm getting off-topic again.
Thank You,
Kevin
(Last edited by vpnsecure on 25 Sep 2007, 16:20)