OpenWrt Forum Archive

Topic: Belkin F5D7630uk4A

The content of this topic has been archived on 13 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

I had a go at installing OpenWRT on my router.  It's pretty definitely broadcom-based, but it's a Belkin F5D7630uk4A, which is listed as Untested on the OpenWRT wiki.

Reading up on the similar 7230 made it seem like it shouldn't be too hard, although the web interface won't take the firmware image and the firmware file format looks different (I hexdump -C'd it). I'm damned if I can persuade it to take a tftp upload of anything.  I've tried two machines on various thernet ports with tftp and atftp.  With one machine, I can see the router bring the link up and down while rebooting.  I've tried clearing the arp cache while the router is down.  I've tried looking for different IP addresses as well as the factory default and its currently-configured one.  Anyone know how to get OpenWRT on one of these?

While messing about, I uploaded the latest Belkin firmware and that's improved network stability, but added a new problem.  After the router has been up a few hours, WPA fails to my main laptop.  The only way out seems to be reboot the router, rinse and repeat, so I'd really like to have OpenWRT on there instead, so I'd stand a chance of debugging it!

Thanks in advance for any help.  Ask if you want more detail and I'll try to post it.


(Last edited by MJR on 19 Mar 2007, 17:17)

Following a message from Belkin support, it seems that the current version of their firmware only works properly with WPA on channels 1, 6 and 11.  Please can anyone help get OpenWRT onto this pig?

Last year, I had the same problem with trying to get dd-wrt on a F5D7230-4. I found that adding a 28-byte header to the file allowed me to upload the firmware through the Belkin's web interface. Perhaps the same method would work for OpenWRT.

Here's a description of the header:

1. The first four bytes are "LOAD".
2. The next four bytes contain the length of the file including the header, in little-endian order.
3. The next four bytes are the CRC-32 checksum of everything but the first 12 bytes of the file. I used the command cksum -o 3 in OS X to calculate this checksum. The file contains the one's complement of the result of this calculation, i.e. flip all the bits, and again, the bytes are in little-endian order.
4. Next comes 00, 80, and then 14 more 00s. You have to prepend this to firmware before you can calculate the checksum in the previous step.


This is my first post on the forum, so bare with me!

I've been looking into "modding" my router to increase the output power and give me more control, but I've been worried about demoting it from router to housebrick, so I've been trying to find someone else who has installed OpenWRT on the same router.

Have you had any luck with this?  I'd be very interested to know if you managed to get it working.

(Last edited by annex666 on 31 Jul 2007, 20:46)

The discussion might have continued from here.