I installed Kamikaze r6596 on a Fonera, but I'm having trouble getting the wireless interface to work automatically. I started with a simple AP configuration:
==> /etc/config/network <==
config interface loopback
option ifname lo
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0
config interface lan
option ifname eth0
option type bridge
option proto 'static'
option ipaddr '10.0.0.65'
option netmask '255.255.255.0'
==> /etc/config/wireless <==
config wifi-device wifi0
option type atheros
option channel 6
config wifi-iface
option device wifi0
option network lan
option mode ap
option ssid OpenWrt
option encryption none
After a reboot, the br-lan interface is constructed:
bridge name bridge id STP enabled interfaces
br-lan 8000.0018841582c8 no eth0
ath0
but not configured. I have to do an explicit "ifup lan" to get the bridge configured:
br-lan Link encap:Ethernet HWaddr 00:18:84:xx:xx:x8
inet addr:10.0.0.65 Bcast:10.0.0.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
But now, the wifi interface is removed from the bridge:
bridge name bridge id STP enabled interfaces
br-lan 8000.0018841582c8 no eth0
I have to issue a "wifi" command to restore the bridge. After that, my laptop is able to obtain an IP address from the router, and I'm able to connect.
Why isn't the network configured automatically on a reboot? Is there something missing? I don't have this problem on my Asus Wl-500g Deluxe router, which is also running Kamikaze.
Oh, and BTW: the wifi LED remains switched off. Is that a known problem?