OpenWrt Forum Archive

Topic: Kamikaze WGT634U Configuration?!

The content of this topic has been archived between 20 Jan 2018 and 5 May 2018. Unfortunately there are posts – most likely complete pages – missing.

Ydef wrote:

Just set the nvram variables in /etc/config/network.  You shouldn't have a problem bringing up the wan on vlan1.<br><br>

Did you install the pppoe packages and insmod the modules?

<br><br>
Yes.<br>
root@OpenWrt:~# lsmod
Module                  Size  Used by    Tainted: P
ehci_hcd 25744 0 - Live 0xc0153000
uhci_hcd 27792 0 - Live 0xc014b000
usb_storage 27440 0 - Live 0xc0127000
sd_mod 12080 0 - Live 0xc011e000
scsi_mod 71360 2 usb_storage,sd_mod, Live 0xc0187000
usbcore 103584 4 ehci_hcd,uhci_hcd,usb_storage, Live 0xc016c000
vfat 8736 0 - Live 0xc0123000
fat 44528 1 vfat, Live 0xc0131000
nls_iso8859_15 3328 0 - Live 0xc00bf000
nls_iso8859_1 2816 0 - Live 0xc00bd000
nls_cp437 4352 0 - Live 0xc00ba000
nls_base 4576 5 vfat,fat,nls_iso8859_15,nls_iso8859_1,nls_cp437, Live 0xc009e000wlan_scan_sta 9568 0 - Live 0xc0093000
wlan_scan_ap 3072 0 - Live 0xc007e000
wlan_xauth 416 0 - Live 0xc0091000
wlan_wep 4576 0 - Live 0xc009b000
wlan_tkip 10752 0 - Live 0xc0097000
wlan_ccmp 6112 0 - Live 0xc006c000
wlan_acl 2880 0 - Live 0xc006f000
ath_pci 85424 0 - Live 0xc00a1000
ath_rate_sample 8512 1 ath_pci, Live 0xc0071000
ath_hal 207072 3 ath_pci,ath_rate_sample, Live 0xc00ea000
wlan 161792 10 wlan_scan_sta,wlan_scan_ap,wlan_xauth,wlan_wep,wlan_tkip,wlan_ccmp,wlan_acl,ath_pci,ath_rate_sample, Live 0xc00c1000
pppoe 10816 0 - Live 0xc005e000
pppox 1424 1 pppoe, Live 0xc006a000
ppp_generic 26368 2 pppoe,pppox, Live 0xc0076000
slhc 5600 1 ppp_generic, Live 0xc0067000
switch_robo 3920 0 - Live 0xc0065000
switch_core 5056 1 switch_robo, Live 0xc0062000
root@OpenWrt:~#<br><br>

root@OpenWrt:~# cat /etc/config/network
#### VLAN configuration
# Kamikaze Revision 254 by nbd on OpenWrt
vlan0hwname=et0
vlan1hwname=et0
vlan0ports="0 1 2 3 5*"
vlan1ports="4 5"

#### LAN configuration
lan_proto="static"
lan_ifname="br0"
lan_ifnames="vlan0 eth1"
lan_ipaddr="192.168.1.1"
# lan_dns="192.168.1.1"
lan_gateway="192.168.1.1"

# The above has worked flawlessly
# Adding to external nameservers to /etc/resolv.conf
# gives flawless access to Internet when connected
# through the lan to the outside Internet
#### WAN configuration
# wan_proto: WAN protocol, available protocols:
#   none: disable
#   dhcp: DHCP
#   static: Static IP
#   pppoe: PPP over Ethernet
#   pptp: Point-to-Point tunneling Protocol
#     for pppoe and pptp you need to use wan_ifname="ppp0"
# wan_proto=dhcp

wan_proto="pppoe"
pppoe_ifname="vlan1"
ppp_username="username@myisp.com"
ppp_passwd="mypassword"
wan_ifname="vlan1"
# wan_ifname="ppp0"
# Tried using both ppp0 and vlan1 without success
wan_device="vlan1"
wan_ipaddr="222.111.111.253"
# IP above is just for discussion purposes
# wan_ipaddr="192.168.0.2"
wan_netmask="255.255.255.0"
# wan_gateway="192.168.0.1"
wan_gateway="222.111.111.1"
# IP above is just for discussion purposes
# wan_dns="192.168.0.1"
# Above not set until external pseudo ethernet device is settable.

## PPP over Ethernet and PPTP
# wan_ifname="ppp0"
# Used above no need for redunancy
# pptp_server_ip="192.168.0.1"
root@OpenWrt:~#
<br><br>

ifconfig vlan1 222.111.111.253

You do realize you can do an:

ifconfig --help

to overcome not knowing proper syntax right?

<quote=Ydef>
You do realize you can do an:

ifconfig --help

to overcome not knowing proper syntax right?<quote>


For several years I had always used the syntax ifconfig aaa.bbb.ccc.ddd dev eth0  or eth1 or ppp0 or some other interface. The Linux man page lists this syntax in the first line and the alternative with the interface before the inet address as the second line.  I had become so used to doing it one way, it never occured to me to try the other.

And yes, I am aware that busybox utilities have --help.

In any event, I am still not able to get the router up and running yet. But, I think I might be a bit closer to that goal. I am able to ping the external interface now. But even with the inet address set and with the;    route add default gw $wan_gtwy_addr dev vlan1   
and with
iptables -A FORWARD -i br0 -o $wan_inet_addr -j ACCEPT

I am still unable to ping any of the nameservers within /etc/resolv.conf

When I have the router plugged in to the LAN and without being connected to the dsl modem, using ssh, from the WGT634U I can ping the outside world and get names resolving.

The main linux box works fine. I would be great if there was a way to simply copy the main linux box pppoe config files and use the identical ones on the router. But as it is, the router doesn't even use an interface called ppp0 for pppoe like my main system does. I don't understand why not as of yet. My main system that acts as a router uses Debian Linux and pppoe to connect my LAN to my ISP using a dsl modem.

There is definately a need for documentation, a mini HOWTO for pppoe, dsl and a static IP, because its seems pretty easy to get confused.

Harley^ wrote:

When I have the router plugged in to the LAN and without being connected to the dsl modem, using ssh, from the WGT634U I can ping the outside world and get names resolving.

How are you able to ping the outside world without being connected to your dsl modem?
This doesn't make any sense.


Harley^ wrote:

The main linux box works fine. I would be great if there was a way to simply copy the main linux box pppoe config files and use the identical ones on the router.

That would be nice, but your router is different architecture that involves nvram and a different packaging system called ipkg. 

Harley^ wrote:

But as it is, the router doesn't even use an interface called ppp0 for pppoe like my main system does. I don't understand why not as of yet.

Have you even checked if your ppp interfaces even exist?  What does:

ifconfig -a

show you?  If you see your ppp interfaces, have you tried to bring them up with ifconfig?

Obviously it would help if you were a lot more specific with how you've attempted to troubleshoot the problem.

Ydef wrote:

How are you able to ping the outside world without being connected to your dsl modem?
This doesn't make any sense.

Sure it does ! In my crazy mixed up world ! smile You're right, it doesn't make sense without the rest of the explanation and context.
There are TWO modes I am using for testing and both are connected one at a time, to the same dsl modem. In one case, the WGT634U connects through a LAN HUB to a Linux box that is acting as the router and the main Linux box is connected directly to the dsl modem. In the second case, the WGT634U is connected directly to the dsl modem itself and is acting as the LAN router. So, to change modes from one to the other, its just a matter of plugging the ethernet cable directly into the WGT634U or in the other mode plugging the dsl modem via an ethernet cable directly into the main Linux.

When the WGT634U is only connected to the LAN HUB and not directly to the dsl modem, I uses the /etc/resolv.conf  search and nameserver settings and is able to search outside of the LAN and resolve names outside of the LAN. When the WGT634U is directly connected to the dsl modem, it can only ping internal LAN addresses (192.168.1.x) and it can ping its own WAN address but is unable to ping the WAN gateway or the nameservers nor can it resolve names.


Ydef wrote:

Have you even checked if your ppp interfaces even exist?  What does:

ifconfig -a

show you?  If you see your ppp interfaces, have you tried to bring them up with ifconfig?


Obviously it would help if you were a lot more specific with how you've attempted to troubleshoot the problem.

You mean you're not all mindreaders ?!? smile

NOTE: I HAVE A STATIC IP. My ISP does NOT set my IP via dhcp, I set it. It has been that way for about three years.

I'll post several results and will modify only information such as userid's, passwords and IP settings (ie the second and third groupings to 111.111) that are specific to my network.

root@OpenWrt:~# ifconfig -a
ath0      Link encap:Ethernet  HWaddr 00:09:5B:F7:95:E1
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

br0       Link encap:Ethernet  HWaddr 00:00:BA:DC:0D:ED
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:47 errors:0 dropped:0 overruns:0 frame:0
          TX packets:39 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:4395 (4.2 KiB)  TX bytes:6181 (6.0 KiB)

eth0      Link encap:Ethernet  HWaddr 00:09:5B:F7:A2:7C
          UP BROADCAST RUNNING PROMISC MULTICAST  MTU:1500  Metric:1
          RX packets:42 errors:0 dropped:0 overruns:0 frame:0
          TX packets:36 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:4995 (4.8 KiB)  TX bytes:6207 (6.0 KiB)
          Interrupt:4

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

vlan0     Link encap:Ethernet  HWaddr 00:00:BA:DC:0D:ED
          UP BROADCAST RUNNING ALLMULTI MULTICAST  MTU:1500  Metric:1
          RX packets:47 errors:0 dropped:0 overruns:0 frame:0
          TX packets:39 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:4583 (4.4 KiB)  TX bytes:6337 (6.1 KiB)

vlan1     Link encap:Ethernet  HWaddr 00:09:5B:F7:A2:7C
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wifi0     Link encap:Ethernet  HWaddr 00:09:5B:F7:95:E1
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:199
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:2 Memory:c0080000-c0090000

root@OpenWrt:~#

# No ppp0 ?  and yet /dev/ppp exists

root@OpenWrt:~# lsmod
Module                  Size  Used by    Tainted: P
ehci_hcd 25744 0 - Live 0xc0153000
uhci_hcd 27792 0 - Live 0xc014b000
usb_storage 27440 1 - Live 0xc0127000
sd_mod 12080 2 - Live 0xc011e000
scsi_mod 71360 2 usb_storage,sd_mod, Live 0xc0187000
usbcore 103584 4 ehci_hcd,uhci_hcd,usb_storage, Live 0xc016c000
vfat 8736 1 - Live 0xc0123000
fat 44528 1 vfat, Live 0xc0131000
nls_iso8859_15 3328 0 - Live 0xc00bf000
nls_iso8859_1 2816 1 - Live 0xc00bd000
nls_cp437 4352 1 - Live 0xc00ba000
nls_base 4576 5 vfat,fat,nls_iso8859_15,nls_iso8859_1,nls_cp437, Live 0xc009e000wlan_scan_sta 9568 0 - Live 0xc0093000
wlan_scan_ap 3072 0 - Live 0xc007e000
wlan_xauth 416 0 - Live 0xc0091000
wlan_wep 4576 0 - Live 0xc009b000
wlan_tkip 10752 0 - Live 0xc0097000
wlan_ccmp 6112 0 - Live 0xc006c000
wlan_acl 2880 0 - Live 0xc006f000
ath_pci 85424 0 - Live 0xc00a1000
ath_rate_sample 8512 1 ath_pci, Live 0xc0071000
ath_hal 207072 3 ath_pci,ath_rate_sample, Live 0xc00ea000
wlan 161792 10 wlan_scan_sta,wlan_scan_ap,wlan_xauth,wlan_wep,wlan_tkip,wlan_ccmp,wlan_acl,ath_pci,ath_rate_sample, Live 0xc00c1000
pppoe 10816 0 - Live 0xc005e000
pppox 1424 1 pppoe, Live 0xc006a000
ppp_generic 26368 2 pppoe,pppox, Live 0xc0076000
slhc 5600 1 ppp_generic, Live 0xc0067000
switch_robo 3920 0 - Live 0xc0065000
switch_core 5056 1 switch_robo, Live 0xc0062000
root@OpenWrt:~#
# nbd suggested using vlan1 on Feb18/06
root@OpenWrt:~#ifconfig vlan1 216.111.111.46

root@OpenWrt:~#ifconfig vlan1
vlan1     Link encap:Ethernet  HWaddr 00:09:5B:F7:A2:7C
          inet addr:216.111.111.46  Bcast:216.111.111.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:30 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:1080 (1.0 KiB)

root@OpenWrt:~#ifconfig ppp up
ifconfig: ppp: error fetching interface information: Device not found
root@OpenWrt:~#ifconfig ppp0 up
SIOCGIFFLAGS: No such device
root@OpenWrt:~#

root@OpenWrt:~#ping -c 5 216.111.111.14 
# one of the nameservers in /etc/resolv.conf results in 100 % packet loss
root@OpenWrt:~# ping -c 5 216.111.111.1
# my own gateway results in 100 % packet loss
root@OpenWrt:~# ping -c 5 215.111.111.46
# my own wan interface results in 100 % SUCCESS.
root@OpenWrt:~#
root@OpenWrt:~#iptables -A FORWARD -i br0 -o 216.111.111.46 -j ACCEPT
# same ping results without it as those above without the iptables setting
root@OpenWrt:~#

root@OpenWrt:~#cat /etc/config/network
#### VLAN configuration
vlan0hwname=et0
vlan1hwname=et0
vlan0ports="0 1 2 3 5*"
vlan1ports="4 5"


#### LAN configuration
lan_proto="static"
lan_ifname="br0"
lan_ifnames="vlan0 eth1"
lan_ipaddr="192.168.1.1"
# lan_dns="192.168.1.1"
lan_gateway="192.168.1.1"
# The above works flawlessly with the router plugged into the LAN HUB

#### WAN configuration
# wan_proto: WAN protocol, available protocols:
#   none: disable
#   dhcp: DHCP
#   static: Static IP
#   pppoe: PPP over Ethernet
#   pptp: Point-to-Point tunneling Protocol
#     for pppoe and pptp you need to use wan_ifname="ppp0"
# wan_proto=dhcp

wan_proto="pppoe"
pppoe_ifname="vlan1"
ppp_username="myuserID@myisp.com"
ppp_passwd="mypasswrd"
# wan_ifname="vlan1"
wan_ifname="ppp0"
wan_device="vlan1"
wan_ipaddr="216.111.111.46"
# wan_ipaddr="192.168.0.2"
wan_netmask="255.255.255.0"
# wan_gateway="192.168.0.1"
wan_gateway="216.111.111.1"
# wan_dns="192.168.0.1"

## PPP over Ethernet and PPTP
# wan_ifname="ppp0"
# same as above
# pptp_server_ip="192.168.0.1"
root@OpenWrt:~#

Still no ppp0 and still unable to ping outside of my own IP (ie. 216.111.111.46)

Any suggestions are welcome.

Your ethernet device should always be up, but it doesn't get an IP # because it's not using IP at all.

Your S10boot file in /etc/init.d should have had an ifconfig eth0 promisc up line in it so i'm not sure why when you do an ifconfig all you see is your vlan1 device.

Have you tried installing the rp-pppoe-client package and using the tools in there to facilitate getting your pppoe to work?

@flyashi

I had installed your Kamikaze Image with the USB-Kernel but i´m missing some packages from your source.
e.g. i want to install samba :

Installing samba (2.0.10-1) to root...
Downloading http://flyashi.dyndns.org:81/packages// … mipsel.ipk
Nothing to be done
An error ocurred, return value: 1.
Collected errors:
ERROR: Cannot satisfy the following dependencies for samba:
         libgcc

And as you see libgcc can not be found

I want to install vpnc and the kmod-tun can not be found:

root@OpenWrt:/etc/vpnc# ipkg list kmod-tun
kmod-tun - 2.6.15.3-brcm-1 - Kernel TUN/TAP extension
Done.
root@OpenWrt:/etc/vpnc# ipkg install kmod-tun
Installing kmod-tun (2.6.15.3-brcm-1) to root...
Downloading http://flyashi.dyndns.org:81/packages// … mipsel.ipk
wget: server returned error 404: HTTP/1.0 404 Not Found
Nothing to be done
An error ocurred, return value: 22.
Collected errors:
ipkg_download: ERROR: Command failed with return value 1: `wget --passive-ftp    -q -P /tmp/ipkg-bxnYim http://flyashi.dyndns.org:81/packages//kmod-tun_2.6.15.3-brcm-1_mipsel.ipk'
Failed to download kmod-tun. Perhaps you need to run 'ipkg update'?

Is there a reason for that behavior, or just an error ?

Either, a) your ipkg.conf is wrong, or b) I haven't compiled those packages (not selected in my menuconfig). I'll check the packages you mentioned; I think I selected everything that compiled.

- Yasha

P.S. If you're in the USA, stock up on CompUSA's $39 + tax SHIPPED WGT's! smile smile smile smile I got four. About to install on the first one right now... i'll let you know if my images work then big_smile

Put OpenWrt on my first WGT. Actually first one didn't work, because with nbd's .cfg I didn't get a DHCP IP. Second one I tried also didnt, but this time I was on IRC and nbd told me to set a static IP. That worked, got openwrt on it. And ... nothing.

Hacked up a serial console (a story in itself) and turns out that the USB image is HORRIBLY broken. No /etc/modules.d folder for madwifi. Terrible everything. Turns out my script actually wasn't using the usb.config during the usb compile. don't know what it was using... regular maybe? anyway, it's horribly broken.

Trying to compile something good now to put on this thing, otherwise it's like NASA's Apollo 13, a successfull failure. This will be a "working brick" if I don't get a good image on it!

So for now, STAY AWAY!!!

- Yasha

OK.
Clear words.

And with the serial Cable...
I know EXACTLY what you mean big_smile
And for me the solution was a Siemens mobile phone cable.

But anyway,
the hope that i had, was to get the usb-port realy working.
because with the original firmware from Netgear the port was horribly slow.
So if you could make this working... i think i would cry for luck. smile

But..
i think there somthing more wrong, than the usb-image.
I know there where more packages in your repository.
Some kmod´s i think and maybe something more.

K-Pax

K-pax:

I got my latest usb-image to work... HORRIBLE mess. I think i'm gonna switch to once-daily and "make clean" every time. After a "make clean" it seems to work. Did one just now. Added the changes mentioned on pg. 2 (add autocreate=ap to 20-madwifi, add "wlanconfig", "iwconfig", and "wifi up" to S20madwifi, and add ath0 to lan in /etc/config/network).

It ... works. Surprizingly. After a few kernel panics, my night (it's almost 5am here) is FINALLY A SUCCESS! So much so that.. *gulp*.. i'm gonna close this thing up. YES! I believe I"M DONE WITH SERIAL!!! (for now).

Anyway, if you have a serial cable, there's no mess I've gotten into that it didn't get me out. Except when the  serial cable was broken. Reversed +V and gnd. 3rd time. 1st time fried a radiotransmitter. 2nd time fried the H-bridge on the wificar. 3rd time - the max survived it cuz i got it away fast enough.

So... try it. Why the hell not.

- Yasha

Your update is online ?
I ask, because i see at http://flyashi.dyndns.org:81/bin/ a creation time of 3:39 EST

Many thanks for your work.
Here in germany it´s 11:21 and i have much time to mess up my Router big_smile

flyashi wrote:

K-pax:

I got my latest usb-image to work... HORRIBLE mess. I think i'm gonna switch to once-daily and "make clean" every time. After a "make clean" it seems to work. Did one just now. Added the changes mentioned on pg. 2 (add autocreate=ap to 20-madwifi, add "wlanconfig", "iwconfig", and "wifi up" to S20madwifi, and add ath0 to lan in /etc/config/network).


- Yasha

Yay!  You mean you finally have a router and can actually troubleshoot/debug your own images now?!  Fantastic! :)

Now if you only had a normal wrt54g/gs so you could fix/verify those images as well, that would take cake! ;)

So what's the status of the usb image at the moment by the way?  Did you add the script i put up in the wgt634u as /linuxrc so that it will use the usb drive as root by default?

@Ylashi

Hi there.
I miss your  "normal" images are missing at http://flyashi.dyndns.org:81/bin/
and there is no Packages-File for ipkg.

The USB-Image work so far, with some errors, but i´m able to mount a USB-Stick.

See this:
couldn't load module 'wlan_scan_ap' (-89)
unable to load wlan_scan_ap
wifi0: Atheros 5212: mem=0x40000000, irq=2
wlan: mac acl policy registered
cifs: Unknown symbol load_nls_default
cifs: Unknown symbol load_nls
cifs: Unknown symbol unload_nls
fat: Unknown symbol utf8_wcstombs
fat: Unknown symbol load_nls
fat: Unknown symbol unload_nls
vfat: Unknown symbol fat_dir_empty
vfat: Unknown symbol fat_fs_panic
vfat: Unknown symbol fat_get_dotdot_entry
vfat: Unknown symbol fat_free_clusters
vfat: Unknown symbol fat_scan
vfat: Unknown symbol fat_date_unix2dos
vfat: Unknown symbol fat_search_long
vfat: Unknown symbol utf8_mbstowcs
vfat: Unknown symbol fat_attach
vfat: Unknown symbol fat_build_inode
vfat: Unknown symbol fat_fill_super
vfat: Unknown symbol fat_alloc_new_dir
vfat: Unknown symbol fat_notify_change
vfat: Unknown symbol fat_remove_entries
vfat: Unknown symbol fat_add_entries
vfat: Unknown symbol fat_sync_inode
vfat: Unknown symbol fat_detach
usbcore: registered new driver usbfs
usbcore: registered new driver hub
PCI: Enabling device 0000:00:03.0 (0000 -> 0002)
ohci_hcd 0000:00:03.0: OHCI Host Controller
ohci_hcd 0000:00:03.0: new USB bus registered, assigned bus number 1
ohci_hcd 0000:00:03.0: irq 6, io mem 0x18003000
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 2 ports detected
PCI: Enabling device 0000:01:02.0 (0000 -> 0002)
PCI: Fixing up device 0000:01:02.0
ohci_hcd 0000:01:02.0: OHCI Host Controller
ohci_hcd 0000:01:02.0: new USB bus registered, assigned bus number 2
ohci_hcd 0000:01:02.0: irq 2, io mem 0x40010000
hub 2-0:1.0: USB hub found
hub 2-0:1.0: 1 port detected
PCI: Enabling device 0000:01:02.1 (0000 -> 0002)
PCI: Fixing up device 0000:01:02.1
ohci_hcd 0000:01:02.1: OHCI Host Controller
hub 1-0:1.0: Cannot enable port 1.  Maybe the USB cable is bad?
ohci_hcd 0000:01:02.1: new USB bus registered, assigned bus number 3
ohci_hcd 0000:01:02.1: irq 2, io mem 0x40011000
hub 3-0:1.0: USB hub found
hub 3-0:1.0: 1 port detected
hub 1-0:1.0: Cannot enable port 1.  Maybe the USB cable is bad?
SCSI subsystem initialized
Initializing USB Mass Storage driver...
hub 1-0:1.0: Cannot enable port 1.  Maybe the USB cable is bad?
hub 1-0:1.0: Cannot enable port 1.  Maybe the USB cable is bad?
usb 1-2: new low speed USB device using ohci_hcd and address 6
usb 1-2: device descriptor read/64, error -145
usb 1-2: device descriptor read/64, error -145
usb 1-2: new low speed USB device using ohci_hcd and address 7
usb 1-2: device descriptor read/64, error -145
usb 1-2: device descriptor read/64, error -145
usb 1-2: new low speed USB device using ohci_hcd and address 8
usb 1-2: device not accepting address 8, error -145
usb 1-2: new low speed USB device using ohci_hcd and address 9
usb 1-2: device not accepting address 9, error -145
usbcore: registered new driver usb-storage
USB Mass Storage support registered.
usb 1-1: new low speed USB device using ohci_hcd and address 10
usb 1-1: device descriptor read/64, error -145
PCI: Enabling device 0000:01:02.2 (0000 -> 0002)
PCI: Fixing up device 0000:01:02.2
ehci_hcd 0000:01:02.2: EHCI Host Controller
usb 1-1: device descriptor read/64, error -145
ehci_hcd 0000:01:02.2: new USB bus registered, assigned bus number 4
ehci_hcd 0000:01:02.2: irq 2, io mem 0x40012000
ehci_hcd 0000:01:02.2: USB 2.0 started, EHCI 1.00, driver 10 Dec 2004
usb 1-1: new low speed USB device using ohci_hcd and address 11
hub 4-0:1.0: USB hub found
hub 4-0:1.0: 2 ports detected
usb 1-1: device descriptor read/64, error -145
usb 1-1: device descriptor read/64, error -145
usb 1-1: new low speed USB device using ohci_hcd and address 12
usb 1-1: device not accepting address 12, error -145
usb 1-1: new low speed USB device using ohci_hcd and address 13
usb 1-1: device not accepting address 13, error -145

And now...
Some samba would be nice and for sure the Packages-File.

K-Pax

K-pax: I was thinking the same thing!

Unfortunately, I can't get sablevm-classpath to compile, becuase it thinks I don't have a java compiler. Maybe I don't, I dunno. Anyway I'm workin' on it. When that compiles, everything else will (the normal images, samba, and everything else).

Also, how'd u get the USB drive to work? I can't. I know you need ohci instead of uhci, but ... aw, nevermind, i'll work it out.

Normal images should be up soon, along with Packages file, samba, libgcc, etc. I need 'em too.

- Yasha

ohh, ehhh...
I pluged the stick in, and ..... it works.
Mount was no problem.
Ahh.
I formated the stick with ext2.
Formating with vfat works, but i can´t mount.

That´s all what i can say about this.

K-Pax

Ah, mine's vfat. I'm having t rouble insmod'ing the vfat module, too. Could be it. So, my default USB image actually works with USB? Cool!

- compiling samba now...

Hm...
I think the only fs that mounts is ext2
Tried with ext3: mount: Mounting /dev/scsi/host1/bus0/target0/lun0/part1 on /mnt/usb failed: Invalid argument
Same with msdos, vfat

Edit:

I forgot the kmod´s, but loading them failed:
root@OpenWrt:/# insmod ext3
insmod: cannot insert `/lib/modules/2.6.15.3/ext3.ko': Invalid parameters (17):Invalid argument
root@OpenWrt:/# insmod fat
insmod: cannot insert `/lib/modules/2.6.15.3/fat.ko': Invalid parameters (2): Invalid argument
root@OpenWrt:/# insmod vfat
insmod: cannot insert `/lib/modules/2.6.15.3/vfat.ko': Invalid parameters (2): Invalid argument


K-Pax

(Last edited by K-Pax on 4 Mar 2006, 22:53)

Same here. Dunno why. I'll try make-clean'ing the kmod-fs's and retrying.

Ok. Good luck.
For me that was it for today.
Whispering: My wife want´s to go Downtown, it´s about 10:00 PM here in Germany. wink

Will see tomorow.

K-Pax

Hm.  I don't have any problem with the usb, my drives are ext3, and again, I specifically do NOT use the ohci module since it only brings up the low speed crap.  I'm able to have my usb drive running with ehci, uhci, usb-storage, usbcore, and scsi_mod.

Of course I'm still back on image 3257 and haven't loaded any new images within the last week so I'm not sure if some of the new images have regressed.

I think Ydef is right.

Removed ohci-hcd -> No usb-storage device any more.
Only with loaded ohcd-hcd my usb-stick will be recognised.

Still problems with samba:
root@OpenWrt:/# ipkg install samba
Installing samba (2.0.10-1) to root...
Downloading http://flyashi.dyndns.org:81/packages// … mipsel.ipk
Nothing to be done
An error ocurred, return value: 1.
Collected errors:
ERROR: Cannot satisfy the following dependencies for samba:
         libgcc

And i think the two images "normal" and the usb-image are identical.

You are, indeed, correct. About samba/libgcc/identical images.

Turns out I'm not very organized (who knew?). Accidentally compiled usb stuff in default images. And didn't save .config with libgcc. And my svn was locked (?). So... i think we're back on track now. In about 11 mins (avg recompile time) all the stuff should be up - non-usb images, libgcc, the Packages file, etc.

I'll check your tip on the USB stuff. My drive is a 250gb Maxtor USB, uses vfat. I remember I had the "cannot mount vfat module: invalid argument (17)" problem before.. [mbm] helped me fix it. Don't remember how... i'll check the logs smile

So.. yea selected some new stuff, should be up soon. Oh, and J4k3 put up a madwifi-old package link: http://www.intrastar.net/~jsuter/openwr … mipsel.ipk . He also submitted it to svn, so it should be up on my package list, too.

Well, hope everything's going well now. Thanks again for the tip, K-pax!

- Yasha

Hm...
Dealing around with vfat...
Figured out that the nls-support must be activated.
Than a vfat formatted drive mounts.
Have some problems with user-rights.
Samba works so far. Many Thanks for that.

Usb-storage works still only with ohci-driver

Hm...

I think I had my drive working without UHCI. UHCI just gave a bunch of errors and never detected my USB port. OHCI determines the manufacturer of the drive, its capacity, and everything else. Just couldn't mount it 'cuz of vfat. I remember it was a codepage problem - I think nls-support fixed it. Thanks for that.

- Yasha

P.S. If I get it worked out, I'll let you know.

Sorry, posts 76 to 75 are missing from our archive.