OpenWrt Forum Archive

Topic: Kamikaze WGT634U Configuration?!

The content of this topic has been archived between 20 Jan 2018 and 5 May 2018. Unfortunately there are posts – most likely complete pages – missing.

Add a space:

if(space)[(space)-x(space)/path/to/file(space)];(space)then
   # do stuff
fi;

Works for me... but the space thing is really annoying; it's almost faster to type out `test` !

- Yasha

Doh!  After getting a night's rest (always recommended) i see my silliness from the abundance of /etc/init.d scripts that use conditional construct flags. 

Thanks for the clarification anyway!  smile

Flyashi:  Have you had a chance to add the getty feature as a compile time option?  This would be a great help in terms of use with the serial port (allowing it to auto-resize the terminal) for both the usb and the regular compiled binaries if a getty can be used in the inittab like in normal linux rather than the weak tts.

Please let me know, as this would be a good enough reason to upgrade with your latest compiled. smile  Thanx again.

Yup, I think it's in. USB at least, haven't compiled regular in about a week.

Cool. 

Also, where's the configs dude?

My wgt634u quit responding after atemting to do an update.  I have a serial link and can get into the CFE.  I tryed to load the (openwrt-wgt634u-2.6-squashfs.bin) but it comes back with a "Timeout occured".  Any idea of what I am doing wrong? Need all the help I can get.

Your TFTP server didn't respond fast enough. Check to make sure it's on the right port, on the right IP. Make sure you've set a static IP on the PC and the router, and that they're on the same subnet. Make sure the Ethernet cable is plugged into the *WAN* port on the router.

Good luck.

Adrianlem wrote:

Not sure of my setup, just using the configuration as shown on the WGT634U per step 2.2 using serial console.  The part I may be having trouble with is the step that is used under (Flash -noheader 192.168.0.3:wgt634u/openwrt-wgt634u-2.6-squashfs.bin Flash0.os) I take it that it was getting its file from OpenWrt. [...]

I wrote the flash command above.  Note that the 192.168.0.3 is just where my tftp server happened to live.  You'll have to adjust the command to match your environment.  Furthermore, you need to put the .bin file in the appropriate place for your tftp server.

Loaded netgear.img.1 and .2 with succes.  Reset my WRT634U but still does the same thing as before just flashes the wireless light and the power led stays on.  The reset has no effect and the Mac says failed on my CFE screen.  Also the lan light works.  Its been a long time and I have to brush up on how to make a file using tftp.  Working on it.

Indeed.  Having a functional tftp server is key if you want to be playing around with the unstable images.  Otherwise, attempting the flash command you posted (flash -noheader 192.168.0.3:wgt634u/openwrt-wgt634u-2.6-squashfs.bin Flash0.os) is nothing short of pointless.

Well I have it my tftp going now, seems to work ok. not much luck thoe.  used a link that used the serial, said it was to restore to original netgear using there tftp and netgear.img 1 and 2. did not do a thing for me. read it flashed it and rebooted according to instructions but still no fifferent then what I started with.
PS sorry Im such a dummy but how is one to learn.  I am new to this and trying to get information from those who know what they are doing.  I have been readding a lot just need to put to practice what I can make of it.

Where can I get this (wgt634u/openwrt-wgt634u-2.6-squashfs.bin) might be a cure for what I could use or try next.

Thanks for the feed back.

(Last edited by Adrianlem on 26 Mar 2006, 08:24)

Adrianlem: I am new at this stuff too, I was having a problem similar to yours and I figured out that my STARTUP environment variable didn't have the command to boot the firmware that it needs.  do a printenv and look at your STARTUP variable and make sure it has something like "boot -elf flash0.os:" in it.  That command needs to happen otherwise it will stay in CFE.

Hello,
I am happy now that compiled Kamikaze from sources and that I have it running on my wgt634u. My concern is about the  documentation in the openwrt web-site, it is not complete about the netgear and  it concern mostly the white-russian version.  I have to rely on browsing this forum, and I find it difficult to find the right information.
I think it would help if someone could update the documention in the openwrt forum.

My target now is to have a minimal version with wireless driver working in managed mode and the packages in a usb key.

Hi,
if this can help,
I managed to have my wireless settings working, 
now my wgt634u router connect as a station in
managed mode  to my main router wich is 192.168.0.1.
my setting is:
in /etc/modules.d/20-madwifi
-> ath_pci autocreate=sta
in /etc/init.d/ S20madwifi
iwpriv ath0 mode 0
iwconfig ath0 essid "mylanessid"
iwconfig ath0 key 00:xx:yy:zz... private date separated by :
ifup ath0

in /etc/config/network  I had to remove ath0 from the bridge,
my config is now:

#### LAN configuration
lan_proto="static"
lan_ifname="br0"
lan_ifnames="vlan0"
lan_ipaddr="192.168.3.1"
lan_netmask="255.255.255.0"

#lan_proto="static"
#lan_ifname="ath0"
#lan_ipaddr="192.168.0.7"
#lan_netmask="255.255.255.0"

wan_proto=static
wan_ifname="ath0"
wan_device="ath0"
wan_ipaddr="192.168.0.7"
wan_netmask="255.255.255.0"
wan_gateway="192.168.0.1"
wan_dns="67.234.xxx.xxx"

-------------
I have a 802.11b based network so I set the mode to 0 but I am not sure if it necessary big_smile

I have a little question: hmm
I have to manually mount the usb key
I created a FSTAB file but its not working
so I mount it manualy like this:
root@OpenWrt:/etc/config# mount -t ext2 /dev/scsi/host1/bus0/target0/lun0/part1 ~/mnt/sda1

I would like to have usb managed by hotplug.d, then if I plug a webcam  or a usb-key it woud be detected
properly smile

for youre information this is some dmesg  exttract:
sda: assuming drive cache: write through
/dev/scsi/host1/bus0/target0/lun0: p1 p2
sd 1:0:0:0: Attached scsi removable disk sda
usb-storage: device scan complete

Hello there,

My webcam is not working when I plug it through a usb-hub
but it works perfectly when I plug it in directly in the usb ports.
The other devices in the hub, usb-keys.. works perfectly.

When I do an insmod spca5xx, it creates the /dev/v4l/video0 device but there is an error message in dmesg:

spca561.h: [spca561_init:469] Find spca561 USB Product ID 561
linux-2.6-brcm/spca5xx-20060301/drivers/usb/spca5xx.c: init isoc: usb_submit_urb(0) ret -89

Is this a known problem, and is there a way to fix it smile

Thanks
Gilles

It could be, that the webcam draws too much power (or claims to draw too much power) for the hub. Try a powered hub.. that'd be my guess. I've got one coming, so I'll check out webcam, hard drive, USB speakers, USB sound card, and every other USB device I can find into the poor little WGT big_smile

Good luck, and let us know if a powered hub works better if you get a chance to try it before I do.

- Yasha

P.S. What webcam are you using?

-Yes my usb-hub is already powered

-webcam is:
Xmaster Viewcam model pk-510
I alo tried with a Labtec.

- this is another print of dmesg:
.../spca5xx-20060301/drivers/usb/spca5xx.c: [spca5xx_getcapability:2188] maxw 352 maxh 288 minw 160 minh 120

PS- I am trying to use a webcam as a surveillance system using the motion program to send
me an email when detecting movement.
I have the cam working, the motion program working and now configuring procmail to send the messages,
and I have a lot of fun with it.

Thanks for your prompt answer
Gilles

The discussion might have continued from here.