OpenWrt Forum Archive

Topic: Support for Marvell 88F5xx81 based routers

The content of this topic has been archived between 18 Jan 2014 and 6 May 2018. Unfortunately there are posts – most likely complete pages – missing.

My guess of the bricking risk is "high".

Check the first two bytes of /dev/mtdblock0:

dd if=/dev/mtd0 bs=16 count=1 | hexdump -e '1/1 "%02x"'

If it is "2705..." then it will brick, if it is "8519..." you may try.

Fwiw, I am in US, and running 10.03 (backfire).  Running this command on my wnr854t shows 8519:

root@MyWnr854T:~# dd if=/dev/mtd0 bs=16 count=1 | hexdump -e '1/1 "%02x"'
1+0 records in
1+0 records out
851903200c00*

Looks promising.

If someone can sysupgrade a WNR854T with the "8519" change without bricking, then I will create a patch for trunk and get it committed, also into Backfire for the next release (10.03.1).
Use sysupgrade with "-n" for a clean config after flashing.

Can also someone explain how to flash back a stock firmware image on WNR854T?

(Last edited by maddes.b on 16 Jun 2010, 20:18)

I have always had good results with putting wnr854t netgear firmware from the uboot serial tftp method outlined here in:

https://forum.openwrt.org/viewtopic.php … 089#p94089  (and the post right below this post stating correction to cp.b parameters)

For OpenWrt's sysupgrade with WNR854T (with script change from #899) this turns into the following command sequence.
It is recommended to do this on a separate Linux machine as "dd" takes a lot of time and may exceed the router's ram (=stalling the router).

cd /tmp
# downloading world-wide firmware, for USA use ftp://downloads.netgear.com/files/WNR854T_V1.4.38NA.img
rm -f WNR854T_V1.4.38.img
wget ftp://downloads.netgear.com/files/WNR854T_V1.4.38.img
# dd can take a lot of time, removes the first 0x14 bytes (=img header) of the image
dd if=WNR854T_V1.4.38.img of=stock_V1.4.38.bin bs=$(( 0x14 )) skip=1

Upload stock_V1.4.38.bin to the router at /tmp

cd /tmp
sysupgrade -n stock_V1.4.38.bin

Thanks nd_100 for the link.

(Last edited by maddes.b on 17 Jun 2010, 13:48)

maddes.b wrote:

If someone can sysupgrade a WNR854T with the "8519" change without bricking, then I will create a patch for trunk and get it committed, also into Backfire for the next release (10.03.1).
Use sysupgrade with "-n" for a clean config after flashing.

Unfortunately, I had my last communication with my router today:

root@WNR854T:/tmp# dd if=/dev/mtd0 bs=16 count=1 | hexdump -e '1/1 "%02x"'
1+0 records in
1+0 records out
851903200c00*


root@WNR854T:/tmp# wget ftp://ftp.maddes.net/openwrt/trunk/orio … i+ipv6.img
Connecting to ftp.maddes.net (85.25.150.198:21)
openwrt-wnr854t-squa 100% |*******************************|  3584k 00:00:00 ETA
root@WNR854T:/tmp# md5sum openwrt-wnr854t-squashfs.release-luci\+ipv6.img
4aef9a7596ed5ba243aa2e5a7f6b8bfc  openwrt-wnr854t-squashfs.release-luci+ipv6.img
root@WNR854T:/tmp# sysupgrade -n -v /tmp/openwrt-wnr854t-squashfs.release-luci\+ipv6.img
Switching to ramdisk...
mount: mounting mini_fo:/overlay on /mnt failed: Function not implemented

Performing system upgrade...
Unlocking image ...
Writing from <stdin> to image ...
Upgrade completed
Rebooting system...

The upgrade took about 20-30 seconds to complete before the "Rebooting system" message came.
After that, I am unable to ping 192.168.1.1 (sigh)
I left the router untouched for 5 more minutes and then tried reset, no lock.
Should I try another address, or is it time to open up the router to try to gain serial access?

192.168.1.1 is the default ip address, also try a telnet connection to the router.
Re-flashing the old working image (or the stock image, mentioned as #1 in your post) would have been a better idea than flashing a new trunk build (=alpha state).
Note that switches in your network may have old ARP entries in their caches.

The lines in red from sysupgrade's verbose output are normal and can be ignored on these devices, as described in the sysupgrade post.

(Last edited by maddes.b on 18 Jun 2010, 12:33)

Telnet timed out. arp flush had no effect.

Yes, on hindsight flashing with a stable firmware would have made more sense. Well at least this will (hopefully) get me to open up the router and solder a serial or jtag header and try some hardware fun smile

Will read up on the link given by nd_100

When you get serial access to your WNR854T, then first check what is wrong with the current flashed version (make a copy of the boot log).
After that you can choose to either fix it or flash a new image via tftpboot.

StrikerNL wrote:
Watha wrote:
maddes.b wrote:

If a "wifi up" doesn't fix it, then try a daily reboot as mentioned in post #751.
Also try "11g" mode only (no N mode).

A daily reboot would fix it, but I dislike having my connections interrupted. I'll try 11g mode.

As maddes says, switching 11ng to 11g mode will likely fix it. We have multiple devices, and the wifi devices seem to differ between 2.0 and 2.1. On some of these it seems it will only work well with mode set to 11g, and for some it will only work well with mode set to 11ng. This is what I've experienced anyway.

That could be it, I've got 2.0 hardware. Anyway, 11g mode is working fine after 7 days.

Hi!
I've registered myself in this forum, some weeks ago, at least to say "thanks" to everyone helped to transformate my "paper weight" wrt350n into a router. I still trying to find the right tissue to dry my eyes from joyfull tears... So... THANKS!!!

I have just few questions, but this is is the most important, at least for me...
I've downloaded firmware I'm using from http://backfire.openwrt.org/10.03/orion … pgrade.img but, I've seen that there is also an x-wrt download site: http://downloads.x-wrt.org/xwrt/backfir … pgrade.img.

The latter seems to be more recent than the former: does one better than the other or are they the same?

They are quite similar, biggest difference is the included web interface: luci inside the openwrt.org downloads, and webif inside the xwrt.org downloads.
It's mainly personal preference.

(Last edited by maddes.b on 22 Jun 2010, 17:39)

Uhm... This seems a personal misunderstanding. I thought that webif was the short term for "web interface", thus the nickname "webif" and luci was the name of the specific application.

I will give a shot to webif, if it's worth: actually I'm pleased with luci so I don't care that much. Anyway the other router is under RMA by netgear so this one is the "last standing man" and I can't bet on its skin smile smile

Just because you seems to be very kind, a couple of questions: did you get wrt350n to do something "more" than simple accessing the net without doing a RAM upgrade? I mean:
-samba;
-mt-daapd;
-transmission-daemon;
-amuled (just in case).

I could add, obviously, an usb drive with a nice swap file...

Edit:
p.s.: I don't have much time to investigate now, but I'm a proud user of Ubuntu, which uses the same kernel release of openwrt. I noticed that last update brought more stability and less cpu consuption: are you thinking to upgrade to same level as kernel.org?

(Last edited by bhonder on 22 Jun 2010, 00:52)

The wiki has a page that explains how to add additional packages on an usb device, another wiki page tells how to boot from an usb device. http://wiki.openwrt.org/

My application list for my router is very short: OpenVPN
In my house applications like Samba, ProFTPd, Subversion, Firefly/mt-daapd, etc. belong onto a NAS device (here Buffalo Linkstation Live V2, see http://www.nas-central.org )

About Ubuntu note:
Different architecture => different source and compiler => different results
It depends if the advantages came from generic code changes, arch-specific code changes or arch-specific compiler optimization. (normally all three)
Trunk (=alpha version, current development) is currently at kernel 2.6.34, while backfire (official release) is at 2.6.32 and will stay there (that's what I heard from the OpenWrt team).

(Last edited by maddes.b on 22 Jun 2010, 17:54)

Quick question. Just add an allegedly gigabyte ethernet capable pc to the net.
The corresponding ethernet port's led is solid yellow: what does it means?
I've tried to google but found no clue.

Edit...
Ok. My brain is dumb. Just looking at dmesg showed me that yellow means gigabyte connection.
I was thinking, in fault, that yellow=problem.
As stated before, my mind is a dummy device... smile

(Last edited by bhonder on 1 Jul 2010, 11:17)

Hi, maddes.b
I see you are using WRT350Nv2. Are you also experiencing wireless problems when connection is lost and you can not connect to it anymore, and also using 40MHz wide channel is terribly slow.
I created a topic describing my problem in details, but it did not receive much attention. https://forum.openwrt.org/viewtopic.php?id=25434

Read the wiki page for your hardware.

I did. And it is not like wireless is becoming unstable over time requiring a restart. It just restarts after what no client can connect to it. Daily restarts will not do much good either, because sometimes this happens 3 or 4 times in one hour. And 40MHz channel is slow all the time. I can switch to "g" only mode to see if that works, but then there is no point in having an "N" capable router and clients. I just hope this can be fixed in future versions.

nbd just updated the mac80211 package for Backfire.
I compiled a build of it, if anyone wants to test it.

Use at your own risk!
The build does not have a web interface, so you have to install it with opkg via console. Read the thread for more info, e.g #300.
Squashfs and Ramdisk images are uploaded.
As always this is just a temporary repository, so keep a local backup if you need it.
ftp://ftp.maddes.net/openwrt/backfire/o … ild_22047/

(Last edited by maddes.b on 2 Jul 2010, 20:26)

is the stock wireless card supported by openwrt in the meantime? if not will it be supported in the future?
and last question which card would you recommend if exchange of stock card is needed?

I'm using 10.03.1 rc1 and still wireless in g+n mode is unstable sad

@cybero2912:
if you mean WNR854T, then it is still not supported.
if you mean WRT350Nv2, then read slowmo's answer, although note that he really means "g plus n" and not "g and n".

(Last edited by maddes.b on 16 Aug 2010, 23:02)

Hi maddes.b
thx for the quick answer
yes I was asking for WNR854T (sorry forgot to mention device name in my post)

so there is no support for the integrated WIFI atm and in the future it will be MAYBE supported...
and if I need wireless support right now I have to buy another card.

how about this one:
http://www.gigabyte.de/Products/Communi … N-WI03N-RH
atheros AR5416  Chipsatz , 3x antenna connectors

Hi all smile

I know the focus has been hot on the wifi front for the wnr854t.
I am also wondering about the gigabit switch and wan performance in 10.03

I found this ticket: https://dev.openwrt.org/ticket/7387

I get about the same SLOW performance listed there.

@cybero2912
@nd_100
@Nilfred
@jcwoltz
@erik___

Can anyone confirm this with later than 10.03 release?
The victory of wifi drivers may be short lived in the face of less than 1/2 of 11g thru put from lan & wan.

Hi everybody,

due to private reasons I will not be able to continue pushing the Orion platform in OpenWrt any longer.
I hope that some people with Linux skills in coding/scripting will take over or someone gets involved who wants to learn these.
Will still be subscribed to the thread, but won't be as active as before.
Edit: Comments about my retreat please via PM.

Here's a list of tasks that are left for the Orion platform:
* Sub targets for Orion devices due to different hardware features
   (Knowledge: OpenWrt build system, Linux kernel configuration)
   a) Wireless/WLAN/Wifi cards
   b) USB (on WRT350Nv2 & DT2, but not on WNR854T)
   c) Crypto hardware (What config is needed for what device or for Orion in general?)
* Full WNR854T Wireless/WLAN/Wifi support (mode "ap") with legal firmware
* /etc/diag.sh script for easier analysis by experts and newbies
   (Knowledge: Linux scripting)
* Wireless stability issues on WRT350N v2
   (Knowledge: Linux kernel coding, hardware, wireless)
* Alternative for wireless client bridge support (see ticket #7918)
   (Knowledge: Linux kernel coding, hardware, wireless)


For /etc/diag.sh there are several other examples for other platforms available:
target/linux/brcm47xx/base-files/etc/diag.sh
target/linux/ramips/base-files/etc/diag.sh
target/linux/ar71xx/base-files/etc/diag.sh
target/linux/rdc/base-files/etc/diag.sh
target/linux/brcm63xx/base-files/etc/diag.sh
target/linux/rb532/base-files/etc/diag.sh
target/linux/cobalt/base-files/etc/diag.sh
target/linux/au1000/base-files/etc/diag.sh
target/linux/adm5120/base-files/etc/diag.sh
target/linux/ar7/base-files/etc/diag.sh

See you
Maddes

(Last edited by maddes.b on 12 Sep 2010, 14:17)