OpenWrt Forum Archive

Topic: Support for Marvell 88F5xx81 based routers

The content of this topic has been archived between 18 Jan 2014 and 6 May 2018. Unfortunately there are posts – most likely complete pages – missing.

Also problem with wireless WRT350N v2, same with all the OpenWRT versions starting with Backfire 3.0 and ending with Attitude Adjustment RC1. Flashed many times no change, using Upgrade and recovery image.
For some reason i cannot configure wireless channel below 11. If i set any channel below wireless radio does not turn on. Tried with all kinds of setting and it seems setting are no problemay other suggestions? The current ones what are working, but the wireless is hell slow:
config 'wifi-device' 'radio0'
        option 'type' 'mac80211'
        option 'macaddr' '00:1a:73:2e:c6:d6'
        option 'hwmode' '11ng'
        option 'htmode' 'HT40-'
        list 'ht_capab' 'SHORT-GI-40'
        list 'ht_capab' 'DSSS_CCK-40'
        option 'country' 'US'
        option 'disabled' '0'
        option 'channel' '11'
        option 'noscan' '1'
        option 'txpower' '17'
config 'wifi-iface'
        option 'device' 'radio0'
        option 'network' 'lan'
        option 'mode' 'ap'
        option 'ssid' 'ssid'
        option 'encryption' 'psk2'
        option 'isolate' '0'
        option 'bgscan' '0'
        option 'wds' '0'
        option 'key' 'key'
If i change it to eg:
config 'wifi-device' 'radio0'
        option 'type' 'mac80211'
        option 'macaddr' '00:1a:73:2e:c6:d6'
        option 'hwmode' '11g'
        list 'ht_capab' 'SHORT-GI-40'
        list 'ht_capab' 'DSSS_CCK-40'
        option 'country' 'US'
        option 'disabled' '0'
        option 'channel' '6'
        option 'noscan' '1'
        option 'txpower' '17'
luci allows to enable the wireless but the radio would not turn on and same with all the channel below 11.
And one even more strange "feature" what happened and why i want to get lower channels working, is beacuse once it worked (ch6), just once and aftre reboot it was gone already, but while it worked wifi speed was also working.
Thanks for help!

I'm brave, and it seems to work on my wrt350.

Actually, my wrt350 was rebooting from time to time, for no obvious reason - which prompted me to look for fixes.

Not yet sure if there is more stability in this version, but for now, seems fine.

OpenWrt Barrier Breaker r35896 / LuCI 0.11 Branch (0.11+svn9463)
Uptime 0h 29m 3s

Well, everything works fine on the latest release, and on maddes.b compile. Everything but wifi. Did anyone get wifi to work on any 12.09 release?? I just cant.

I have the netgear 854 and successfully loaded 10.03; the wiki page suggests that is the latest version which is supported:

The sysupgrade to 12.09 does not seem to work:
root@OpenWrt:/tmp# md5sum openwrt-wnr854t-squashfs-sysupgrade.img
1a63cda9ac132b6f9facc4fe39b0aed0  openwrt-wnr854t-squashfs-sysupgrade.img
root@OpenWrt:/tmp# sysupgrade -v openwrt-wnr854t-squashfs-sysupgrade.img
Invalid image type 8519.
Image check 'platform_check_image' failed.
root@OpenWrt:/tmp# dd if=/dev/mtd0 bs=16 count=1 | hexdump -e '1/1 "%02x"'
1+0 records in
1+0 records out

But there is an earlier post that suggests altering the magic number in might get around that:

I am not sure if that post was for a special build or else if it should work also with the release version I have downloaded.

Is there a good reason to use the later version and/or a proven way to achieve it?

Has anyone else that did a 128M memory upgrade got 12.09 running.

I have just spent a day trying to upgrade from 10.31 to 12.09

Have tried both Maddes images and "stable" all 3 ways

Sysupgrade from 10.31
Factory from 2017
Recovery using Upge207.exe

In all the tries it gets as far as

Uncomressing linux, done.... booting the kernal

and then just hangs.

I can put 10.31 and Linksys-2017 back on and they run fine.

The UBoot message still shows the patch for 128M RAM holding after all the attempts.

Does anyone have any ideas?

Totally bricked one of my two routers trying to "downgrade" uboot to 32M to see if that helped.

I can't afford to loose the 2nd one trying to install 12.09 so I am just going to have to stay on 10.03.1

I've read maddes jtag recovery posts and it seems too hard for me.

When I can afford the $ I will just by a new tp-link router and bin these ones.

Are the orion images still being built? I don't see them here:

If not, does anyone have any idea why not?

Edit: this is why: -- it's not specificallly anything to do with orion, just the buildbots not being able to build wn802t which breaks the rest

(Last edited by StrikerNL on 20 Nov 2013, 17:06)

WRT350N v2 is really strange router. Wired works with 10.3 and 12.09, but wireless...I recently changed miniPCI card with the same type (AR5008), to see if I solved wifi connection problems, but new card is detected randomly (only power off/on). After hostapd is started all network connection is lost, LEDs were still blinking, like everything is up and running.

I also checked wiki how to change miniPCI card, but this one is the same, the same drivers.

I'm looking to flash my WRT350N v2 with OpenWrt, but I wanted to have the stock firmware on hand in case I needed to go back for any reason, especially since mentions that some people experience issues with wireless performance.

Linksys no-longer provide the stock firmware for download.

Does anyone have the 2.00.19 stock firmware, and, if so, could you tell me the MD5 sum?  The firmware is available on other websites but I want to make sure what I've found is correct.

(Last edited by mavit on 8 Jan 2014, 17:21)

oOo.Manu.oOo wrote:

I switched off my router, hold on the reset button then swithc it on as described, I got the power led blinking between orange and green and finally issued this :

upslug2 -d eth1 -t 00:xx:7E:yy:D0:zz --image=openwrt-wrt350nv2-squashfs-recovery_10.03.1.bin

and got this :

openwrt-wrt350nv2-squashfs-recovery_10.03.bin: invalid file (e.g. bad signature): fatal error [std::exception]

tried this :

# upslug2 -d eth1 -t 00:xx:7E:yy:D0:zz
[no NSLU2 machines found in upgrade mode]

So was wondering if ubuntu's upslug2 is ok, then downloaded and compiled

retried and got exactly the same result.

Did you apply the patch as well? I did that and was able to attempt to flash my router. Note that the form without the --image will still give the "no NSLU2 machines found in upgrade mode" message, but with --image it works.

Except that mine doesn't work, it dies with a timeout at 4aff3f+0005c0 every time, so I think the onboard flash must have died at that address.

I compiled my linux kernel with GPIO Support enabled still /sys/class folder is not found.
My chip is RTL8197D
linux - gpio folder not found in /sys/class/ directory

Hi all!

Has installed 12.09, flight normal.

At me 128 Mb - problems are not present.


Is there any barrier breaker build for wrt250nv2 ? i've looked on the downloads and i don't see orion builds anymore?

Also anyone did wireless work for attitude_adjustment ?


See here for why it's not being built, you can try to complain on #openwrt IRC or elsewhere, maybe someone is interested in fixing it there, it seems trivial to me.

(Last edited by StrikerNL on 12 Sep 2014, 22:10)

Sorry, posts 1117 to 1125 are missing from our archive.