OpenWrt Forum Archive

Topic: Is this router based on the infineon danube?

The content of this topic has been archived between 1 Oct 2014 and 1 May 2018. Unfortunately there are posts – most likely complete pages – missing.

Anyone knows what is wrong when cat /proc/interrupts show that eth_rx is always zero?

How do i get U-Boot and OpenWrt image to recognize my 64MB memory upgrade on ARV7510PW board?

Does anybody know which OpenWrt image to use for ARV4518PW2 or at least some confirmation of the current status?

It is listed in as supported / WIP, however, I can not find and image or any other hints that show that there's some development being done on this device.

trndr wrote:

Hi, I've been tying to use the ARV7510PW images (with wiki patches) on a ARV4510PW-A (Bewan vodafone branded)
It seems like everything works, except WIFI (AR2417).
I keep getting:

PCI: Enabling device 0000:00:0e.0 (0000 -> 0002)
ath5k 0000:00:0e.0: registered as 'phy0'
ath5k phy0: unable to init EEPROM
ath5k: probe of 0000:00:0e.0 failed with error -5

Anybody able to help me with this?


I also have an ARV4510PW-A-LF-L3 (VFP). It's a Bewan modem that was distributed by Vodafone Portugal.
I think that this modem was also distributed by Vodafone in Egypt (cf this post which contains links to photos of the internals of the modem).
It's mentionned on the wiki page that such a variant exists (with Atheros AR2417 wireless chip directly soldered on the board), but the page does not mention that the switch is not an Infineon ADM6996i, but a RTL8306SD, and that the RAM chip is different too : it's a Qimonda HYB25DC256160CE-6 chip (32 MB of SDRAM 133).

So my question is, does the uboot image on the wiki page works for this modem ?
I have a doubt because at least with Chaos Calmer, uboot is compiled with support of the switch adm6996i but not rtl8306.
So perhaps uboot works, but i'm not sure Ethernet is functionnal ?
Does someone has experience with this modem, because i don't want to brick my modem, as i don't known how to enter UART mode (there's no visible pins to shortcut, like for the ARV7510PW) ?

Thank you


i am new in the forum, i have 2 routers zte zxv10 h108l and i want try to instal openwrt in it, is it worth it?
I search a litle and i found that the chip is lantiq amazon se and that exist a ase.image, is it right that?


can i use the firmware upgrade with the ase/openwrt-lantiq-ase-NONE-squashfs.image, is it safe?


I am sorry to ask like a lazy NERD, but spend already a lot of time to bring OPENWRT on my EasyBox802.

I did it as described here:

But this Wiki is very complicated to understnd. So I think unfortunately I earsed my flash.

After Point 2. Flash


Use this image when you want to put the u-boot permanently on the flash. Requires: uboot-lantiq-arv752DPW_flash

From a running u-boot (see instructions above)

1. copy flash image to ram (see steps 2-6 from above with 0x80500000 as address before executing the u-boot at address 0x80002000, download u-boot.bin, see Downloads )

2. unprotect the sector where the U-BOOT config is being stored.

protect off 0xb0010000 0xb001FFFF

2. erase the flash

erase 0xb0000000 0xb001FFFF

3. write the uploaded u-boot.bin to flash (here; 0x80500000 is the RAM adress, where i've uploaded my file)

cp.b 0x80500000 0xb0000000 10000

4. protect the config sector

protect on 0xb0010000 0xb001FFFF

5. reboot device and hope for the best :)


* If kernel ignores parameters from u-boot, remove the preceding - in linux's hardcoded cmdline 

I get only this promt

ROM VER: 1.0.3
CFG 01

Tried to solder like described in 3., but either I got CFG01 oder CFG05, but in no case CFG04 or UART Mode...

So I tried and tried and now on R80 both soldering pads are gone. Last state before they gone, I had a situtation where Bootloader-Log repeats constantly with

ROM VER: 1.0.3
CFG 01

ROM VER: 1.0.3
CFG 01
ROM VER: 1.0.3
CFG 01

No way to bridge R80 again now.

Now I cleaned everythind and got a static

ROM VER: 1.0.3
CFG 01


Is there a way to restore without soldering. Everything worked as described in Point 2, but since rebooting (as described in the last line) noting more happens...

Would love to get a quick help. Would love to use openwrt on this device

The latest trunk (Designated Driver r49395) runs quite well on the ARV7510PW with a few small patches. See for more information and a working image.

Hey guys, a dinosaur here.
I've stumbled uppon an ARV4518PW2 (branded Pirelli/ADB P.RG A4201G and NetFasteR IAD 2 PSTN by greek ISPs) and tried to run linux, to my knowledge nobody has succesfully run linux on this device. Specs are described at the toh page. Same wifi chip as ARV4518PW (ar2417), same ethernet chip as ARV7518PW and ARV752DPW22 (ar8216). Started building from source (12.09, since the flash size is very small), and after a lot of concuctions, got USB, DSL, VOIP, and lately even the WIFI working.
For the life of me I had no luck with the ethernet chip, neither on uboot nor on openwrt. Here is my uboot log:

ROM VER: 1.0.3
CFG 01
ROM VER: 1.0.3
CFG 01

U-Boot 2010.03-dirty (Dec 06 2016 - 13:18:40)

Board: ARV4518PW2
SoC: Danube/Twinpass/Vinax-VE V1.3, DDR Speed 166 MHz, CPU Speed 333 MHz
DRAM:  32 MB
Flash:  4 MB
*** Warning - bad CRC, using default environment

Net:   bring up ebu gpio
initializing ar8216 switch... Port 0, Negotiation timeout
Port 1, Negotiation timeout
Port 2, Negotiation timeout
Port 3, Negotiation timeout
eth0: Phy Specific Status=ffffb368
eth0: Phy Specific Status=ffffb368
eth0: Phy Specific Status=ffffb368
eth0: Phy Specific Status=ffffb368
failed ...
Hit any key to stop autoboot:  0
ARV4518 => printenv
bootcmd=run flash_flash
flashargs=setenv bootargs rootfstype=squashfs,jffs2
nfsargs=setenv bootargs root=/dev/nfs rw nfsroot=${serverip}:${rootpath}
addip=setenv bootargs ${bootargs} ip=${ipaddr}:${serverip}:${gatewayip}:${netmask}:${hostname}:${netdev}:off
addmisc=setenv bootargs ${bootargs} init=/etc/preinit console=ttyS1,115200 ethaddr=${ethaddr} ${mtdparts}
flash_flash=run flashargs addip addmisc;bootm ${kernel_addr}
flash_nfs=run nfsargs addip addmisc;bootm ${kernel_addr}
net_flash=run load_kernel flashargs addip addmisc;bootm ${ram_addr}
net_nfs=run load_kernel nfsargs addip addmisc;bootm ${ram_addr}
load_kernel=tftp ${ram_addr} ${tftppath}openwrt-ifxmips-uImage
update_uboot=tftp 0x81000000 ${tftppath}u-boot-ARV4518PW2.bin;era 0xb0000000 +${filesize};cp.b 0x81000000 0xb0000000 ${filesize}
update_openwrt=tftp ${ram_addr} ${tftppath}ARV4518PW2-squashfs.image;era ${kernel_addr} +${filesize};cp.b ${ram_addr} ${kernel_addr} ${filesize}
ver=U-Boot 2010.03-dirty (Dec 06 2016 - 13:18:40)

Environment size: 1277/65532 bytes
ARV4518 =>

That is with a modified uboot for the ARV4519PW, with loady and loadb, of course tftp doesn't work. In fact, connecting an ethernet cable to the switch, there is no link, and no leds light up. The mac address on the enviroment is correct.

Here's what openwrt reports when booting:

[    0.420000] ltq_mii: probed
[    0.420000] (unregistered net_device): no PHY found
[    0.428000] etop: mdio probe failed

Then again, ifconfig eth0 reports the same, correct, mac address as uboot does, but no link. The image was for the ARV4518PW, but was built with the drivers for the ar8216. Everything else works

If you want the link for my uboot images and a very basic openwrt build, please PM. I am not allowed to post links here.
I can build more images with more(or less) features if anyone wants them.
Any help on making the ethernet work would be greatly appreciated! smile

(Last edited by Ntalton on 7 Dec 2016, 21:40)

Hello Ntalton
I just try to boot openwrt on a ARV4518PW2 board.

I am new to openwrt but have good linux knowledge.
First I tried from brnboot  to write mem [m] and goto [y] to no avail.
Then  I flashed the uboot image ffrom
  and booted the uboot (dirty).

As I want to avoid flashing, is there any way from here to
a) boot openwrt images from uart/itfp
b) boot another uboot from uart/tftp ?

Also i would be gratefull if you could send me some hepliing information in order to setup a build environment to try and build new images.


(Last edited by basos.g on 4 Nov 2017, 17:41)

The discussion might have continued from here.