OpenWrt Forum Archive

Topic: Is this router based on the infineon danube?

The content of this topic has been archived between 1 Oct 2014 and 1 May 2018. Unfortunately there are posts – most likely complete pages – missing.

I apologize if this isn't the most appropriate forum.
My isp, in spain, supplies an smc wireless router. It's called SMC-7908-ISP, has a customized version of the firmware and there's virtually no documentation available on the net. It has an adsl port, a 4 port ethernet switch, wireless and 2 FXS ports.
I opened it and took some photos, unfortunately the main chip is covered with a glued-in heatsink.


As you can see in the wireless chip is an atheros 2417 (3rd photo), the switch is a realtek (2nd photo) and there's not much else there.
I suppose it's a danube because the firmware file (that I cannot decipher) it's called "", and there are references to DANUBE inside (e.g. there's an embedded zip file with a "DANUBE_2." file).
On the second photo you can see a J2 header that's probably a serial port.
Do you think it's really based on the danube chipset? If so it should be possible to run openwrt on it, though I won't have the possibility to experiment too much since the device will be providing my main phone line (through its FXS ports).

I got here looking for information about the same router and its internal parts. A great thing of it is that the memory chip is 512 DDR chip PSC A3S12D40ETP, but I don't know id the router chipset is supporting that whole amount of memory.

Anyway it looks like they are already working on this platform, let's hope it will be working soon and convert this router with a really old looking firmware to a great piece of firmware.

With a USB 2.0 port in it, a lot of RAM, VoIP with two FXS ports, and Atheros WiFi chipset, it could be a complete powerful communication center.

Hi sblanco, since I wrote that message I managed to connect a serial port (the pinout is the same as described at … ware.html) and effectively it's based on the danube chip according to the bootlog.
OTOH I couldn't find too much documentation about danube in general and what openwrt can do with it (apart from this bug, but I suppose that the openwrt port is based on an infineon reference design ( … teway.html), and the 7908 deviates from it since it has a different switch (a realtek rtl8306sd instead of the reference infineon adm6996ix), has a different bootloader (the shitty "brn bootloader" disguised as arcadyan bootloader) and it doesn't run Linux.

Oh, and if you want to play with the firmware, somebody has uploaded it to megaupload:

The program sp300ex (which, btw, runs fine under wine) available at … nload.html is capable of splitting the bin file into its individual components, however the kernel and the pfs image use a different compression (they're not a simple zip anymore) and I couldn't find a way to decompress those files (I tried writing simple programs trying to uncompress the data part, after stripping the 0x21 0x43 0x65 0x87 signature bytes at the beginning, as lzma, lzo, deflate, bzip2) with no success.
I supposed it shouldn't be a too complex compression (since it has to be decompressed by the bootloader), but I cannot make sense of it.
It would be interesting to at least recover the file system to see what hidden pages are there (like, e.g.  undoc_upgrade.stm or production.stm, the usb related ones are not really hidden since you can find them in the javascript).

Hi pippolippi,

Do you know if any further development was done on this router? I have one and I really would like to have it available for openwrt.



The devs (blogic) are still working on it but, AFAIK, there's no public release yet.

Hi guys,

Does anybody know if this project is moving forward or will be obsolete? I bought one of these devices, hoping that it will be a perfect host for openwrt, but it looks like it is going to be forgotten (if it is not already). Could somebody suggest an alternate router which has similar architecture?
What I need:

- Atheros wifi
- USB 2.0
- Big enough RAM
- Above average processor speed
- Openwrt compatibility

I know WL500gp v1 with a Wistron CM9 atheros mini-pci card meets my requirements, but it is too expensive. I'm looking for something similar to this SMC, but with better support.


Well, I don't really think it's moving forward. I'd love to be proved wrong though (the stock firmware is such a piece of s***).


There is infineon danube support with open DSL and VOIP drivers in the new backfire version.

Has anybody tried it?


No support for the smc7908/astoria arv4518pw unless blogic can get one to test.

I've two of them and I'll receive a new one because the firmware is such a piece of s*** (you're completely right, pippolippi), every week it hangs at least for two times and they prefer to send me a new one instead of fixing the problem ...

Firmware is always the same, but they don't know that I know that ...

Maybe I can send one of them to blogic or
he can just let me know how to perform installation ...

I'm a SW engineer, so both ideas are ok for me ... ;-)

As I have 2 and I'll have 3, maybe I just try to install the new backfire version ...

vpablos wrote:

Maybe I can send one of them to blogic or
he can just let me know how to perform installation ...

Yes, try to get in contact with him.
Regarding your other messages, nobody managed to boot openwrt on this router yet.

I've found that it's supported:

there are config files for 2.6.30, 2.6.32 and 2.6.33

and that they can even boot root from nfs … be/bootlog

uboot-ifxmips source code (there are much more things there): … e/danube.c

There are some web pages more updated than others, but no info on how to install

I'll try to get in contact with him

blogic and ralph have been working on it, since
there are commits 3 months and 3 days ago: … ips/danube

Although work on uboot-ifxmips for danube is 9 months old: … ifx/danube

There is a commit adding voip support: … 49085ccf6c

Some other threads on the topic:

I think I have found the perfect place for asking: … devel/5607

And my email asking for information ... … 06956.html

I'll let u know if we succeed on this operation.

By the way, I've seen that one of them (1 year old) is:

SMC Networks

while the other one is:

Astoria Networks

the only difference seems to be the firmware version,
and indeed some people have installed the newest firmware
on the oldest one, but I'm not really sure.


... pls note that the uboot-lantiq package is now replacing the uboot-ifxmips

I've build a serial cable and I've access to the bootloader. Writting "!" at the bootloader prompt shows options to upload to RAM (M) using XModem. The standard linux tools doesn't work since the bootloader (is called BRN) uses a variant of XModem which changes the original 8-bit checksum by a 16-bit CRC in big endian format.

I've developed a custom tool to upload the firmware; now the bootloader accepts the firmware and ask me if I want to boot it. I've tried to load uboot-lantiq.bin image and openwrt-ifxmips-uImage but none boot. Now I'm trying to build my own raw vmlinux image.

I'll inform of futher progress.

... any logs from the boot attempt ?

blogic now has one of these units.
A couple of weeks ago he told me it's basically working.

vmlinux image doesn't work either. I get this output:

ROM VER: 1.0.3
CFG 01
ROM VER: 1.0.3
CFG 01

Wireless ADSL Gateway DANUBE Loader 64M-V0.02 build Apr 24 2008 16:12:25
                    Arcadyan Technology Corporation
MXIC MX29LV320ABTC bottom boot 16-bit mode found

Copying boot params.....DONE

Press Space Bar 3 times to enter command mode ...123
Yes, Enter command mode ...

[DANUBE Boot]:!

Enter Administrator Mode !

 [u] Upload to Flash  
 [E] Erase Flash      
 [G] Run Runtime Code 
 [M] Upload to Memory 
 [R] Read from Memory 
 [W] Write to Memory  
 [T] Memory Test      
 [Y] Go to Memory     
 [A] Set MAC Address 
 [#] Set Serial Number 
 [V] Set Board Version 
 [h] Set Options 
 [P] Print Boot Params 
 [0] Use Normal Firmware
 [1] Use ART-Testing Firmware


RAM upload destination: (default:0x80002000) : 0x
Starting XModem download...(press Enter to abort)
Do you want to execute the uploaded code? (Y/n) Y
Jump to address 0x80002000 ...

Next I will try to develop an small PIE program that just toggles a led.

(Last edited by unaiur on 10 Jul 2010, 17:07)

Hi everyone,

How are things going with this router? This is the first post of mine, because I haven't found enough information on how to use OpenWRT with this router (I have an SMC7908A-ISP).

I've had no problems on using OpenWRT with other routers: Fonera, Comtrend CT536, and Livebox. But with this one I'm not able of doing anything with the information that is available, at least for my knowledge, maybe for others it's enough.

So far I've only been able to open the router and find the J2 connector, which I guess is the serial conector. But that's it. Could anyone be so kind as to explain how to proceed from this point on?

Thanks in advance.